Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Kura » Kura 3.2.0 and Java 9(system requirement, openjre)
Kura 3.2.0 and Java 9 [message #1787082] Fri, 18 May 2018 14:43 Go to next message
Matteo Palmieri is currently offline Matteo PalmieriFriend
Messages: 6
Registered: December 2015
Junior Member
Hi,

I'm looking into Eclipse Kura 3.2.0 to use with OpenJRE 9.
Is this combination already supported or still work in progress?

Among the other benefit is a footprint reduction expected due to the "java 9 module" feature? Otherwise what are minimum RAM requirements for Kura 3.2.0 + OpenJRE9?

Thanks

Matteo
Re: Kura 3.2.0 and Java 9 [message #1787092 is a reply to message #1787082] Fri, 18 May 2018 16:50 Go to previous messageGo to next message
Benjamin Cabé is currently offline Benjamin CabéFriend
Messages: 201
Registered: July 2009
Location: Toulouse, France
Senior Member

Kura 3.2.0 won't work on Java 9, however, I am in the process of submitting a pull request that will allow Kura to run on Java 9.

Re: Kura 3.2.0 and Java 9 [message #1787218 is a reply to message #1787092] Tue, 22 May 2018 09:01 Go to previous message
Benjamin Cabé is currently offline Benjamin CabéFriend
Messages: 201
Registered: July 2009
Location: Toulouse, France
Senior Member

The latest nightly builds of Eclipse Kura 3.3.0-SNAPSHOT now include support for Java 9. It would be great to get your feedback!

See: https://ci.eclipse.org/kura/job/kura-develop/lastSuccessfulBuild/artifact/kura/distrib/target/


[Updated on: Tue, 22 May 2018 09:02]

Report message to a moderator

Previous Topic:Can't unblock ports in Kura Firewall
Next Topic:Calling the Kura API methods?
Goto Forum:
  


Current Time: Sun Sep 23 07:20:12 GMT 2018

Powered by FUDForum. Page generated in 0.01354 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top