Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Sirius » Problem in Filters function (Filter)
Problem in Filters function [message #1785508] Mon, 16 April 2018 05:41 Go to next message
Bo Zhang is currently offline Bo ZhangFriend
Messages: 19
Registered: July 2017
Junior Member
I found a problem when I use Filter in Sirius. I'm not sure is it a bug or it is the default design.

Step for reproduce the problem:
1. Define a Mapping Filter and a Selection Wizard Filter(Variable Filter-Select Model Element Variable) in odesign.
2. Enable the Mapping Filter in the diagram.
3. Select the Selection Wizard Filter, then press 'Cancel' or close this wizard.
Then the Mapping Filter will be unselected.

In step 3, I only canceled the Selection Wizard Filter, not did any operation for mapping filter, but it effected the mapping filter.
There is also a problem if multi-mapping filters already enabled when user cancel a Selection Wizard.

So please check this problem. This problem occurs when I used Sirius 4.1.2 and Obeo Diesigner 10.1(Sirius 5.1.1).
Re: Problem in Filters function [message #1785614 is a reply to message #1785508] Tue, 17 April 2018 14:04 Go to previous messageGo to next message
Pierre Guilet is currently offline Pierre GuiletFriend
Messages: 161
Registered: June 2017
Senior Member
Hi,

I consider the behaviors you describe as bugs. I did a ticket: https://bugs.eclipse.org/bugs/show_bug.cgi?id=533688

Regards,


Pierre Guilet - Obeo
Need training or professional services for Sirius?
http://www.obeodesigner.com/sirius
Re: Problem in Filters function [message #1786030 is a reply to message #1785614] Tue, 24 April 2018 10:59 Go to previous message
Bo Zhang is currently offline Bo ZhangFriend
Messages: 19
Registered: July 2017
Junior Member
Hi,
I check the source code:
http://git.eclipse.org/c/sirius/org.eclipse.sirius.git/tree/plugins/org.eclipse.sirius.diagram.ui/src-diag/org/eclipse/sirius/diagram/ui/tools/internal/handler/ChangeFilterActivation.java

In line 157
ConcernService.setCurrentConcern(diagram, oldConcern); in this function clears the activated Filters.
So I add some codes after it, add the activatedFiltersCopy.
if (activatedFiltersCopy.size() > 0) {
activatedFilters.addAll(activatedFiltersCopy);
}
It works well now.
But I'm not sure is it right, and I don't know do I need to deal rules and behaviors.
Please give me some suggestions.
Thank you.

[Updated on: Tue, 24 April 2018 11:01]

Report message to a moderator

Previous Topic:issue with the Reference widget in the properties view
Next Topic:Delete item from custom widget of property page with toolbar button
Goto Forum:
  


Current Time: Mon Sep 24 03:18:54 GMT 2018

Powered by FUDForum. Page generated in 0.01867 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top