Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » AJDT » With eclipse 4.8 it's not working
With eclipse 4.8 it's not working [message #1785393] Fri, 13 April 2018 12:48 Go to next message
Andreas  Hoehmann is currently offline Andreas HoehmannFriend
Messages: 14
Registered: July 2009
Location: Leipzig
Junior Member
Hello guys,

I try to install AJDT from

AspectJ features and related tools - http://download.eclipse.org/tools/ajdt/47_aj9/dev/update

But I got an error:

Cannot complete the install because of a conflicting dependency.
Software being installed: AspectJ Development Tools 2.2.4.201803261956 (org.eclipse.ajdt.feature.group 2.2.4.201803261956)
Software currently installed: Eclipse Java Development Tools 3.14.0.v20180314-2000 (org.eclipse.jdt.feature.group 3.14.0.v20180314-2000)
Only one of the following can be installed at once:
Java Code Manipulation Functionality 1.9.100.v20171116-1149 (org.eclipse.jdt.core.manipulation 1.9.100.v20171116-1149)
Java Code Manipulation Functionality 1.10.0.v20180302-1956 (org.eclipse.jdt.core.manipulation 1.10.0.v20180302-1956)
Cannot satisfy dependency:
From: AspectJ Development Tools 2.2.4.201803261956 (org.eclipse.ajdt.feature.group 2.2.4.201803261956)
To: org.eclipse.equinox.p2.iu; org.eclipse.ajdt.ui [2.2.4.201803261956,2.2.4.201803261956]
Cannot satisfy dependency:
From: AspectJ Development Tools UI 2.2.4.201803261956 (org.eclipse.ajdt.ui 2.2.4.201803261956)
To: osgi.bundle; org.eclipse.jdt.core.manipulation [1.3.0,1.10.0)
Cannot satisfy dependency:
From: Eclipse Java Development Tools 3.14.0.v20180314-2000 (org.eclipse.jdt.feature.group 3.14.0.v20180314-2000)
To: org.eclipse.equinox.p2.iu; org.eclipse.jdt.core.manipulation [1.10.0.v20180302-1956,1.10.0.v20180302-1956]

Can anyone help me? :D

Ciao
Andreas
Re: With eclipse 4.8 it's not working [message #1785397 is a reply to message #1785393] Fri, 13 April 2018 13:13 Go to previous messageGo to next message
Andreas  Hoehmann is currently offline Andreas HoehmannFriend
Messages: 14
Registered: July 2009
Location: Leipzig
Junior Member
org.eclipse.jdt.core.manipulation version 1.10.0.v20180302-1956 is installed in my eclipse ... could it be that ajdt need 1.9.0 here or what? I don't understand it :)
Re: With eclipse 4.8 it's not working [message #1785488 is a reply to message #1785397] Sun, 15 April 2018 07:43 Go to previous messageGo to next message
Andreas  Hoehmann is currently offline Andreas HoehmannFriend
Messages: 14
Registered: July 2009
Location: Leipzig
Junior Member
http://git.eclipse.org/c/ajdt/org.eclipse.ajdt.git/tree/org.eclipse.ajdt.core/META-INF/MANIFEST.MF?h=e47_aj9 says
RequiredBundle org.eclipse.jdt.core.manipulation;bundle-version="[1.3.0,1.10.0)"
Why is "1.10.0.v20180302-1956" not correctly interpreted?
Anyone knows why?
Re: With eclipse 4.8 it's not working [message #1785489 is a reply to message #1785488] Sun, 15 April 2018 07:45 Go to previous messageGo to next message
Andreas  Hoehmann is currently offline Andreas HoehmannFriend
Messages: 14
Registered: July 2009
Location: Leipzig
Junior Member
Found on https://dzone.com/articles/manifestmf-and-featurexml this

A "half-open" range, such as [1.2.3,2.0.0), which has an inclusive lower limit and an exclusive upper limit, denoting version 1.2.3 and any version after this, up to, but not including, version 2.0.0.

So 1.10.0 is not included? So I need a < 1.10.0 ?

Can anyone provide a

http://download.eclipse.org/tools/ajdt/48/dev/update

with dep to org.eclipse.jdt.core.manipulation >= 1.10.0?

:D
Re: With eclipse 4.8 it's not working [message #1787325 is a reply to message #1785489] Wed, 23 May 2018 17:53 Go to previous messageGo to next message
Alex Lara Garachana is currently offline Alex Lara GarachanaFriend
Messages: 2
Registered: May 2018
Junior Member
Anyone found a solution?
... it works with photon (4.8) M5 BUT does not work for photon (4.8) > M5; M6 & M7
Re: With eclipse 4.8 it's not working [message #1789849 is a reply to message #1787325] Thu, 31 May 2018 04:57 Go to previous messageGo to next message
Alex Lara Garachana is currently offline Alex Lara GarachanaFriend
Messages: 2
Registered: May 2018
Junior Member
Fixed at PHOTON RC1
... there's a new eclipse 4.8 update repo: http://download.eclipse.org/tools/ajdt/48/dev/update
Re: With eclipse 4.8 it's not working [message #1789907 is a reply to message #1789849] Thu, 31 May 2018 16:30 Go to previous messageGo to next message
Sara Belaid is currently offline Sara BelaidFriend
Messages: 2
Registered: May 2018
Junior Member
http://download.eclipse.org/tools/ajdt/48/dev/update
Re: With eclipse 4.8 it's not working [message #1794857 is a reply to message #1789907] Sat, 08 September 2018 08:20 Go to previous message
mini jon is currently offline mini jonFriend
Messages: 1
Registered: September 2018
Junior Member
I try to install AJDT.1.10.0.v20180302-1956 is installed .Is it work?
Previous Topic:Eclipse Java development tools (JDT) for all
Next Topic:LTW not working in Eclipse Juno
Goto Forum:
  


Current Time: Mon Nov 19 20:37:44 GMT 2018

Powered by FUDForum. Page generated in 0.02045 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top