Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Plug-in install on other Eclipses(Trying to install my plugin on other Eclipses but not istalling due to missing requirements)
Plug-in install on other Eclipses [message #1785285] Thu, 12 April 2018 06:32
Vivek Selvaraj is currently offline Vivek SelvarajFriend
Messages: 1
Registered: April 2018
Junior Member
I have an Eclipse plugin project with me. I am trying to make it install on to other eclipses. I created a feature and an update site for the feature. Tried installing using the update site. The error thrown was

Cannot complete the install because one or more required items could not be found.
Software being installed: Feature 1.0.0.201804121118 (com.example.eclipse.feature.feature.group 1.0.0.201804121118)
Missing requirement: Plugin 1.0.0.201804121118
(com.example.eclipse.plugin 1.0.0.201804121118) requires 'bundle org.eclipse.nebula.widgets.grid 0.0.0' but it could not be found
Cannot satisfy dependency:
From: Feature 1.0.0.201804121118
(com.example.eclipse.feature.feature.group 1.0.0.201804121118
To: com.example.eclipse.plugin [1.0.0.201804121118]

The plugin works fine when I run the plugin project as an Eclipse Application. But when installing I face these issues. Please let me know how to include the missing requirements with my plugin

Previous Topic:No Application Id found
Next Topic:MultiPageEditorPart not found when testing RCP app
Goto Forum:
  


Current Time: Sat Sep 22 09:18:05 GMT 2018

Powered by FUDForum. Page generated in 0.02134 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top