Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » BIRT Runtime Error(unsupported class version error)
BIRT Runtime Error [message #1784879] Thu, 05 April 2018 06:51 Go to next message
jatin grover is currently offline jatin groverFriend
Messages: 2
Registered: April 2018
Junior Member
Hello, I am new to BIRT, and i am trying deploy BIRT using Tomcat installed on a server. i downloaded BIRT Runtime and so i copied WebViewerExampe in Webapps folder of the tomcat

when i tried to run it , it shows this error:-
SEVERE: Exception sending context initialized event to listener instance of class org.eclipse.birt.report.listener.ViewerServletContextListener
java.lang.UnsupportedClassVersionError: org/eclipse/core/runtime/CoreException : Unsupported major.minor version 52.0 (unable to load class org.eclipse.core.runtime.CoreException)

the java version on server is jdk1.7
The link from where i downloaded this BIRT Runtime says that the pre- requisite is jdk 1.7 only

I amdont understand and i am unable to find a solution, please help?
Re: BIRT Runtime Error [message #1786038 is a reply to message #1784879] Tue, 24 April 2018 15:21 Go to previous message
Dave Skura is currently offline Dave SkuraFriend
Messages: 1
Registered: April 2018
Junior Member
I had this same exact problem.

tomcat appears to work, but the deploy of BIRT always failed.

For me, I solved it by setting my JAVA_HOME variable to
C:\Program Files\Java\jdk1.8.0_171

after that, it deployed.

good luck.
Previous Topic:How to set the printing direction of the column area of a cross tab on pages when using an interval
Next Topic:Fill by pattern on the fly
Goto Forum:
  


Current Time: Sat Nov 17 19:46:28 GMT 2018

Powered by FUDForum. Page generated in 0.02519 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top