Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » 4DIAC - Framework for Distributed Industrial Automation and Control » Problem with Publisher/subscriber (is it possible that more than one publishers use the same ID?)
Problem with Publisher/subscriber [message #1784712] Tue, 03 April 2018 07:24 Go to next message
Barry wan is currently offline Barry wanFriend
Messages: 36
Registered: July 2017
Member
Dear all,
I want to design a one-to-more communication at same time.
considering the loose-coupled, the pub/sub mode is suitable,(socket is close-coupled). So I try to test whether it is possible that more than one publishers use the same ID?
When these publisher work at same time ,the subscriber only receive the last message as follows Fig shown.
1、is there any other solutions?
2、the different between FB "PUBLxxx" and"PUBILISHxxx"?
3、the"PUBLxxx"can not work well.
Re: Problem with Publisher/subscriber [message #1784728 is a reply to message #1784712] Tue, 03 April 2018 09:51 Go to previous messageGo to next message
Alois Zoitl is currently online Alois ZoitlFriend
Messages: 635
Registered: January 2014
Senior Member
I would have expected that all messages would be sent. However we have some issues if several messages are received at the same time. Can you check with wireshark how many messages are sent?

The PUBL blocks are an implementation of the local multicast design pattern [1]. They can only be used to communicate within the same device.

[1] http://www.holobloc.com/doc/despats/publsubl/index.htm
Re: Problem with Publisher/subscriber [message #1785028 is a reply to message #1784728] Sun, 08 April 2018 06:55 Go to previous messageGo to next message
Barry wan is currently offline Barry wanFriend
Messages: 36
Registered: July 2017
Member
Dear Prof. Alois Zoitle
thank you for your reply.
Four messages are sent, however only one message received.
Re: Problem with Publisher/subscriber [message #1785071 is a reply to message #1785028] Mon, 09 April 2018 07:08 Go to previous messageGo to next message
Alois Zoitl is currently online Alois ZoitlFriend
Messages: 635
Registered: January 2014
Senior Member
Thanks for finding this out. Then I assume that the operating system is combining all four messages into one notification to forte. Currently we do not handle this very well. It is also not very easy to debug.

Just out of curiosity if you add an E_DELAY between sending of your four messages (maybe 100 to 200 ms) does this change anything?
Re: Problem with Publisher/subscriber [message #1785580 is a reply to message #1785071] Tue, 17 April 2018 07:30 Go to previous messageGo to next message
Barry wan is currently offline Barry wanFriend
Messages: 36
Registered: July 2017
Member
Thank you ! it's ok when using a delay.
Re: Problem with Publisher/subscriber [message #1785591 is a reply to message #1785580] Tue, 17 April 2018 09:28 Go to previous message
Alois Zoitl is currently online Alois ZoitlFriend
Messages: 635
Registered: January 2014
Senior Member
Ok that helps to track down the issue. We anyhow have planed for the near future to rework the network infrastructure to better handle message bursts. This is one test case we should then consider.
Previous Topic:Adding a custom function block inside forte RTE (C Code)
Next Topic:Is IEC 61499 is suitable for discrete manufacturing?
Goto Forum:
  


Current Time: Mon Sep 24 15:27:47 GMT 2018

Powered by FUDForum. Page generated in 0.02615 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top