Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Support for Java 9 in non-beta main version(Support for Java 9 in non-beta main version)
Support for Java 9 in non-beta main version [message #1784006] Wed, 21 March 2018 13:17 Go to next message
Jukka Wallenius is currently offline Jukka WalleniusFriend
Messages: 1
Registered: March 2018
Junior Member
Hello!

I have been using Eclipse for a couple of years for Java. I also teach Java programming for students. I have myself been quite happy with the functionality offered by Eclipse.

However, I have been hearing lately a lot the question that when will Eclipse support new Java versions 9 (or 10 for that matter). The Beta version worked fine with Java 9.0.1 but ceased to function with new Java 9 versions such as 9.0.4.

When do you think Eclipse will support Java 9?
Re: Support for Java 9 in non-beta main version [message #1784111 is a reply to message #1784006] Thu, 22 March 2018 15:52 Go to previous message
Stephan Herrmann is currently offline Stephan HerrmannFriend
Messages: 1650
Registered: July 2009
Senior Member
From a JDT developers p.o.v. Java 9 support is stable, Java 10 support is being finalized as we speak.

I'm aware that people "in the wild" have problems, but we can only speak about those, if we have corresponding bug reports. Feel free to search bugzilla, for open bugs against JDT marked with "[9]" or "[10]" in the title.
If you observe problems that don't appear in such search, please file new bug reports, otherwise I will continue stating "Java 9 support is stable" even if you observe differently :)

On a special note: there may be differences in how well Java 9 is supported by just JDT vs. the cooperation / integration with your favorite build tool. The need for such cooperation is much more crucial in Java 9 than it was for previous versions, but that's in the nature of Java 9.

cheers,
Stephan
Previous Topic:Unable to load Tool package
Next Topic:problem to open Eclipse Oxygen-Error : Could not create the Java Virtual Machine
Goto Forum:
  


Current Time: Wed Nov 14 07:32:57 GMT 2018

Powered by FUDForum. Page generated in 0.02014 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top