Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » 4DIAC - Framework for Distributed Industrial Automation and Control » Did not correctly import old projects (1.8.4) into 1.9.0(How i must correctly Import old Projects?)
Did not correctly import old projects (1.8.4) into 1.9.0 [message #1783980] Wed, 21 March 2018 05:49 Go to next message
Evgeniy Mityukov is currently offline Evgeniy MityukovFriend
Messages: 10
Registered: March 2018
Junior Member
I have an issue about Import old projects into 1.9.0 RC2
If i choose: "Import -> Existing Projects into Workspace" when files put to my workspace, all of them. If i start to edit App, when changes did not save to ****.sys, bus in ".project" and in "virtualDNS.dns" new data saved. After restart IDE all changed data is lost, sys file did not edited by IDE.
How i must correctly Import old Projects?
Re: Did not correctly import old projects (1.8.4) into 1.9.0 [message #1784127 is a reply to message #1783980] Thu, 22 March 2018 17:05 Go to previous messageGo to next message
Alois Zoitl is currently offline Alois ZoitlFriend
Messages: 631
Registered: January 2014
Senior Member
This would be the correct way for doing this. Could you be so kind and have a look into the .log file which is located in the .metadata directory of your 1.9.0 RC2 workspace. Also it would be extremely helpful if you could enable automatic error reporting under "Window->Preferences->General->Error Reporting". This gives us directly the occurred exceptions in an database.
Re: Did not correctly import old projects (1.8.4) into 1.9.0 [message #1784161 is a reply to message #1784127] Fri, 23 March 2018 05:56 Go to previous messageGo to next message
Evgeniy Mityukov is currently offline Evgeniy MityukovFriend
Messages: 10
Registered: March 2018
Junior Member
I enable automatic error reporting, but this is not error, no error messages. Before I wait your answer i`m continue with experiments, and i found a solution how to correct import old projects:

1. First, you need to prepare the IDE by adding all the used in old project libraries that were in the previous version to TypeLibrary.
2. Create a new System with the same name as the old project.
3. Delete all new TypeLibrary automatically added by IDE. I use typelibrary via links to ECLIPSE_HOME, do it for project.
4. Important step! Without with step project did not saved. In System Configuration, add Device and Segment ( i`m use Ethernet ) - without this project will not be saved to the file after close IDE.
5. Close the IDE.
6. In Explorer, take the old project file *.sys and *.dns and copy them to the new project. In System Configuration early added Device and Segment (step 4) will overwrited (even the color).
7. Run the project, make a minor change to any app and make sure that the project is saved to a file *.sys. You also need to make a change in dns.
8. Happy with your new imported project.

[Updated on: Fri, 23 March 2018 05:58]

Report message to a moderator

Re: Did not correctly import old projects (1.8.4) into 1.9.0 [message #1784244 is a reply to message #1784161] Sat, 24 March 2018 12:41 Go to previous messageGo to next message
Alois Zoitl is currently offline Alois ZoitlFriend
Messages: 631
Registered: January 2014
Senior Member
This is very strange. I just did a quick test with the examples coming with 4daic 1.8.4. I opend them in 1.8.4 saved them so that the sys file is in the 1.8.4 project, and then imported them into my 1.9.0 RC2 (with some nightly updates). This worked as it should be for both copy into workspace and leaving the project in the original workspace and just linking them into my 1.9.0 RC2 workspace.

If you like you can add the our experimental update site [1] to your RC2 and update to the latest fixes done for the 1.9.0 release. Please be aware that this feature is experimental and may break your 4diac installation.

[1] http://download.eclipse.org/4diac/nightly/update
Re: Did not correctly import old projects (1.8.4) into 1.9.0 [message #1784285 is a reply to message #1784244] Mon, 26 March 2018 09:52 Go to previous messageGo to next message
Evgeniy Mityukov is currently offline Evgeniy MityukovFriend
Messages: 10
Registered: March 2018
Junior Member
Alois Zoitl wrote on Sat, 24 March 2018 12:41
This is very strange. I just did a quick test with the examples coming with 4daic 1.8.4. I opend them in 1.8.4 saved them so that the sys file is in the 1.8.4 project, and then imported them into my 1.9.0 RC2 (with some nightly updates). This worked as it should be for both copy into workspace and leaving the project in the original workspace and just linking them into my 1.9.0 RC2 workspace.

May be if you have projects in workspace it will work? I have projects not in my workspace at 1.8.4.
Re: Did not correctly import old projects (1.8.4) into 1.9.0 [message #1784292 is a reply to message #1784285] Mon, 26 March 2018 10:45 Go to previous messageGo to next message
Alois Zoitl is currently offline Alois ZoitlFriend
Messages: 631
Registered: January 2014
Senior Member
Quote:
May be if you have projects in workspace it will work? I have projects not in my workspace at 1.8.4.

Tried this now as well and it worked for me.

The only thing that is not imported are segment colors. The reason for that is that 1.8.4 is not storing them.

Would it be possible to share a project with us (or me privately) for testing?
Re: Did not correctly import old projects (1.8.4) into 1.9.0 [message #1784574 is a reply to message #1784292] Thu, 29 March 2018 12:46 Go to previous messageGo to next message
Evgeniy Mityukov is currently offline Evgeniy MityukovFriend
Messages: 10
Registered: March 2018
Junior Member
Here simple project for testing.
Another reason is typelibrary maded by Links to ECLIPSE_HOME?

[Updated on: Thu, 29 March 2018 14:30]

Report message to a moderator

Re: Did not correctly import old projects (1.8.4) into 1.9.0 [message #1784577 is a reply to message #1784574] Thu, 29 March 2018 14:12 Go to previous messageGo to next message
Alois Zoitl is currently offline Alois ZoitlFriend
Messages: 631
Registered: January 2014
Senior Member
Ah that's explaining the problem. Yes we currently are not handling typed libraries with relative linked content correctly. I think this is in general a hard point to do. With 4diac we decided that each project has its own typelibrary. This has some advantages regarding versioning, copying. however it has the drawback that we get quite some duplicated files. I have no clear answer how we should proceed here. But getting feedback from our users on their requirements and use cases is a valuable feedback for our thinking process.

Coming back to your import problem. I could imagine that when you synch your 1.8.4 tool lib with the 1.9 that the importing should also work for you.

If you are on Linux you could even think about moving the tool lib to a central place and link it into your eclipse home directory. Not sure if this works in windows.

Just while I'm typing I got this idea: would it be easier for you if a project's typelib would be in a dedicated subdirectory of a project (e.g., typelib) as it is shown in the project explorer. Then linking the typelib into the project would be much easier and we could even add an option for that into the advanced section of the project creation wizard.
Re: Did not correctly import old projects (1.8.4) into 1.9.0 [message #1784580 is a reply to message #1784577] Thu, 29 March 2018 14:29 Go to previous messageGo to next message
Evgeniy Mityukov is currently offline Evgeniy MityukovFriend
Messages: 10
Registered: March 2018
Junior Member
I`m Windows user.
Your idea: do you mean PROJECT_LOC location?
Our idea for use ECLIPSE_HOME location is one TypeLibrary for many projects. Don`t need to dublicate many files, and don`t need to update as example one changed type in all project locations. Imagine if one change need to update 100 projects. What`s why we use link to ECLIPSE_HOME, where typelibrary directory already exist.
Anyway, we are already imported all our old projects in 1.9.0 RC3 IDE with steps as i described above few posts earlier. This may be useful for other users as a hint.
Re: Did not correctly import old projects (1.8.4) into 1.9.0 [message #1784584 is a reply to message #1784580] Thu, 29 March 2018 15:02 Go to previous message
Alois Zoitl is currently offline Alois ZoitlFriend
Messages: 631
Registered: January 2014
Senior Member
I expected that use case. I different solution for your use case would be to put your common type library into version control system (e.g., git) and clone it into your project. You can easily add git support to 4diac and then commit all the changes into this common repo. This has the further advantage that you can more easily and structured share this between the members of your team. The problem only is that you may also want to check in your projects as well and this is with the current typelib and project setup not as easy as it could be.

That brings me to my last idea from above:
If you look at the current file structure in a 4diac project it look something like this:
project 
   |- project.sys
   |- virtualdns.xml
   |- events
   |- iec61311
   |- ...


so in order to check in your typelib into a repo you could only do it with git submodules and by using one dedicated directory in your typelib. My Idea was to change the structure of projects as follows:
project 
   |- project.sys
   |- virtualdns.xml
   |- typelibrary
        |- events
        |- iec61311
        |- ...


With that you could very easily put the whole typelib into a repo or link the whole typelib to a common place like you are doing it.

I'm curios what you and others think about this as potential change for the 1.10 release.

P.S.: yes this has some backward compatibility issues but I think this could be solved in some code which would check for the typelib directory and if not present create one and move all directories into this lib on project opening/import.



Previous Topic:Distributed application error
Next Topic:Issue with IEC 61131-3 FIND (string conversion) function block
Goto Forum:
  


Current Time: Tue Sep 18 20:02:22 GMT 2018

Powered by FUDForum. Page generated in 0.02620 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top