Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » OCL » Failed to set 'self' context(Failed to set 'self' context)
Failed to set 'self' context [message #1783915] Tue, 20 March 2018 10:39 Go to next message
Bruce Trask is currently offline Bruce TraskFriend
Messages: 58
Registered: July 2009
Member
Hello,

I am walking through the online documentation on OCL.

I had a quick question on the Getting Started part.

I am executing the steps:

"You may evaluate custom OCL queries interactively. From the editor for Tutorial.xmi, invoke OCL->Show Xtext OCL Console from the context menu. Select Book b2 in the editor, then in the bottom line of the console enter the OCL expression loans.member and then Enter. The results are shown in the panel and identify that all three loans are by Member m3."

When I execute this I get a dialog box "OCL Console Selection Error" - Failed to set 'self' context. Reason: org.eclipse.xtext.completeocl.utilities.CompleteOCLASResourceFactory.getASElement

Also I see on the console:

Diagnostic ERROR source=org.eclipse.ocl.examples.debug.evaluation code=120 Execution failed data=[org.eclipse.ocl.examples.debug.vm.utils.VMRuntimeException: Execution failed]
[Java cause:]
org.eclipse.ocl.examples.debug.vm.utils.VMRuntimeException: Execution failed
at org.eclipse.ocl.examples.debug.vm.launching.InternalDebuggableExecutor.execute(InternalDebuggableExecutor.java:287)
at org.eclipse.ocl.examples.debug.vm.launching.DebuggableRunner.execute(DebuggableRunner.java:112)
at org.eclipse.ocl.examples.debug.vm.launching.DebuggableRunner$2.execute(DebuggableRunner.java:83)
at org.eclipse.ocl.examples.debug.vm.VMVirtualMachine.execute(VMVirtualMachine.java:161)
at org.eclipse.ocl.examples.debug.vm.VMVirtualMachine.access$14(VMVirtualMachine.java:158)
at org.eclipse.ocl.examples.debug.vm.VMVirtualMachine$1.run(VMVirtualMachine.java:218)
at java.lang.Thread.run(Unknown Source)
Diagnostic ERROR source=org.eclipse.ocl.examples.debug.evaluation code=120 Execution failed data=[org.eclipse.ocl.examples.debug.vm.utils.VMRuntimeException: Execution failed]



Just wanted to know if this is expected, a problem of if I am doing something wrong.

Regards,
Bruce
Re: Failed to set 'self' context [message #1783921 is a reply to message #1783915] Tue, 20 March 2018 12:26 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 6045
Registered: July 2009
Senior Member
Hi

No this is not what is expected. I see something very similar in my workspace. Thank you. I'll investigate.

https://bugs.eclipse.org/bugs/show_bug.cgi?id=532591 came in yesterday and looks very adjacent to your observation. Are you a Mac 10.12.6, Eclipse Oxygen SR0 user?

Regards

Ed Willink
Re: Failed to set 'self' context [message #1783925 is a reply to message #1783921] Tue, 20 March 2018 13:01 Go to previous messageGo to next message
Bruce Trask is currently offline Bruce TraskFriend
Messages: 58
Registered: July 2009
Member
Hi Ed,

I am on Windows with

Eclipse Modeling Tools

Version: Oxygen.1a Release (4.7.1a)

Regards,
Bruce
Re: Failed to set 'self' context [message #1783933 is a reply to message #1783925] Tue, 20 March 2018 14:04 Go to previous messageGo to next message
Bruce Trask is currently offline Bruce TraskFriend
Messages: 58
Registered: July 2009
Member
Hello,

Just another piece of information. The dialog box I mention above pops up after a certain amount of time while walking throught the OCLinECore tutorial as well. Seems to come up when I make the OCLinEcore editor tab active.

Regards,
Bruce

[Updated on: Tue, 20 March 2018 14:07]

Report message to a moderator

Re: Failed to set 'self' context [message #1783935 is a reply to message #1783933] Tue, 20 March 2018 14:29 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 6045
Registered: July 2009
Senior Member
Hi

Thanks, but my only trouble with the repro is embarrassment at how solid it is.

https://bugs.eclipse.org/bugs/show_bug.cgi?id=529886 explains why this has eluded testing.

Regards

Ed Willink
Re: Failed to set 'self' context [message #1785297 is a reply to message #1783935] Thu, 12 April 2018 08:16 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 6045
Registered: July 2009
Senior Member
Hi

The problems with the OCL debugger are fixed in the latest OCL I-build: http://www.eclipse.org/modeling/download.php?file=/modeling/mdt/ocl/downloads/drops/6.4.0/I201804111318/mdt-ocl-Update-I201804111318.zip

(A refactoring introduced an infinite recursion for any attempt to step into/over an iteration. The OCL debugger is now subject to a JUnit test.)

Regards

Ed Willink
Re: Failed to set 'self' context [message #1785523 is a reply to message #1785297] Mon, 16 April 2018 08:39 Go to previous messageGo to next message
Bruce Trask is currently offline Bruce TraskFriend
Messages: 58
Registered: July 2009
Member
Great. Thanks.

Was this also the problem (as fix) with the OCL console and the unimplemented method I believe?

Regards,
Bruce

[Updated on: Mon, 16 April 2018 08:40]

Report message to a moderator

Re: Failed to set 'self' context [message #1785525 is a reply to message #1785523] Mon, 16 April 2018 09:04 Go to previous message
Ed Willink is currently offline Ed WillinkFriend
Messages: 6045
Registered: July 2009
Senior Member
Hi

The UOE was a separate much more easily fixed problem. https://bugs.eclipse.org/bugs/show_bug.cgi?id=532666

M6 was 4 weeks ago. M7 is 4 weeks time. An I-build has all the latest fixes. http://www.eclipse.org/modeling/download.php?file=/modeling/mdt/ocl/downloads/drops/6.4.0/I201804111318/mdt-ocl-Update-I201804111318.zip

Regards

Ed Willink
Previous Topic:Code Generation with external ocl document
Next Topic:OCL and SBVR
Goto Forum:
  


Current Time: Wed Sep 26 09:12:34 GMT 2018

Powered by FUDForum. Page generated in 0.01717 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top