Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Problem for updating Eclipse Oxygen
Problem for updating Eclipse Oxygen [message #1783772] Fri, 16 March 2018 18:31 Go to next message
Guillaume DALLENNE is currently offline Guillaume DALLENNEFriend
Messages: 1
Registered: March 2018
Junior Member
Hello everyone,

I am looking for some help because when i want to update Eclipse with "Check for updates", the updating software encounter a problem.

Here is the error Eclipse gave me :
An error occurred while collecting items to be installed
session context was:(profile=C__Users_Guillaume_eclipse_java-latest-released_eclipse, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,com.google.inject,3.0.0.v201605172100
No repository found containing: osgi.bundle,com.google.inject.multibindings,3.0.0.v201605172100
No repository found containing: osgi.bundle,org.eclipse.recommenders.apidocs,2.5.1.v20180228-0833
No repository found containing: osgi.bundle,org.eclipse.recommenders.apidocs.rcp,2.5.1.v20180228-0833
No repository found containing: osgi.bundle,org.eclipse.recommenders.calls,2.5.1.v20180228-0833
No repository found containing: osgi.bundle,org.eclipse.recommenders.calls.rcp,2.5.1.v20180228-0833
No repository found containing: osgi.bundle,org.eclipse.recommenders.chain.rcp,2.5.1.v20180228-0833
No repository found containing: osgi.bundle,org.eclipse.recommenders.completion.rcp,2.5.1.v20180228-0833
No repository found containing: osgi.bundle,org.eclipse.recommenders.constructors,2.5.1.v20180228-0833
No repository found containing: osgi.bundle,org.eclipse.recommenders.constructors.rcp,2.5.1.v20180228-0833
No repository found containing: osgi.bundle,org.eclipse.recommenders.coordinates,2.5.1.v20180228-0833
No repository found containing: osgi.bundle,org.eclipse.recommenders.coordinates.rcp,2.5.1.v20180228-0833
No repository found containing: osgi.bundle,org.eclipse.recommenders.injection,2.5.1.v20180228-0833
No repository found containing: osgi.bundle,org.eclipse.recommenders.jayes,2.5.1.v20180228-0833
No repository found containing: osgi.bundle,org.eclipse.recommenders.jayes.io,2.5.1.v20180228-0833
No repository found containing: osgi.bundle,org.eclipse.recommenders.jdt,2.5.1.v20180228-0833
No repository found containing: osgi.bundle,org.eclipse.recommenders.models,2.5.1.v20180228-0833
No repository found containing: osgi.bundle,org.eclipse.recommenders.models.rcp,2.5.1.v20180228-0833
No repository found containing: osgi.bundle,org.eclipse.recommenders.mylyn.rcp,2.5.1.v20180228-0833
No repository found containing: osgi.bundle,org.eclipse.recommenders.net,2.5.1.v20180228-0833
No repository found containing: osgi.bundle,org.eclipse.recommenders.news,2.5.1.v20180228-0833
No repository found containing: osgi.bundle,org.eclipse.recommenders.news.api,2.5.1.v20180228-0833
No repository found containing: osgi.bundle,org.eclipse.recommenders.news.impl,2.5.1.v20180228-0833
No repository found containing: osgi.bundle,org.eclipse.recommenders.news.rcp,2.5.1.v20180228-0833
No repository found containing: osgi.bundle,org.eclipse.recommenders.overrides,2.5.1.v20180228-0833
No repository found containing: osgi.bundle,org.eclipse.recommenders.overrides.rcp,2.5.1.v20180228-0833
No repository found containing: osgi.bundle,org.eclipse.recommenders.rcp,2.5.1.v20180228-0833
No repository found containing: osgi.bundle,org.eclipse.recommenders.snipmatch,2.5.1.v20180228-0833
No repository found containing: osgi.bundle,org.eclipse.recommenders.snipmatch.rcp,2.5.1.v20180228-0833
No repository found containing: osgi.bundle,org.eclipse.recommenders.statics,2.5.1.v20180228-0833
No repository found containing: osgi.bundle,org.eclipse.recommenders.statics.rcp,2.5.1.v20180228-0833
No repository found containing: osgi.bundle,org.eclipse.recommenders.subwords.rcp,2.5.1.v20180228-0833
No repository found containing: osgi.bundle,org.eclipse.recommenders.types.rcp,2.5.1.v20180228-0833
No repository found containing: osgi.bundle,org.eclipse.recommenders.utils,2.5.1.v20180228-0833
No repository found containing: osgi.bundle,org.eclipse.recommenders.utils.rcp,2.5.1.v20180228-0833
No repository found containing: org.eclipse.update.feature,org.eclipse.recommenders.mylyn.rcp.feature,2.5.1.v20180228-0833
No repository found containing: org.eclipse.update.feature,org.eclipse.recommenders.news.rcp.feature,2.5.1.v20180228-0833
No repository found containing: org.eclipse.update.feature,org.eclipse.recommenders.rcp.feature,2.5.1.v20180228-0833
No repository found containing: org.eclipse.update.feature,org.eclipse.recommenders.snipmatch.rcp.feature,2.5.1.v20180228-0833




Sorry i didn't find how to put a spoiler. Thanks in advance.
Re: Problem for updating Eclipse Oxygen [message #1783899 is a reply to message #1783772] Tue, 20 March 2018 07:30 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29545
Registered: July 2009
Senior Member
You could use these instructions to find a repo that contains such a version: https://wiki.eclipse.org/Eclipse_Oomph_Authoring#How_to_find_a_P2_repository_at_Eclipse_using_the_Repository_Explorer

It looks to me like a version that's not yet the released version of Oxygen but rather in the soon-to-be-released repo...
Re: Problem for updating Eclipse Oxygen [message #1790504 is a reply to message #1783899] Tue, 12 June 2018 03:17 Go to previous message
Frank Schulten is currently offline Frank SchultenFriend
Messages: 2
Registered: June 2018
Junior Member
What I did on this was just to uninstall Recommenders from Marketplace, then restart. I got a notification that my installation is missing recommenders, installed them again and afterwards could also update them.

With Eclipse Oxygen I had those recommenders update problems with every update, and its only recommenders...
Previous Topic:adding commons lang when using Gradle
Next Topic:How to get internal.compiler ASTnodes from core.dom ASTnodes?
Goto Forum:
  


Current Time: Sat Sep 22 18:24:27 GMT 2018

Powered by FUDForum. Page generated in 0.01966 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top