Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Installing xtext(Domain Spicific Language - Recreating a Coordinate Geometry Language developed MIT discontinued in 2001)
Installing xtext [message #1783108] Thu, 08 March 2018 02:52 Go to next message
Joseph O'Connor is currently offline Joseph O'ConnorFriend
Messages: 2
Registered: March 2018
Junior Member
getting the following error by entering this address http://download.eclipse.org/modeling/tmf/xtext/updates/composite/releases/ to add xtext as directed from https://www.eclipse.org/Xtext/download.html


Cannot complete the install because one or more required items could not be found.
Software being installed: Xtext Complete SDK 2.13.0.v20171020-0920 (org.eclipse.xtext.sdk.feature.group 2.13.0.v20171020-0920)
Missing requirement: Xtext Testing Infrastructure 2.13.0.v20171020-0708 (org.eclipse.xtext.testing 2.13.0.v20171020-0708) requires 'bundle org.junit 4.12.0' but it could not be found
Cannot satisfy dependency:
From: Xtend IDE 2.13.0.v20171020-0920 (org.eclipse.xtend.sdk.feature.group 2.13.0.v20171020-0920)
To: org.eclipse.xtext.testing [2.13.0.v20171020-0708]
Cannot satisfy dependency:
From: Xtext Complete SDK 2.13.0.v20171020-0920 (org.eclipse.xtext.sdk.feature.group 2.13.0.v20171020-0920)
To: org.eclipse.xtend.sdk.feature.group [2.13.0.v20171020-0920]

i have the bad habit of doing thins by brute force. so my configuration might be a problem. i do strongly belief in have a complete install of eclipse 3.8.

I will continue tomorrow, hoping i can start a good chat with someone. Very much a beginner hoping to get on a good track.

Joseph O'Connor
Re: Installing xtext [message #1783180 is a reply to message #1783108] Thu, 08 March 2018 20:48 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 12356
Registered: July 2009
Senior Member
Into which platform do you try to install?
Did you add an update site that contains Junis 4.12
E.g. one from eclipse orbit


Need professional support for Xtext, Xpand, EMF?
Go to: https://xtext.itemis.com
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Installing xtext [message #1783196 is a reply to message #1783108] Fri, 09 March 2018 04:37 Go to previous messageGo to next message
Karsten Thoms is currently offline Karsten ThomsFriend
Messages: 639
Registered: July 2009
Location: Dortmund, Germany
Senior Member

You might want to add http://download.eclipse.org/tools/orbit/downloads/drops/R20180206163158/ to your available update sites before in preferences: Install/Update => Available Update Sites

Are you really on eclipse 3.8? Xtext is only supported for Eclipse 4.4 (Luna) at least. No guarantee you get it working on 3.8.
Re: Installing xtext [message #1783796 is a reply to message #1783196] Sun, 18 March 2018 06:50 Go to previous messageGo to next message
Joseph O'Connor is currently offline Joseph O'ConnorFriend
Messages: 2
Registered: March 2018
Junior Member
I was seriously in 3.8 with negative results I believe I have moved beyond them . I will make efforts to keep you posted. Maybe we can cooperate on efforts.
Re: Installing xtext [message #1783800 is a reply to message #1783796] Sun, 18 March 2018 09:14 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 12356
Registered: July 2009
Senior Member
As I said. Have a look at eclipse orbit
But as stated by Karsten 38 is not officially supported
So you need to know what you are doing


Need professional support for Xtext, Xpand, EMF?
Go to: https://xtext.itemis.com
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Installing xtext [message #1783817 is a reply to message #1783800] Sun, 18 March 2018 14:55 Go to previous message
Karsten Thoms is currently offline Karsten ThomsFriend
Messages: 639
Registered: July 2009
Location: Dortmund, Germany
Senior Member

The move from Eclipse 3.x to 4.x was indeed troublesome some years ago. But this is not the case anymore. Eclipse is now in any regard better than 3.8.

If you really, really need to backport, we can offer services for that. Also for upgrading or whatever.
Previous Topic:Regarding Validations in Xtext
Next Topic:Specifying Java version when running xtext.generator.GeneratorComponent from mwe2
Goto Forum:
  


Current Time: Tue Nov 13 02:52:23 GMT 2018

Powered by FUDForum. Page generated in 0.01618 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top