Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » ServerTools (WTP) » Support for Webapps v 4.0
Support for Webapps v 4.0 [message #1782279] Wed, 21 February 2018 09:04 Go to next message
Christian Bachmaier is currently offline Christian BachmaierFriend
Messages: 3
Registered: September 2017
Junior Member
Will there be support for WebApps 4.0, i.e,, with <web-app version="4.0" ... in web.xml in Eclipse 4.7.3 for the Tomcat 9 adapter? Unfortunately, the respective bug entry https://bugs.eclipse.org/bugs/show_bug.cgi?id=529156 contains no new information.
@Larry Isaacs: Maybe you could have a look on that?

This is kind a show stopper: My students cannot start the provided demo application as a war-File. Unfortunately, they often switch to IntelliJ then.

Thanks, Chris
Re: Support for Webapps v 4.0 [message #1782596 is a reply to message #1782279] Tue, 27 February 2018 00:22 Go to previous message
Larry Isaacs is currently offline Larry IsaacsFriend
Messages: 1354
Registered: July 2009
Senior Member
Hi Chris,

It appears that WebTools 3.9.x version that comes with Eclipse 4.7.x does not include support for Servlet 4.0 Dynamic Web Projects. WebTools 3.10.0 coming this summer will support Servlet 4.0 Dynamic Web Projects. I'll try to take care of that defect prior to the M6 milestone for Proton that is coming in March.

Cheers,
Larry
Previous Topic: when deployed projects in jboss; ear, war, jar files are publish them in the eclipse workspace
Next Topic:Integrate JavaScript Development Tools in Eclipse RCP application
Goto Forum:
  


Current Time: Thu Jun 21 12:38:30 GMT 2018

Powered by FUDForum. Page generated in 0.02183 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top