Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Setting breakpoints in Javascript editor does not work as expected(Debug Javascript using JSDT)
Setting breakpoints in Javascript editor does not work as expected [message #1782258] Wed, 21 February 2018 03:13
Dhanya Pradeep is currently offline Dhanya PradeepFriend
Messages: 4
Registered: July 2013
Junior Member
Hi,

We have an application which provides scripting support using the mozilla Rhino javascript engine. We also have a framework that provides APIs to the script that helps the script to interact with the internals of our tool. Recently we provided a feature to enable debugging of the javascripts developed for the tool using eclipse and the debug support provided by the JSDT Debug framework.
We see two problems and would like to know whether someone can help us

1. Sometimes the breakpoints do not get set at the place that we intend to. For eg: If I want to set a breakpoint at line no 10, it gets set at 11, sometimes 15 etc.
2. Even if I set a breakpoint, they are not hit at the right places when we run the script.
3. It is also noted that with small scripts we do not face much problem, as the length of the script increases we see more and more problems.

We are using Eclipse 4.2 Juno version.
It is also to be noted that the since the script is embedded into our java application users are free to use both java and javascript syntaxes.
I'm not sure whether the commands are causing any problem.

Any help would be highly appreciated.

Thanks,
Dhanya
Previous Topic:Could not connect to virtual machine
Next Topic:How long to wait the new topic get permit to post?
Goto Forum:
  


Current Time: Mon Jun 25 02:49:26 GMT 2018

Powered by FUDForum. Page generated in 0.03039 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top