Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Seeking useful plugin documentation(Each one I've viewed leads to a dead end, either a crash of insufficient information)
Seeking useful plugin documentation [message #1781736] Mon, 12 February 2018 19:44 Go to next message
Jerry Miller is currently offline Jerry MillerFriend
Messages: 6
Registered: March 2014
Junior Member
I'm told I can test Eclipse plugins (not what I eventually want to develop, but that's what the intro examples recommend) by debugging within Eclipse apparently running another instance of Eclipse with the plugin, if I've read it correctly.

But lo and behold, I get an error dump complaining about a missing component that I can't even find, given the haphazard way I discover alternative views of the project. Some page tells me to delete a lock file without telling me where to find it, but it doesn't help.

Later, I find a doc that says to create a zip file to expand into a plugin directory, which I have yet to look for, because the next step tells me to create and run build.xml, which creates a @dot directory and still no zip file!

In addition, the doc in question tells me to click the Export... button on figure 2 to get to figure 3, only it never told me how to get to figure 2!!!
Re: Seeking useful plugin documentation [message #1781737 is a reply to message #1781736] Mon, 12 February 2018 19:53 Go to previous messageGo to next message
Jerry Miller is currently offline Jerry MillerFriend
Messages: 6
Registered: March 2014
Junior Member
I'm very pessimistic about the time frame of this, considering all I've even created so far is a virtually empty plugin with not even a clue as to how to introduce functionality!!!
Re: Seeking useful plugin documentation [message #1781739 is a reply to message #1781737] Mon, 12 February 2018 20:44 Go to previous messageGo to next message
Stephan Herrmann is currently offline Stephan HerrmannFriend
Messages: 1602
Registered: July 2009
Senior Member
All this sounds very unfortunate, but frankly, I have have no idea what exactly you tried and in which exact way it failed.
Do you care to share enough information so that others have a chance to understand what's going on?
Or for a start: which documentation / tutorials have you tried so far?
Re: Seeking useful plugin documentation [message #1781740 is a reply to message #1781739] Mon, 12 February 2018 21:02 Go to previous messageGo to next message
Jerry Miller is currently offline Jerry MillerFriend
Messages: 6
Registered: March 2014
Junior Member
If I'm able to track down the page I found on Friday that got me as far as crashing, or the one after it that told me to delete a lock file, I'll post that. Meanwhile, I can't even find the one one from today, because I lost it in the hassle to find this forum, but I believe it was an Eclipse document.

The only page I still have open is another one that gave me information that crashed with a port that couldn't be accessed, without telling me why I needed a port. (Since -port does not appear to be a Java option, I'm guessing it's an obscure Eclipse one. Anyway, it was using 22, the ssh port, but changing it didn't help, and omitting it caused a complaint:

https://stackoverflow.com/questions/255370/automating-unit-tests-junit-for-eclipse-plugin-development
Re: Seeking useful plugin documentation [message #1781741 is a reply to message #1781740] Mon, 12 February 2018 21:06 Go to previous messageGo to next message
Jerry Miller is currently offline Jerry MillerFriend
Messages: 6
Registered: March 2014
Junior Member
On the other hand, what I'm asking should be fairly straightforward. Where can I find a complete, accurate documentation of the creation and testing of plug-ins, complete with an explanation of why I'm doing what I'm told to do, so I know what to try when it doesn't work?

One thing I can tell you about the page I read on Friday is that it created what it called a "helloworld" example that, as far as I could see, didn't even output "Hello world!" in any way, shape, or form, let alone do anything else--not very useful!

I'm pretty sure it wasn't this, which I just found in a search, but I'm bookmarking it as what I hope will be a less abortive attempt than any I've encountered up to now:

https://www.eclipse.org/articles/Article-Your%20First%20Plug-in/YourFirstPlugin.html

[Updated on: Mon, 12 February 2018 21:17]

Report message to a moderator

Re: Seeking useful plugin documentation [message #1781743 is a reply to message #1781741] Mon, 12 February 2018 21:43 Go to previous messageGo to next message
Stephan Herrmann is currently offline Stephan HerrmannFriend
Messages: 1602
Registered: July 2009
Senior Member
Eclipse, like any software, is evolving technology, so the tutorial "YourFirstPlugin.html" doesn't look like a good candidate, because its last modification dates 15 years back!
In fact, that modification was the addition of: "Editor's note: Sept. 2003 - This article has been retired from service. ".

A better guess would be this (last edit 2016): http://www.vogella.com/tutorials/EclipsePlugin/article.html
Anyway, there are several others on the web, too, just make sure to check it's recency. It should at the very least cover Eclipse 3.x,
because the nature of plugins has changed significantly between 2.x and 3.x.
Re: Seeking useful plugin documentation [message #1781830 is a reply to message #1781743] Tue, 13 February 2018 16:39 Go to previous messageGo to next message
Gerald Miller is currently offline Gerald MillerFriend
Messages: 3
Registered: February 2018
Junior Member
My eventual goal is not so much to write Eclipse plugins but to create them for other platforms that support their use, so the less Eclipse-specific the examples are, the better.
Re: Seeking useful plugin documentation [message #1781832 is a reply to message #1781743] Tue, 13 February 2018 17:12 Go to previous messageGo to next message
Gerald Miller is currently offline Gerald MillerFriend
Messages: 3
Registered: February 2018
Junior Member
!SESSION 2018-02-13 12:10:14.448 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_102
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Framework arguments: -application garbage.application
Command-line arguments: -application garbage.application -data C:\Users\gerald.miller\plugintest/../runtime-garbage.application -dev file:C:/Users/gerald.miller/plugintest/.metadata/.plugins/org.eclipse.pde.core/garbage.application/dev.properties -os win32 -ws win32 -arch x86_64 -consoleLog

!ENTRY org.eclipse.ui.workbench 4 0 2018-02-13 12:10:15.041
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.ui.workbench [7]
Unresolved requirement: Import-Package: org.eclipse.e4.ui.internal.workbench.swt
-> Export-Package: org.eclipse.e4.ui.internal.workbench.swt; bundle-symbolic-name="org.eclipse.e4.ui.workbench.swt"; bundle-version="0.14.0.v20160523-1900"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.workbench.addons.swt,org.eclipse.e4.ui.workbench.renderers.swt,org.eclipse.ui.workbench"
org.eclipse.e4.ui.workbench.swt [20]
Unresolved requirement: Require-Capability: osgi.extender; filter:="(&(osgi.extender=osgi.component)(version>=1.2)(!(version>=2.0)))"
Unresolved requirement: Import-Package: org.eclipse.e4.ui.internal.workbench.renderers.swt
-> Export-Package: org.eclipse.e4.ui.internal.workbench.renderers.swt; bundle-symbolic-name="org.eclipse.e4.ui.workbench.renderers.swt"; bundle-version="0.14.0.v20160525-0940"; version="0.0.0"; x-friends:="org.eclipse.ui.workbench"
org.eclipse.e4.ui.workbench.renderers.swt [19]
Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.workbench.swt; bundle-version="0.9.0"
-> Bundle-SymbolicName: org.eclipse.e4.ui.workbench.swt; bundle-version="0.14.0.v20160523-1900"; singleton:="true"

at org.eclipse.osgi.container.Module.start(Module.java:444)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1620)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1599)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1571)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1514)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.e4.ui.workbench.addons.swt 4 0 2018-02-13 12:10:15.048
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.e4.ui.workbench.addons.swt [13]
Unresolved requirement: Import-Package: org.eclipse.e4.ui.internal.workbench.swt
-> Export-Package: org.eclipse.e4.ui.internal.workbench.swt; bundle-symbolic-name="org.eclipse.e4.ui.workbench.swt"; bundle-version="0.14.0.v20160523-1900"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.workbench.addons.swt,org.eclipse.e4.ui.workbench.renderers.swt,org.eclipse.ui.workbench"
org.eclipse.e4.ui.workbench.swt [20]
Unresolved requirement: Require-Capability: osgi.extender; filter:="(&(osgi.extender=osgi.component)(version>=1.2)(!(version>=2.0)))"
Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.workbench.renderers.swt; bundle-version="0.9.1"
-> Bundle-SymbolicName: org.eclipse.e4.ui.workbench.renderers.swt; bundle-version="0.14.0.v20160525-0940"; singleton:="true"
org.eclipse.e4.ui.workbench.renderers.swt [19]
Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.workbench.swt; bundle-version="0.9.0"
-> Bundle-SymbolicName: org.eclipse.e4.ui.workbench.swt; bundle-version="0.14.0.v20160523-1900"; singleton:="true"

at org.eclipse.osgi.container.Module.start(Module.java:444)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1620)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1599)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1571)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1514)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.e4.ui.workbench.renderers.swt 4 0 2018-02-13 12:10:15.055
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.e4.ui.workbench.renderers.swt [19]
Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.workbench.swt; bundle-version="0.9.0"
-> Bundle-SymbolicName: org.eclipse.e4.ui.workbench.swt; bundle-version="0.14.0.v20160523-1900"; singleton:="true"
org.eclipse.e4.ui.workbench.swt [20]
Unresolved requirement: Require-Capability: osgi.extender; filter:="(&(osgi.extender=osgi.component)(version>=1.2)(!(version>=2.0)))"

at org.eclipse.osgi.container.Module.start(Module.java:444)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1620)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1599)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1571)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1514)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.e4.ui.workbench.swt 4 0 2018-02-13 12:10:15.060
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.e4.ui.workbench.swt [20]
Unresolved requirement: Require-Capability: osgi.extender; filter:="(&(osgi.extender=osgi.component)(version>=1.2)(!(version>=2.0)))"

at org.eclipse.osgi.container.Module.start(Module.java:444)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1620)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1599)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1571)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1514)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.ui 4 0 2018-02-13 12:10:15.065
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.ui [37]
Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)"; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.108.0.v20160602-1232"; singleton:="true"
org.eclipse.ui.workbench [7]
Unresolved requirement: Import-Package: org.eclipse.e4.ui.internal.workbench.swt
-> Export-Package: org.eclipse.e4.ui.internal.workbench.swt; bundle-symbolic-name="org.eclipse.e4.ui.workbench.swt"; bundle-version="0.14.0.v20160523-1900"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.workbench.addons.swt,org.eclipse.e4.ui.workbench.renderers.swt,org.eclipse.ui.workbench"
org.eclipse.e4.ui.workbench.swt [20]
Unresolved requirement: Require-Capability: osgi.extender; filter:="(&(osgi.extender=osgi.component)(version>=1.2)(!(version>=2.0)))"
Unresolved requirement: Import-Package: org.eclipse.e4.ui.internal.workbench.renderers.swt
-> Export-Package: org.eclipse.e4.ui.internal.workbench.renderers.swt; bundle-symbolic-name="org.eclipse.e4.ui.workbench.renderers.swt"; bundle-version="0.14.0.v20160525-0940"; version="0.0.0"; x-friends:="org.eclipse.ui.workbench"
org.eclipse.e4.ui.workbench.renderers.swt [19]
Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.workbench.swt; bundle-version="0.9.0"
-> Bundle-SymbolicName: org.eclipse.e4.ui.workbench.swt; bundle-version="0.14.0.v20160523-1900"; singleton:="true"

at org.eclipse.osgi.container.Module.start(Module.java:444)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1620)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1599)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1571)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1514)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY garbage 4 0 2018-02-13 12:10:15.070
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: garbage [68]
Unresolved requirement: Require-Bundle: org.eclipse.ui
-> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.108.0.v20160518-1929"; singleton:="true"
org.eclipse.ui [37]
Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)"; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.108.0.v20160602-1232"; singleton:="true"
org.eclipse.ui.workbench [7]
Unresolved requirement: Import-Package: org.eclipse.e4.ui.internal.workbench.swt
-> Export-Package: org.eclipse.e4.ui.internal.workbench.swt; bundle-symbolic-name="org.eclipse.e4.ui.workbench.swt"; bundle-version="0.14.0.v20160523-1900"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.workbench.addons.swt,org.eclipse.e4.ui.workbench.renderers.swt,org.eclipse.ui.workbench"
org.eclipse.e4.ui.workbench.swt [20]
Unresolved requirement: Require-Capability: osgi.extender; filter:="(&(osgi.extender=osgi.component)(version>=1.2)(!(version>=2.0)))"
Unresolved requirement: Import-Package: org.eclipse.e4.ui.internal.workbench.renderers.swt
-> Export-Package: org.eclipse.e4.ui.internal.workbench.renderers.swt; bundle-symbolic-name="org.eclipse.e4.ui.workbench.renderers.swt"; bundle-version="0.14.0.v20160525-0940"; version="0.0.0"; x-friends:="org.eclipse.ui.workbench"
org.eclipse.e4.ui.workbench.renderers.swt [19]
Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.workbench.swt; bundle-version="0.9.0"
-> Bundle-SymbolicName: org.eclipse.e4.ui.workbench.swt; bundle-version="0.14.0.v20160523-1900"; singleton:="true"

at org.eclipse.osgi.container.Module.start(Module.java:444)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1620)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1599)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1571)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1514)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.e4.ui.workbench.swt 2 0 2018-02-13 12:10:15.322
!MESSAGE Could not resolve module: org.eclipse.e4.ui.workbench.swt [20]
Unresolved requirement: Require-Capability: osgi.extender; filter:="(&(osgi.extender=osgi.component)(version>=1.2)(!(version>=2.0)))"


!ENTRY org.eclipse.ui.workbench 2 0 2018-02-13 12:10:15.328
!MESSAGE Could not resolve module: org.eclipse.ui.workbench [7]
Unresolved requirement: Import-Package: org.eclipse.e4.ui.internal.workbench.swt
-> Export-Package: org.eclipse.e4.ui.internal.workbench.swt; bundle-symbolic-name="org.eclipse.e4.ui.workbench.swt"; bundle-version="0.14.0.v20160523-1900"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.workbench.addons.swt,org.eclipse.e4.ui.workbench.renderers.swt,org.eclipse.ui.workbench"
org.eclipse.e4.ui.workbench.swt [20]
Unresolved requirement: Require-Capability: osgi.extender; filter:="(&(osgi.extender=osgi.component)(version>=1.2)(!(version>=2.0)))"
Unresolved requirement: Import-Package: org.eclipse.e4.ui.internal.workbench.renderers.swt
-> Export-Package: org.eclipse.e4.ui.internal.workbench.renderers.swt; bundle-symbolic-name="org.eclipse.e4.ui.workbench.renderers.swt"; bundle-version="0.14.0.v20160525-0940"; version="0.0.0"; x-friends:="org.eclipse.ui.workbench"
org.eclipse.e4.ui.workbench.renderers.swt [19]
Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.workbench.swt; bundle-version="0.9.0"
-> Bundle-SymbolicName: org.eclipse.e4.ui.workbench.swt; bundle-version="0.14.0.v20160523-1900"; singleton:="true"


!ENTRY org.eclipse.e4.ui.workbench.renderers.swt 2 0 2018-02-13 12:10:15.333
!MESSAGE Could not resolve module: org.eclipse.e4.ui.workbench.renderers.swt [19]
Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.workbench.swt; bundle-version="0.9.0"
-> Bundle-SymbolicName: org.eclipse.e4.ui.workbench.swt; bundle-version="0.14.0.v20160523-1900"; singleton:="true"
org.eclipse.e4.ui.workbench.swt [20]
Unresolved requirement: Require-Capability: osgi.extender; filter:="(&(osgi.extender=osgi.component)(version>=1.2)(!(version>=2.0)))"


!ENTRY org.eclipse.e4.ui.workbench.addons.swt 2 0 2018-02-13 12:10:15.340
!MESSAGE Could not resolve module: org.eclipse.e4.ui.workbench.addons.swt [13]
Unresolved requirement: Import-Package: org.eclipse.e4.ui.internal.workbench.swt
-> Export-Package: org.eclipse.e4.ui.internal.workbench.swt; bundle-symbolic-name="org.eclipse.e4.ui.workbench.swt"; bundle-version="0.14.0.v20160523-1900"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.workbench.addons.swt,org.eclipse.e4.ui.workbench.renderers.swt,org.eclipse.ui.workbench"
org.eclipse.e4.ui.workbench.swt [20]
Unresolved requirement: Require-Capability: osgi.extender; filter:="(&(osgi.extender=osgi.component)(version>=1.2)(!(version>=2.0)))"


!ENTRY org.eclipse.ui 2 0 2018-02-13 12:10:15.345
!MESSAGE Could not resolve module: org.eclipse.ui [37]
Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)"; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.108.0.v20160602-1232"; singleton:="true"
org.eclipse.ui.workbench [7]
Unresolved requirement: Import-Package: org.eclipse.e4.ui.internal.workbench.swt
-> Export-Package: org.eclipse.e4.ui.internal.workbench.swt; bundle-symbolic-name="org.eclipse.e4.ui.workbench.swt"; bundle-version="0.14.0.v20160523-1900"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.workbench.addons.swt,org.eclipse.e4.ui.workbench.renderers.swt,org.eclipse.ui.workbench"
org.eclipse.e4.ui.workbench.swt [20]
Unresolved requirement: Require-Capability: osgi.extender; filter:="(&(osgi.extender=osgi.component)(version>=1.2)(!(version>=2.0)))"
Unresolved requirement: Import-Package: org.eclipse.e4.ui.internal.workbench.renderers.swt
-> Export-Package: org.eclipse.e4.ui.internal.workbench.renderers.swt; bundle-symbolic-name="org.eclipse.e4.ui.workbench.renderers.swt"; bundle-version="0.14.0.v20160525-0940"; version="0.0.0"; x-friends:="org.eclipse.ui.workbench"
org.eclipse.e4.ui.workbench.renderers.swt [19]
Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.workbench.swt; bundle-version="0.9.0"
-> Bundle-SymbolicName: org.eclipse.e4.ui.workbench.swt; bundle-version="0.14.0.v20160523-1900"; singleton:="true"


!ENTRY garbage 2 0 2018-02-13 12:10:15.350
!MESSAGE Could not resolve module: garbage [68]
Unresolved requirement: Require-Bundle: org.eclipse.ui
-> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.108.0.v20160518-1929"; singleton:="true"
org.eclipse.ui [37]
Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)"; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.108.0.v20160602-1232"; singleton:="true"
org.eclipse.ui.workbench [7]
Unresolved requirement: Import-Package: org.eclipse.e4.ui.internal.workbench.swt
-> Export-Package: org.eclipse.e4.ui.internal.workbench.swt; bundle-symbolic-name="org.eclipse.e4.ui.workbench.swt"; bundle-version="0.14.0.v20160523-1900"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.workbench.addons.swt,org.eclipse.e4.ui.workbench.renderers.swt,org.eclipse.ui.workbench"
org.eclipse.e4.ui.workbench.swt [20]
Unresolved requirement: Require-Capability: osgi.extender; filter:="(&(osgi.extender=osgi.component)(version>=1.2)(!(version>=2.0)))"
Unresolved requirement: Import-Package: org.eclipse.e4.ui.internal.workbench.renderers.swt
-> Export-Package: org.eclipse.e4.ui.internal.workbench.renderers.swt; bundle-symbolic-name="org.eclipse.e4.ui.workbench.renderers.swt"; bundle-version="0.14.0.v20160525-0940"; version="0.0.0"; x-friends:="org.eclipse.ui.workbench"
org.eclipse.e4.ui.workbench.renderers.swt [19]
Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.workbench.swt; bundle-version="0.9.0"
-> Bundle-SymbolicName: org.eclipse.e4.ui.workbench.swt; bundle-version="0.14.0.v20160523-1900"; singleton:="true"


!ENTRY org.eclipse.osgi 4 0 2018-02-13 12:10:15.355
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: Application "garbage.application" could not be found in the registry. The applications available are: org.eclipse.ant.core.antRunner, org.eclipse.equinox.app.error.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:248)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
at org.eclipse.equinox.launcher.Main.main(Main.java:1492)
An error has occurred. See the log file
C:\Users\gerald.miller\plugintest\.metadata\.plugins\org.eclipse.pde.core\garbage.application\1518541814736.log.
Re: Seeking useful plugin documentation [message #1781835 is a reply to message #1781832] Tue, 13 February 2018 19:09 Go to previous messageGo to next message
Stephan Herrmann is currently offline Stephan HerrmannFriend
Messages: 1602
Registered: July 2009
Senior Member
This thread appears to be a dump of mishaps with unknown origin / background, rather than a question regarding documentation about a particular topic.
Impossible to give advice ...
Re: Seeking useful plugin documentation [message #1781924 is a reply to message #1781835] Wed, 14 February 2018 16:28 Go to previous messageGo to next message
Gerald Miller is currently offline Gerald MillerFriend
Messages: 3
Registered: February 2018
Junior Member
This dump is directly related to the Eclipse IDE Plug-in Development document you referred me to. I was told to right-click the MANIFEST.MF and select Run As > Eclipse Application. That dump is the result, and it happens regardless of which documentation's instructions I follow.
Re: Seeking useful plugin documentation [message #1781939 is a reply to message #1781924] Wed, 14 February 2018 19:53 Go to previous message
Stephan Herrmann is currently offline Stephan HerrmannFriend
Messages: 1602
Registered: July 2009
Senior Member
Let's step back for a second, and consider that hundreds (thousands?) of people in this community develop Eclipse Plug-ins on a daily basis.
There must be some difference between what all of them are doing and what you are doing.
From the infinite possibilities of such differences I can see a tiny hint in your dump:
Quote:
eclipse.buildId=unknown


In that line a proper installation of Eclipse would identify itself with a proper build ID.
From a broken installation any error is possible, right?
So, from here you could either explain from where you obtained Eclipse, and how you installed, possibly updated, Eclipse (with exact coordinates, versions etc.).
Or, you could give it a fresh start with a fresh download of the latest release version.

PS: I don't think the IDE is yet smart enough to behave that way because it senses that you actually don't want to develop any Eclipse plug-ins ;p
Previous Topic:Eclipse MAT heap dump import
Next Topic:Error without explaination
Goto Forum:
  


Current Time: Sun Jun 24 03:50:20 GMT 2018

Powered by FUDForum. Page generated in 0.01936 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top