Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Cannot deploy RAP on tomcat 9
Cannot deploy RAP on tomcat 9 [message #1781430] Wed, 07 February 2018 09:47 Go to next message
Arnaud MERGEY is currently offline Arnaud MERGEYFriend
Messages: 218
Registered: March 2010
Location: France
Senior Member
Hello,

rwt and others bundles (file updload, nebula grid, .... ) manifest exclude servlet 4 which prevent a RAP application to be deployed in tomcat 9 (on top of servlet bridge) are there any reasons ?

(Import-Package: javax.servlet;version="[2.3.0,4.0.0)",javax.servlet.ht
tp;version="[2.3.0,4.0.0)",javax.xml.parsers,org.w3c.dom,org.xml.sax,
org.xml.sax.helpers)

Regards,
Arnaud

[Updated on: Wed, 07 February 2018 09:48]

Report message to a moderator

Re: Cannot deploy RAP on tomcat 9 [message #1781432 is a reply to message #1781430] Wed, 07 February 2018 10:03 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2263
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi Arnaud,
we didn't tested RAP framework yet with Tomcat 9 (javax.servlet 4). Did you encounter any issues? Is everything operational like intended? If so please open a bugzilla to address this issue.
Regards,
Ivan
Re: Cannot deploy RAP on tomcat 9 [message #1781445 is a reply to message #1781430] Wed, 07 February 2018 11:46 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2263
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi Arnaud,
I tried to move the required upper version limit for javax.servlet package to 4.1.0, but it did not help. Tested with latest Photon M5 platform. Than I found that there is the same version range specified in "org.eclipse.equinox.http.servlet" bundle MANIFEST.MF:
---
javax.servlet;version="[2.3.0,4.0.0)",
javax.servlet.annotation;version="[2.6.0,4.0.0)";resolution:=optional,
javax.servlet.descriptor;version="[2.6.0,4.0.0)";resolution:=optional,
javax.servlet.http;version="[2.3.0,4.0.0)",
---
This means that first Equinox must update/adjust their bundles to work with Servlet 4.
Regards,
Ivan
Re: Cannot deploy RAP on tomcat 9 [message #1781446 is a reply to message #1781432] Wed, 07 February 2018 11:48 Go to previous message
Arnaud MERGEY is currently offline Arnaud MERGEYFriend
Messages: 218
Registered: March 2010
Location: France
Senior Member
I cannot test it, as tomcat 9 is servlet 4.0 and my application is osgi it cannot run on tomcat 9 because, rap bundles cannot start because of 4.0 exclusion for servlets
https://bugs.eclipse.org/bugs/show_bug.cgi?id=530826
Regards,
Arnaud
Previous Topic:Deploying E4 application to a servlet container using tycho
Next Topic:custom progress view
Goto Forum:
  


Current Time: Tue Feb 20 23:47:36 GMT 2018

Powered by FUDForum. Page generated in 0.01642 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software