Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » [Resolved] Newbie can't get SWT demo "Hello World" set up(Having trouble getting the right files set up for SWT)
[Resolved] Newbie can't get SWT demo "Hello World" set up [message #1781235] Sun, 04 February 2018 00:38 Go to next message
Doug Hutcheson is currently offline Doug HutchesonFriend
Messages: 10
Registered: January 2018
Junior Member
Fedora Linux27 86_64.
Oracle Java jdk1.8.x86_64 2000:1.8.0_161
Eclipse IDE for Java Developers - Version: Oxygen.2 Release (4.7.2) - Build id: 20171218-0600 (the genuine item, not the one from the Fedora repositories).
Plugin Development Environment (PDE) is installed.

I am trying to get the SWT demo "Hello World" application to set up.

Following the instructions from the 'Create a Hello World SWT Application' page, I have got as far as :

Open the Import wizard from the main menu via File > Import..., and select Plug-in Development > Plug-ins and Fragments. Click Next.
On the Import Plug-ins and Fragments page, select
Import from: The active target platform.
Plug-ins and Fragments to import: Select from all plug-ins and fragments found at specified location.
Import As: Projects with source folders.
Click Next.
On the Selection page, Add org.eclipse.swt.{platform}.{os}.{arch} (for example: org.eclipse.swt.win32.win32.x86 for win32) to Plug-ins and Fragments to Import: list.


When I get to this step, there are no items to choose in the selection list (see attached).

What have I done wrong? I've been trying everything I can think of including reinstalling Java and Eclipse.

Any help would be appreciated.

Cheers,
Doug

[Updated on: Mon, 19 February 2018 07:04]

Report message to a moderator

Re: Newbie can't get SWT demo "Hello World" set up [message #1781292 is a reply to message #1781235] Mon, 05 February 2018 16:52 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3083
Registered: July 2009
Senior Member

Checked the Target Platform preference page and make sure it looks correct. When you click on the Active target definition, the Locations text box should show a non-zero number of plug-ins as available. Restore Defaults if you find this is not the case.

Nitin Dahyabhai
Eclipse Web Tools Platform

[Updated on: Mon, 05 February 2018 18:43]

Report message to a moderator

Re: Newbie can't get SWT demo "Hello World" set up [message #1781655 is a reply to message #1781292] Sun, 11 February 2018 06:14 Go to previous message
Doug Hutcheson is currently offline Doug HutchesonFriend
Messages: 10
Registered: January 2018
Junior Member
After some fumbling, I decided it was a bad installation. Cleaned everything up, started again today. Now it all works as it says on the label. Being a newbie can be exciting for all the wrong reasons.

Thanks for your reply, Nitin. "8-)
Previous Topic:How to get two IDEs show in macos launchpad ?
Next Topic:I can't get Eclipse to work with JavaFX
Goto Forum:
  


Current Time: Sat Feb 24 02:51:54 GMT 2018

Powered by FUDForum. Page generated in 0.02784 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software