Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Opening the "Preprocessor Include Paths, Macro's etc" settings dialog causes crash(Just opening and sitting at the "Preprocessor Include Paths, Macro's etc" dialog crashes Eclipse)
Opening the "Preprocessor Include Paths, Macro's etc" settings dialog causes crash [message #1781023] Wed, 31 January 2018 16:07 Go to next message
Jim Carroll is currently offline Jim CarrollFriend
Messages: 1
Registered: January 2018
Junior Member
For reference, a screenshot of the dialog in question is attached.

For my project, just opening and sitting at the "Preprocessor Include Paths, Macro's etc" dialog causes eclipse to eventually crash with no error message and no messages added to the log on crash.

What is happening is the "Setting Entries" window is continuously expanding to the right. You can see this when you hover over the frame in the behavior of the slider. It continuous expands its width until eclipse simply disappears without any additional log or console message.

EDIT: If it matters I'm on:
Ubuntu 16.04
Oxygen from December with the latest updates applied.

[Updated on: Wed, 31 January 2018 18:16]

Report message to a moderator

Re: Opening the "Preprocessor Include Paths, Macro's etc" settings dialog causes crash [message #1781101 is a reply to message #1781023] Thu, 01 February 2018 12:34 Go to previous messageGo to next message
Michal Kristek is currently offline Michal KristekFriend
Messages: 2
Registered: February 2018
Junior Member
Hello,

Did you have any success on this issue? I am asking because I have the same experience with Eclipse Oxygen2, but when I run it in Oxygen version from June 2017, it works correctly...Thanks

[Updated on: Tue, 06 February 2018 15:58]

Report message to a moderator

Re: Opening the "Preprocessor Include Paths, Macro's etc" settings dialog causes crash [message #1781385 is a reply to message #1781101] Tue, 06 February 2018 16:07 Go to previous message
Michal Kristek is currently offline Michal KristekFriend
Messages: 2
Registered: February 2018
Junior Member
Hi again.
Found this bug at https://bugs.eclipse.org/bugs/show_bug.cgi?id=529433
It is not very comfortable solution, but it works somehow for me:

Workaround: select the "Providers" tab in the right pane and the navigation pane selection takes effect.
Previous Topic:Eclipse CDT with C/C++ Makefile
Next Topic:undefined reference to - error build
Goto Forum:
  


Current Time: Wed Feb 21 09:14:34 GMT 2018

Powered by FUDForum. Page generated in 0.01412 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software