Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Kura » HTTPS for Kura Web UI?
HTTPS for Kura Web UI? [message #1779526] Tue, 09 January 2018 09:15 Go to next message
giuseppe ferro is currently offline giuseppe ferroFriend
Messages: 26
Registered: August 2016
Junior Member
Hi,
It's possible to open Kura Web UI in https?

thanks for help
Re: HTTPS for Kura Web UI? [message #1779555 is a reply to message #1779526] Tue, 09 January 2018 15:01 Go to previous messageGo to next message
Matteo Maiero is currently offline Matteo MaieroFriend
Messages: 279
Registered: July 2015
Location: Italy
Senior Member
Hi,
I believe so. Probably you need to change some parameters in the web2 bundle and open the 443 port in the firewall.

Maybe do a search in this forum if anyone else had the same issue and reported their solution.

Best regards,
Matteo
Re: HTTPS for Kura Web UI? [message #1781561 is a reply to message #1779555] Thu, 08 February 2018 15:18 Go to previous messageGo to next message
giuseppe ferro is currently offline giuseppe ferroFriend
Messages: 26
Registered: August 2016
Junior Member
Hi Matteo,
I found this link:

https://dev.eclipse.org/mhonarc/lists/kura-dev/msg00712.html

I'm working on Raspberry Pi (kura 3.1.1) and i've follow the link's instuction but i have this exceptions:

(kura-console.log)
....
org.osgi.framework.BundleException: Exception in org.eclipse.equinox.http.jetty.internal.Activator.start() of bundle org.eclipse.equinox.http.jetty.
.......
Caused by: org.osgi.service.cm.ConfigurationException: default : no valid keystore
... 12 more
Caused by: java.lang.IllegalStateException: no valid keystore
... 17 more
Root exception:
org.osgi.service.cm.ConfigurationException: default : no valid keystore

Have you some ideas?
Any help is appreciated
Thanks
Re: HTTPS for Kura Web UI? [message #1781604 is a reply to message #1781561] Fri, 09 February 2018 10:33 Go to previous messageGo to next message
Matteo Maiero is currently offline Matteo MaieroFriend
Messages: 279
Registered: July 2015
Location: Italy
Senior Member
Hi,
I've personally never tried it. But, from the snippet provided it seems an issue with the Keystore you defined.

Best regards,
Matteo
Re: HTTPS for Kura Web UI? [message #1785559 is a reply to message #1781604] Mon, 16 April 2018 16:16 Go to previous messageGo to next message
giuseppe ferro is currently offline giuseppe ferroFriend
Messages: 26
Registered: August 2016
Junior Member
Hi Matteo,
Can you give me some news about this issue?
I'm still stuck on it!

Thanks in advance
Re: HTTPS for Kura Web UI? [message #1785560 is a reply to message #1785559] Mon, 16 April 2018 16:23 Go to previous message
Matteo Maiero is currently offline Matteo MaieroFriend
Messages: 279
Registered: July 2015
Location: Italy
Senior Member
Hi,
currently there is no official support for https. It could be that those instructions are not anymore working with newest versions of Kura.
I would suggest to review the steps and maybe open an issue in the official GitHub repository reporting carefully the steps done and where you are stuck in order to give all the information needed to provide help or create a fix, if needed.

Best regards,
Matteo
Previous Topic:Multiple kura instances.
Next Topic:GPIO access not working for me.
Goto Forum:
  


Current Time: Fri Nov 16 11:20:56 GMT 2018

Powered by FUDForum. Page generated in 0.09656 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top