Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » Error installing Eclipse modeling tools since Oxygen.2
Error installing Eclipse modeling tools since Oxygen.2 [message #1779351] Fri, 05 January 2018 16:48 Go to next message
Lutz Wrage is currently offline Lutz WrageFriend
Messages: 135
Registered: July 2009
Senior Member
I've been using the installer successfully for a couple of months, but now I can't update anything to oxygen.2. Even just installing plain Eclipse modeling tools without adding any project setups fails on my machine (see log below). The same errors (missing org.eclipse.platform.feature.group) occur for Eclipse JDT. Any idea how I can make this work again?

Executing bootstrap tasks
Java(TM) SE Runtime Environment 1.8.0_151-b12
Product org.eclipse.products.epp.package.modeling.oxygen
Bundle org.eclipse.oomph.setup 1.9.0.v20171202-1121, build=3282, branch=f99b41819cc9f86beec6b54bf453173fc2d4acef
Bundle org.eclipse.oomph.setup.core 1.9.0.v20171202-1121, build=3282, branch=f99b41819cc9f86beec6b54bf453173fc2d4acef
Bundle org.eclipse.oomph.setup.installer 1.9.0.v20171202-1121, build=3282, branch=f99b41819cc9f86beec6b54bf453173fc2d4acef
Bundle org.eclipse.oomph.setup.p2 1.9.0.v20171202-1121, build=3282, branch=f99b41819cc9f86beec6b54bf453173fc2d4acef
Performing P2 Director (Eclipse Modeling Tools (Oxygen))
Offline = true
Mirrors = true
Resolving 37 requirements from 3 repositories to /home/lw/local/eclipse/modeling-oxygen/eclipse
Requirement epp.package.modeling [4.7.0,4.8.0)
Requirement org.eclipse.platform.feature.group [4.7.0,4.8.0)
Requirement org.eclipse.rcp.feature.group [4.7.0,4.8.0)
Requirement org.eclipse.amalgam.discovery.feature.group
Requirement org.eclipse.e4.core.tools.feature.feature.group
Requirement org.eclipse.egit.feature.group
Requirement org.eclipse.emf.cdo.epp.feature.group
Requirement org.eclipse.emf.compare.diagram.sirius.source.feature.group
Requirement org.eclipse.emf.compare.egit.feature.group
Requirement org.eclipse.emf.compare.ide.ui.source.feature.group
Requirement org.eclipse.emf.compare.source.feature.group
Requirement org.eclipse.emf.ecoretools.design.feature.group
Requirement org.eclipse.emf.ecoretools.explorer.contextual.feature.group
Requirement org.eclipse.emf.ecp.sdk.feature.feature.group
Requirement org.eclipse.emf.emfstore.sdk.feature.feature.group
Requirement org.eclipse.emf.parsley.sdk.feature.group
Requirement org.eclipse.emf.parsley.sdk.source.feature.group
Requirement org.eclipse.emf.query.sdk.feature.group
Requirement org.eclipse.emf.sdk.feature.group
Requirement org.eclipse.emf.transaction.sdk.feature.group
Requirement org.eclipse.emf.validation.sdk.feature.group
Requirement org.eclipse.gef.sdk.feature.group
Requirement org.eclipse.gmf.runtime.sdk.feature.group
Requirement org.eclipse.jdt.feature.group
Requirement org.eclipse.mylyn.bugzilla_feature.feature.group
Requirement org.eclipse.mylyn.context_feature.feature.group
Requirement org.eclipse.mylyn.ide_feature.feature.group
Requirement org.eclipse.mylyn.java_feature.feature.group
Requirement org.eclipse.mylyn.pde_feature.feature.group
Requirement org.eclipse.mylyn.wikitext_feature.feature.group
Requirement org.eclipse.mylyn_feature.feature.group
Requirement org.eclipse.ocl.all.sdk.feature.group
Requirement org.eclipse.pde.feature.group
Requirement org.eclipse.sdk.feature.group
Requirement org.eclipse.uml2.sdk.feature.group
Requirement org.eclipse.xsd.sdk.feature.group
Requirement org.eclipse.oomph.setup.feature.group
Repository http://download.eclipse.org/technology/epp/packages/oxygen
Repository http://download.eclipse.org/releases/oxygen/201712201001
Repository http://download.eclipse.org/oomph/updates/milestone/latest
Adding repository http://download.eclipse.org/releases/oxygen/201712201001
Adding repository http://download.eclipse.org/oomph/updates/milestone/latest
Adding repository http://download.eclipse.org/technology/epp/packages/oxygen
Calculating requirements and dependencies.
Cannot complete the request.  Generating details.
ERROR: org.eclipse.equinox.p2.director code=10053 Cannot complete the install because one or more required items could not be found.
  at org.eclipse.oomph.util.OomphPlugin.coreException(OomphPlugin.java:280)
  at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.resolve(ProfileTransactionImpl.java:425)
  at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.commit(ProfileTransactionImpl.java:337)
  at org.eclipse.oomph.setup.p2.impl.P2TaskImpl.perform(P2TaskImpl.java:729)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:3324)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:3252)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:3233)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:3133)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$9.run(ProgressPage.java:575)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$11$1.run(ProgressPage.java:701)
  at org.eclipse.core.internal.jobs.Worker.run(Worker.java:56)
  ERROR: org.eclipse.equinox.p2.director code=0 Software being installed: artificial_root 1.0.0.v1515170281933
  ERROR: org.eclipse.equinox.p2.director code=0 Missing requirement: Eclipse Modeling Tools 4.7.0.20170620-1800 (epp.package.modeling 4.7.0.20170620-1800) requires 'org.eclipse.platform.feature.group [4.7.0.v20170612-1255]' but it could not be found
  ERROR: org.eclipse.equinox.p2.director code=0 Missing requirement: Eclipse Modeling Tools 4.7.1.20170914-1200 (epp.package.modeling 4.7.1.20170914-1200) requires 'org.eclipse.platform.feature.group [4.7.1.v20170906-1700]' but it could not be found
  ERROR: org.eclipse.equinox.p2.director code=0 Missing requirement: Eclipse Modeling Tools 4.7.1.20171009-0537 (epp.package.modeling 4.7.1.20171009-0537) requires 'org.eclipse.platform.feature.group [4.7.1.v20171009-0410]' but it could not be found
  ERROR: org.eclipse.equinox.p2.director code=1 Cannot satisfy dependency:
    ERROR: org.eclipse.equinox.p2.director code=0 From: artificial_root 1.0.0.v1515170281933
    ERROR: org.eclipse.equinox.p2.director code=0 To: epp.package.modeling [4.7.0,4.8.0)

Took 3 seconds.
There are failed tasks.
Press Back to choose different settings or Cancel to abort.
Re: Error installing Eclipse modeling tools since Oxygen.2 [message #1779428 is a reply to message #1779351] Sun, 07 January 2018 10:14 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29545
Registered: July 2009
Senior Member
Using the Repository Explorer to look at http://download.eclipse.org/technology/epp/packages/oxygen I can see that there is a "<unit id='epp.package.modeling' version='4.7.2.20171218-0600'>" in that repo. That's the one that should be installed. When I test this myself, it works and does install exactly the version 4.7.2.20171218-0600.

So what I suspect is happening is that the Eclipse download server supports "transparent mirroring" so that it can avoid serving the large p2 content/artifact resources but rather redirects the requests to a mirror local to you. Such a mirror is presumed to be up-to-date, but if it isn't, you'd see old content metadata from an older version of the repository. That appears to be the case given the list of versions in your log is not the complete one. Unfortunately there is no way for Oomph to disable or affect this behavior of the server. Even the "Use Mirrors" check box has no impact on this; that only affects the internal behavior when fetching artifacts. So I'm really not sure what to suggest. If the Eclipse.org product catalog pointed at http://download.eclipse.org/releases/oxygen instead of http://download.eclipse.org/releases/oxygen/201712201001 then the install would likely succeed, but it would install Oxygen.1 rather than Oxygen.2 (and the Eclipse download server would need to serve up the metadata of each child of the composite which would be 4 times as much work for the server and 4 times as much delay for the user, or more if the server becomes overloaded as a result).

Perhaps this is a transient problem or intermittent depending on which mirror to which you are redirected?
Re: Error installing Eclipse modeling tools since Oxygen.2 [message #1779565 is a reply to message #1779428] Tue, 09 January 2018 16:17 Go to previous message
Lutz Wrage is currently offline Lutz WrageFriend
Messages: 135
Registered: July 2009
Senior Member
I had offline mode checked by accident. Clearing that flag fixed the issue.
Previous Topic:General Eclipse Installer questions
Next Topic:Install Oxygen / CDT / Oomph: Project Explorer shows 293 projects, org.eclipse.cdt etc.
Goto Forum:
  


Current Time: Sat Sep 22 10:41:36 GMT 2018

Powered by FUDForum. Page generated in 0.02214 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top