Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Java 9 problem with eclipse (installation problem ) - [solve ]
Java 9 problem with eclipse (installation problem ) - [solve ] [message #1778920] Sun, 24 December 2017 08:38 Go to next message
Lalit Solanki is currently offline Lalit SolankiFriend
Messages: 142
Registered: April 2015
Senior Member
Hi friends,

I am using eclipse - Kepler and now try to add java 9 but not install please help me .


Lalit

[Updated on: Thu, 04 January 2018 12:24]

Report message to a moderator

Re: Java 9 problem with eclipse (installation problem ) [message #1778923 is a reply to message #1778920] Sun, 24 December 2017 11:25 Go to previous messageGo to next message
Stephan Herrmann is currently offline Stephan HerrmannFriend
Messages: 1602
Registered: July 2009
Senior Member
You were trying to add the BETA support for Java 9, but (a) the BETA feature is obsolete (hence the update site has been disabled) and (b) Kepler cannot support Java 9, Oxygen is required.
So please install Oxygen.2, then no additional feature is needed for Java 9 support.
Re: Java 9 problem with eclipse (installation problem ) [message #1779250 is a reply to message #1778923] Thu, 04 January 2018 12:25 Go to previous messageGo to next message
Lalit Solanki is currently offline Lalit SolankiFriend
Messages: 142
Registered: April 2015
Senior Member
Hello Stephan Herrmann my problem is solved thank you.

Lalit
Re: Java 9 problem with eclipse (installation problem ) [message #1779524 is a reply to message #1779250] Tue, 09 January 2018 08:35 Go to previous messageGo to next message
Priya Arrora is currently offline Priya ArroraFriend
Messages: 3
Registered: November 2017
Junior Member
If your application makes use of APIs from other modules, you need to configure the JVM to make those modules available. The Eclipse IDE its itself a Java application that uses APIs from modules outside of that default group, so a little extra configuration is needed to make it run on Java 9.
Re: Java 9 problem with eclipse (installation problem ) - [solve ] [message #1781278 is a reply to message #1778920] Mon, 05 February 2018 12:42 Go to previous messageGo to next message
GIRIRAJ SHAH is currently offline GIRIRAJ SHAHFriend
Messages: 2
Registered: February 2018
Junior Member
index.php/fa/32004/0/Hello Lalit,

I would like to do same thing.

But I am unable to Load Kepler with Java 9.

I have configure vmargs in eclipse.ini file shown as below


--launcher.appendVmargs
-vm
C:\Program Files\Java\jdk-9\bin\javaw.exe
-vmargs
-Dosgi.requiredJavaVersion=1.8
--add-modules=ALL-SYSTEM

I am receiving error index.php/fa/32004/0/.

I am attaching the log file for the same.

Please Let me know the how many changes are required to run kepler on Java 9.


Thanks In Advance
Re: Java 9 problem with eclipse (installation problem ) - [solve ] [message #1781303 is a reply to message #1781278] Mon, 05 February 2018 20:29 Go to previous messageGo to next message
Stephan Herrmann is currently offline Stephan HerrmannFriend
Messages: 1602
Registered: July 2009
Senior Member
@Giriraj, to quote myself from above:
Quote:
Kepler cannot support Java 9, Oxygen is required.
Re: Java 9 problem with eclipse (installation problem ) - [solve ] [message #1781322 is a reply to message #1781303] Tue, 06 February 2018 04:26 Go to previous messageGo to next message
Lalit Solanki is currently offline Lalit SolankiFriend
Messages: 142
Registered: April 2015
Senior Member
Hi

@Giriraj

Stephan Herrmann is right.


Lalit
Re: Java 9 problem with eclipse (installation problem ) - [solve ] [message #1781368 is a reply to message #1781322] Tue, 06 February 2018 13:27 Go to previous message
GIRIRAJ SHAH is currently offline GIRIRAJ SHAHFriend
Messages: 2
Registered: February 2018
Junior Member
Hi,

@Stephan , @ Lalit Solanki

Thanks for quick replay.

I will start with Oxygen
Previous Topic:Formatter alignment vs indentation
Next Topic:IProgressMonitor missing
Goto Forum:
  


Current Time: Mon Jun 18 02:28:39 GMT 2018

Powered by FUDForum. Page generated in 0.02230 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top