Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » No preview on BIRT OXYGEN Report Developer-Problem with Build(Cannot preview reports)
No preview on BIRT OXYGEN Report Developer-Problem with Build [message #1778890] Fri, 22 December 2017 23:52 Go to next message
Dianne Evans is currently offline Dianne EvansFriend
Messages: 5
Registered: February 2017
Junior Member
I am not able to preview reports in BIRT.

I received confirmation from Kronos TeleStaff support (who is recommending that we use BIRT for custom reports) that it is a problem with the build when using the latest Eclipse Oxygen on Windows 10.

"When you preview it, Eclypse will generate this error: Exception:java.lang.NoClassDefFoundError: org/eclipse/jetty/util/Decorator at org.eclipse.birt.report.viewer.utilities.ViewerWebApp.start(ViewerWebApp.java:40) at org.eclipse.birt.report.viewer.utilities.AppServerWrapper.startJettyServer(AppServerWrapper.java:256) at org.eclipse.birt.report.viewer.utilities.AppServerWrapper.start(AppServerWrapper.java:155) at org.eclipse.birt.report.viewer.utilities.WebappAccessor.start(WebappAccessor.java:72) at org.eclipse.birt.report.viewer.utilities.WebViewer.startWebApp(WebViewer.java:827) at org.eclipse.birt.report.viewer.utilities.WebViewer.display(WebViewer.java:1078) at org.eclipse.birt.report.viewer.utilities.WebViewer.display(WebViewer.java:1073) at org.eclipse.birt.report.designer.ui.actions.PreviewSupport.preview(PreviewSupport.java:402) at org.eclipse.birt.report.designer.ui.actions.PreviewSupport$3.widgetSelected(PreviewSupport.java:245) at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:249) at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:86) at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4428) at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1079) at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4238) at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3817) at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$5.run(PartRenderingEngine.java:1150) at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336) at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1039) at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:153) at org.eclipse.ui.internal.Workbench.lambda$3(Workbench.java:680) at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336) at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:594) at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148) at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:151) at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196) at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134) at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243) at sun.reflect.NativeMethodAccessorImpl.invoke0(null:-2) at sun.reflect.NativeMethodAccessorImpl.invoke(null:-1) at sun.reflect.DelegatingMethodAccessorImpl.invoke(null:-1) at java.lang.reflect.Method.invoke(null:-1) at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:653) at org.eclipse.equinox.launcher.Main.basicRun(Main.java:590) at org.eclipse.equinox.launcher.Main.run(Main.java:1499) Caused by: java.lang.ClassNotFoundException: org.eclipse.jetty.util.Decorator cannot be found by org.eclipse.jetty.servlet_9.4.5.v20170502 I have uploaded the full stack trace in the attached file : eclipse error.txt.

It looks like the latest org.eclipse.jetty.servlet_9.4.5.v20170502, they have have removed the class org.eclipse.jetty.util.Decorator. "

[Updated on: Wed, 27 December 2017 16:13]

Report message to a moderator

Re: No preview on BIRT OXYGEN Report Developer-Problem with Build [message #1779888 is a reply to message #1778890] Mon, 15 January 2018 11:41 Go to previous messageGo to next message
Jeffrey Zelt is currently offline Jeffrey ZeltFriend
Messages: 2
Registered: January 2018
Junior Member
I too am not able to preview reports in BIRT. Eclipse complains because of the same error:

java.lang.NoClassDefFoundError: org/eclipse/jetty/util/Decorator
	at org.eclipse.birt.report.viewer.utilities.ViewerWebApp.start(ViewerWebApp.java:40)
	...
Caused by: java.lang.ClassNotFoundException: org.eclipse.jetty.util.Decorator cannot be found by org.eclipse.jetty.servlet_9.4.5.v20170502
	at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:484)
	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:395)
	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:387)
	at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:150)
	at java.base/java.lang.ClassLoader.loadClass(Unknown Source)
	... 37 more


I am running Eclipse Oxygen.2 (4.7.2). I have the same problem running Eclipse/BIRT from Windows 10 and Ubuntu 16.04.

Is the BIRT Report Designer now basically broken?

I cannot even find an entry in the Eclipse Bugzilla for this problem, even though Oxygen has already had two big updates. Does this mean that BIRT is on its way out? Is it no longer supported? This will cause huge problems for our company.
Re: No preview on BIRT OXYGEN Report Developer-Problem with Build [message #1780224 is a reply to message #1779888] Thu, 18 January 2018 18:04 Go to previous messageGo to next message
Brock Freeman is currently offline Brock FreemanFriend
Messages: 1
Registered: January 2018
Junior Member
I am also having this same issue. Has anyone found a workaround, or do we need to go back to a previous version?
Re: No preview on BIRT OXYGEN Report Developer-Problem with Build [message #1780469 is a reply to message #1778890] Mon, 22 January 2018 22:48 Go to previous messageGo to next message
Dianne Evans is currently offline Dianne EvansFriend
Messages: 5
Registered: February 2017
Junior Member
I reverted back to Mars Release 4.5.0 and this resolved the issue.
Re: No preview on BIRT OXYGEN Report Developer-Problem with Build [message #1780481 is a reply to message #1780224] Tue, 23 January 2018 07:29 Go to previous message
Jeffrey Zelt is currently offline Jeffrey ZeltFriend
Messages: 2
Registered: January 2018
Junior Member
I have found no workaround, so I too have reverted to an earlier version. I have reverted to neon.3 (Eclipse 4.6.3), which is the last version I have worked with that has functioned OK for me.
Previous Topic:Unable to run report - Permission denied
Next Topic:How to export to RPTLIBRARY and reuse it
Goto Forum:
  


Current Time: Sat Feb 24 03:42:17 GMT 2018

Powered by FUDForum. Page generated in 0.01471 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software