Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » No preview on BIRT OXYGEN Report Developer-Problem with Build(Cannot preview reports)
No preview on BIRT OXYGEN Report Developer-Problem with Build [message #1778890] Fri, 22 December 2017 23:52 Go to next message
Dianne Evans is currently offline Dianne EvansFriend
Messages: 5
Registered: February 2017
Junior Member
I am not able to preview reports in BIRT.

I received confirmation from Kronos TeleStaff support (who is recommending that we use BIRT for custom reports) that it is a problem with the build when using the latest Eclipse Oxygen on Windows 10.

"When you preview it, Eclypse will generate this error: Exception:java.lang.NoClassDefFoundError: org/eclipse/jetty/util/Decorator at org.eclipse.birt.report.viewer.utilities.ViewerWebApp.start(ViewerWebApp.java:40) at org.eclipse.birt.report.viewer.utilities.AppServerWrapper.startJettyServer(AppServerWrapper.java:256) at org.eclipse.birt.report.viewer.utilities.AppServerWrapper.start(AppServerWrapper.java:155) at org.eclipse.birt.report.viewer.utilities.WebappAccessor.start(WebappAccessor.java:72) at org.eclipse.birt.report.viewer.utilities.WebViewer.startWebApp(WebViewer.java:827) at org.eclipse.birt.report.viewer.utilities.WebViewer.display(WebViewer.java:1078) at org.eclipse.birt.report.viewer.utilities.WebViewer.display(WebViewer.java:1073) at org.eclipse.birt.report.designer.ui.actions.PreviewSupport.preview(PreviewSupport.java:402) at org.eclipse.birt.report.designer.ui.actions.PreviewSupport$3.widgetSelected(PreviewSupport.java:245) at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:249) at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:86) at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4428) at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1079) at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4238) at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3817) at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$5.run(PartRenderingEngine.java:1150) at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336) at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1039) at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:153) at org.eclipse.ui.internal.Workbench.lambda$3(Workbench.java:680) at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336) at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:594) at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148) at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:151) at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196) at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134) at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243) at sun.reflect.NativeMethodAccessorImpl.invoke0(null:-2) at sun.reflect.NativeMethodAccessorImpl.invoke(null:-1) at sun.reflect.DelegatingMethodAccessorImpl.invoke(null:-1) at java.lang.reflect.Method.invoke(null:-1) at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:653) at org.eclipse.equinox.launcher.Main.basicRun(Main.java:590) at org.eclipse.equinox.launcher.Main.run(Main.java:1499) Caused by: java.lang.ClassNotFoundException: org.eclipse.jetty.util.Decorator cannot be found by org.eclipse.jetty.servlet_9.4.5.v20170502 I have uploaded the full stack trace in the attached file : eclipse error.txt.

It looks like the latest org.eclipse.jetty.servlet_9.4.5.v20170502, they have have removed the class org.eclipse.jetty.util.Decorator. "

[Updated on: Wed, 27 December 2017 16:13]

Report message to a moderator

Re: No preview on BIRT OXYGEN Report Developer-Problem with Build [message #1779888 is a reply to message #1778890] Mon, 15 January 2018 11:41 Go to previous messageGo to next message
Jeffrey Zelt is currently offline Jeffrey ZeltFriend
Messages: 4
Registered: January 2018
Junior Member
I too am not able to preview reports in BIRT. Eclipse complains because of the same error:

java.lang.NoClassDefFoundError: org/eclipse/jetty/util/Decorator
	at org.eclipse.birt.report.viewer.utilities.ViewerWebApp.start(ViewerWebApp.java:40)
	...
Caused by: java.lang.ClassNotFoundException: org.eclipse.jetty.util.Decorator cannot be found by org.eclipse.jetty.servlet_9.4.5.v20170502
	at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:484)
	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:395)
	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:387)
	at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:150)
	at java.base/java.lang.ClassLoader.loadClass(Unknown Source)
	... 37 more


I am running Eclipse Oxygen.2 (4.7.2). I have the same problem running Eclipse/BIRT from Windows 10 and Ubuntu 16.04.

Is the BIRT Report Designer now basically broken?

I cannot even find an entry in the Eclipse Bugzilla for this problem, even though Oxygen has already had two big updates. Does this mean that BIRT is on its way out? Is it no longer supported? This will cause huge problems for our company.
Re: No preview on BIRT OXYGEN Report Developer-Problem with Build [message #1780224 is a reply to message #1779888] Thu, 18 January 2018 18:04 Go to previous messageGo to next message
Brock Freeman is currently offline Brock FreemanFriend
Messages: 1
Registered: January 2018
Junior Member
I am also having this same issue. Has anyone found a workaround, or do we need to go back to a previous version?
Re: No preview on BIRT OXYGEN Report Developer-Problem with Build [message #1780469 is a reply to message #1778890] Mon, 22 January 2018 22:48 Go to previous messageGo to next message
Dianne Evans is currently offline Dianne EvansFriend
Messages: 5
Registered: February 2017
Junior Member
I reverted back to Mars Release 4.5.0 and this resolved the issue.
Re: No preview on BIRT OXYGEN Report Developer-Problem with Build [message #1780481 is a reply to message #1780224] Tue, 23 January 2018 07:29 Go to previous messageGo to next message
Jeffrey Zelt is currently offline Jeffrey ZeltFriend
Messages: 4
Registered: January 2018
Junior Member
I have found no workaround, so I too have reverted to an earlier version. I have reverted to neon.3 (Eclipse 4.6.3), which is the last version I have worked with that has functioned OK for me.
Re: No preview on BIRT OXYGEN Report Developer-Problem with Build [message #1784032 is a reply to message #1779888] Wed, 21 March 2018 19:18 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3223
Registered: July 2009
Senior Member

Jeffrey Zelt wrote on Mon, 15 January 2018 06:41
I cannot even find an entry in the Eclipse Bugzilla for this problem, even though Oxygen has already had two big updates.

Has anyone actually reported this as a bug in Bugzilla yet? You would do so at https://bugs.eclipse.org/bugs/enter_bug.cgi?classification=BIRT .


Nitin Dahyabhai
Eclipse Web Tools Platform

[Updated on: Wed, 21 March 2018 20:15]

Report message to a moderator

Re: No preview on BIRT OXYGEN Report Developer-Problem with Build [message #1784064 is a reply to message #1784032] Thu, 22 March 2018 08:29 Go to previous messageGo to next message
Jeffrey Zelt is currently offline Jeffrey ZeltFriend
Messages: 4
Registered: January 2018
Junior Member
I realize that we, as BIRT users, have a certain responsibility to report bugs if we expect to have them fixed by the BIRT developers. But the problem reported here in this topic describes a complete inability to use BIRT in the Eclipse Oxygen release for report development. I cannot believe that BIRT developers can be unaware of this problem.

What this actually looks like, and I am not an advocate of conspiracy theories, is that there is no BIRT development at the moment. It seems that the main sponsor, Actuate, has pulled the plug on development. All of their online resources are either dead links or redirect to useless pages.

I really, really hope that this is not the beginning of a long slow death of BIRT because it is a very powerful and useful reporting platform. It does not need a large numer of new bells and whistles, but it does need to be updated continually to run in the most recent Eclipse distributions; otherwise, no companies will choose BIRT for future reporting needs.

I can see that the master branch in the BIRT GitHub repository does mention the next version of Eclipse (4.8 - Photon), but it is not clear to me if there is still serious development work being performed on BIRT:

https://github.com/eclipse/birt/tree/master

Does anyone know if BIRT is currently being developed and whether we should expect it to work with Eclipse 4.8 (Photon)?
Re: No preview on BIRT OXYGEN Report Developer-Problem with Build [message #1784069 is a reply to message #1784064] Thu, 22 March 2018 08:52 Go to previous messageGo to next message
Jeffrey Zelt is currently offline Jeffrey ZeltFriend
Messages: 4
Registered: January 2018
Junior Member
There does seem to be an understanding that BIRT 4.7 does not work properly for Eclipse 4.7. Look at the official Download page for BIRT here:

http://download.eclipse.org/birt/downloads/

The title of the first section on this page is: "Latest BIRT Designer Release Build: 4.7.0". However, the link associated with the "Download Now" button is:

https://www.eclipse.org/downloads/packages/eclipse-ide-java-and-report-developers/neonr ,

This downloads the Eclipse distribution for version 4.6 (Neon), not 4.7 (Oxygen). This Neon distribution does work fine for me.

This may only be circumstance evidence of the recognition that BIRT does not work properly with Eclipse 4.7. At the very least, it would indicate that no one is seriously maintaining the Eclipse web pages. So which is it:


  1. BIRT is not being actively developed?
  2. Eclipse.org web pages are not being maintained?

Re: No preview on BIRT OXYGEN Report Developer-Problem with Build [message #1784626 is a reply to message #1778890] Fri, 30 March 2018 17:16 Go to previous messageGo to next message
Mat Booth is currently offline Mat BoothFriend
Messages: 1
Registered: March 2018
Junior Member
Someone in the IRC channel had some insight on this, but was unable to post to the forums:

Quote:

[18:10:07] <laidback_01> perhaps someone else can post this... the ticket of concern is : https://www.eclipse.org/forums/index.php/t/1090767/
[18:10:24] <laidback_01> I can't use Preview either. Don't care. I have a workaround that's perfect
[18:10:46] <laidback_01> the workaround is to install the viewer as http://wiki.eclipse.org/BirtPOJO_Viewer_Tomcat_Deployment
[18:11:23] <laidback_01> and put my project into a git repo. I then have the tomcat dir under the birt/ directory be a clone of that repo
[18:11:32] <laidback_01> root cron pulls repo every minute
[18:11:57] * jmaury1 has quit (Quit: Leaving.)
[18:12:22] <laidback_01> it's crude, but i get to see the real deal, it's a production replicat - ideal for me. Has the side affect of forcing me to commit MUCH more often than I normally would, which is a good thing for me.
[18:12:56] <laidback_01> anyway, it works a charm, I can use the latest build of Oxygen, let Eclipse update itself, I don't worry about BIRT, it just works, etc, etc.
[18:13:13] <mbooth> laidback_01: I can post this, with a pointer to the IRC channel if they need further help of course :-)
[18:14:22] <laidback_01> okay, cool. I'm on linux, presumably this will work regardless of O/S, but i've not tested on windows or anything. I dev in linux, deploy to FreeBSD


Feel free to join the conversation in the #eclipse channel on Freenode.
Re: No preview on BIRT OXYGEN Report Developer-Problem with Build [message #1784903 is a reply to message #1784626] Thu, 05 April 2018 13:34 Go to previous message
Bahram Sanaei is currently offline Bahram SanaeiFriend
Messages: 1
Registered: April 2018
Junior Member
You can check the Eclipse bugzilla 517662. I already provided the solution for this exception issue.

https://bugs.eclipse.org/bugs/show_bug.cgi?id=517662
Previous Topic:Eclipse Oxygen - ReporEngine.openReportDesign( reportFile ); fails
Next Topic:BIRT Table
Goto Forum:
  


Current Time: Thu Aug 16 16:29:28 GMT 2018

Powered by FUDForum. Page generated in 0.02717 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top