Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » MPartDescriptor has empty handler list(MPartDescriptor has no handlers at runtime although defined in model fragment)
MPartDescriptor has empty handler list [message #1778847] Fri, 22 December 2017 12:56
Gernot Krause is currently offline Gernot KrauseFriend
Messages: 22
Registered: June 2014
Junior Member
Hi there!

For my RCP I have an e4 application model with a part descriptor. I attached 3 handlers to it below the 'Handlers' section

When I create a part from the descriptor at runtime the handlers are not triggered. Debugging the part creation reveals that the MPartDescriptor object has none of my handlers attached at runtime (empty list returned from .getHandlers() ).

Can someone please help or give a hint what might be wrong?

Thx,
Gernot.

	MPart editor = partService.createPart(partDescriptor.getElementId());
	editor.setContributionURI(partDescriptor.getContributionURI());

	// DEBUG
	partDescriptor.getHandlers();		// --> returns empty list

	partStack.getChildren().add(editor);
	partService.activate(editor);

[Updated on: Fri, 22 December 2017 13:29]

Report message to a moderator

Previous Topic:e4.ui.progress final version?
Next Topic:Reusing eclipse built in dark syntax theme
Goto Forum:
  


Current Time: Sun Jun 24 05:15:24 GMT 2018

Powered by FUDForum. Page generated in 0.01814 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top