Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse installation errors(I am getting Eclipse installation errors)
Eclipse installation errors [message #1778623] Tue, 19 December 2017 00:09 Go to next message
Des Kenny is currently offline Des KennyFriend
Messages: 1
Registered: December 2017
Junior Member
See details of error below

Any ideas, most appreciated.

Thanks

Des
============================================
java.lang.NoClassDefFoundError: Could not initialize class org.eclipse.oomph.jreinfo.JREManager
at org.eclipse.oomph.setup.internal.installer.SimpleVariablePage.createContent(SimpleVariablePage.java:344)
at org.eclipse.oomph.setup.internal.installer.SimpleInstallerPage.<init>(SimpleInstallerPage.java:91)
at org.eclipse.oomph.setup.internal.installer.SimpleVariablePage.<init>(SimpleVariablePage.java:267)
at org.eclipse.oomph.setup.internal.installer.SimpleInstallerDialog.createUI(SimpleInstallerDialog.java:237)
at org.eclipse.oomph.setup.internal.installer.AbstractSimpleDialog.show(AbstractSimpleDialog.java:139)
at org.eclipse.oomph.setup.internal.installer.InstallerApplication.run(InstallerApplication.java:250)
at org.eclipse.oomph.setup.internal.installer.InstallerApplication.start(InstallerApplication.java:408)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:653)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:590)
at org.eclipse.equinox.launcher.Main.run(Main.java:1499)

===========================================

Java was started but returned exit code=1
-Xms256M
-Xmx1024M
-XstartOnFirstThread
-Dorg.eclipse.swt.internal.carbon.smallFonts
-Djava.class.path=/private/var/folders/gy/n_3fr6q95fd2_c_dc6lhyxt00000gn/T/AppTranslocation/0C61BD41-767C-4CAC-8E57-B7561B0BC157/d/Eclipse Installer.app/Contents/MacOS//../Eclipse/plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar
-os macosx
-ws cocoa
-arch x86_64
-showsplash
-launcher /private/var/folders/gy/n_3fr6q95fd2_c_dc6lhyxt00000gn/T/AppTranslocation/0C61BD41-767C-4CAC-8E57-B7561B0BC157/d/Eclipse Installer.app/Contents/MacOS/eclipse-inst
-name Eclipse Installer
--launcher.library /private/var/folders/gy/n_3fr6q95fd2_c_dc6lhyxt00000gn/T/AppTranslocation/0C61BD41-767C-4CAC-8E57-B7561B0BC157/d/Eclipse Installer.app/Contents/MacOS//../Eclipse/plugins/org.eclipse.equinox.launcher.cocoa.macosx.x86_64_1.1.500.v20170531-1133/eclipse_1624.so
-startup /private/var/folders/gy/n_3fr6q95fd2_c_dc6lhyxt00000gn/T/AppTranslocation/0C61BD41-767C-4CAC-8E57-B7561B0BC157/d/Eclipse Installer.app/Contents/MacOS//../Eclipse/plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar
--launcher.appendVmargs
-data @noDefault
-keyring /Users/deskenny/.eclipse_keyring
-vm /Library/Java/JavaVirtualMachines/jdk1.8.0_151.jdk/Contents/Home/bin/../jre/lib/server/libjvm.dylib
-vmargs
-Xms256M
-Xmx1024M
-XstartOnFirstThread
-Dorg.eclipse.swt.internal.carbon.smallFonts
-Djava.class.path=/private/var/folders/gy/n_3fr6q95fd2_c_dc6lhyxt00000gn/T/AppTranslocation/0C61BD41-767C-4CAC-8E57-B7561B0BC157/d/Eclipse Installer.app/Contents/MacOS//../Eclipse/plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar
Re: Eclipse installation errors [message #1778627 is a reply to message #1778623] Tue, 19 December 2017 02:25 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3201
Registered: July 2009
Senior Member

Can you walk us through the steps you performed before the error happened?

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Eclipse installation errors [message #1778862 is a reply to message #1778627] Fri, 22 December 2017 14:37 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 29452
Registered: July 2009
Senior Member
The locations look very strange. I seem to recall that on Mac you have to be careful not to run any type of Eclipse application from a temporary/download folder because some "randomizer thing" messes with the paths that result in classes not being found. Unpack the installer in some more permanent location before running it.
Previous Topic:An error has occurred. See the log file
Next Topic:"Cannot be resolved to a type" error
Goto Forum:
  


Current Time: Tue Jul 17 17:39:00 GMT 2018

Powered by FUDForum. Page generated in 0.02947 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top