Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » How to install new software for eclipse mips64el platform(via Eclipse IDE Help->Install New Software to expand Eclipse IDE function)
How to install new software for eclipse mips64el platform [message #1777626] Fri, 01 December 2017 03:32 Go to next message
vans wang is currently offline vans wangFriend
Messages: 3
Registered: November 2017
Junior Member
I have got an eclipse source rpm package from the following link and built out some RPMs package for my platform.


My Platform info:
OS: Fedora 21
Architecture: mps64el
Kernel: 3.10.84
Eclipse:Luna SR1

Now I want to install some software to expand my eclipse IDE. The plugins (such as "Eclipse IDE for java Developer") installed form menu Help--> Install new software doesn't fit my platform.

Anyone can give some suggestions for my situation? and where can I get the source code for the following plugins so that I could build form source。
(1)Eclipse for Java EE Developers
(2)Eclipse for maven project



The attachment is the patch for my platform to build form eclipse-4.4.1-5.src.rpm。
Re: How to install new software for eclipse mips64el platform [message #1777636 is a reply to message #1777626] Fri, 01 December 2017 07:33 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29034
Registered: July 2009
Senior Member
You should install Eclipse from https://www.eclipse.org/downloads/ because these rpm packages are extremely out-dated.

JDT and various other projects have an Oomph setup so like the platform, you can follow the analog of these instructions to setup a JDT development environment: https://wiki.eclipse.org/Platform_UI/How_to_Contribute#Setting_up_your_SDK_for_code_contributions

For m2e it looks like you'll need to do the setup manually: https://www.eclipse.org/m2e/m2e-community.html
Re: How to install new software for eclipse mips64el platform [message #1777741 is a reply to message #1777636] Mon, 04 December 2017 02:23 Go to previous messageGo to next message
vans wang is currently offline vans wangFriend
Messages: 3
Registered: November 2017
Junior Member
@Ed Merks, Many thanks for your reply. Above all , following you first link I get the package eclipse-jee-luna-SR1-linux-gtk-x86_64.tar.gz, from this link https://www.eclipse.org/downloads/packages/release/Luna/SR1.

Because my main Eclipse IDE version is Eclipse Luna SR1, and I just wanna Expand Eclipse Luna SR1 features at the moment . The above tar ball is the product built for x86-64 platform and I can not find for my target platform --- mips64el.

As for m2e, I have got the source code form github via link: https://github.com/eclipse/m2e-core. I am building the source and will create a eclipse maven project for testing later. I guess the problem is not big.

@Ed Merks , I know Eclipse Luna SR1 is out-dated and Lack of maintenance .What can I do for this platform to get a lasting update on the Eclipse IDE software? I got Eclipse IDE software from open source and built out for mips64el platfom. I wanna commit the patch to you. and hope there will be a small branch for mips64el just like X86-64. but I don't know what shall I do for this aim?
Re: How to install new software for eclipse mips64el platform [message #1777742 is a reply to message #1777636] Mon, 04 December 2017 02:23 Go to previous message
vans wang is currently offline vans wangFriend
Messages: 3
Registered: November 2017
Junior Member
No Message Body

[Updated on: Mon, 04 December 2017 06:10]

Report message to a moderator

Previous Topic:Runnable JAR file export | JAR creation failed.
Next Topic:xml validation occurs by default in Eclipse neon
Goto Forum:
  


Current Time: Thu Dec 14 04:26:18 GMT 2017

Powered by FUDForum. Page generated in 0.03042 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software