Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » e4 Compatibility Mode > MinMaxAddon
e4 Compatibility Mode > MinMaxAddon [message #1777607] Thu, 30 November 2017 17:28 Go to next message
Laurent CARON is currently offline Laurent CARONFriend
Messages: 6
Registered: June 2011
Junior Member
Hello,

I'm currently doing a migration of an old Eclipse 3.7 application to e4.
Currently we use the compatibility mode, and I've got a problem.

I want to "customize" the default MinMaxAddon.

I created a new add-on, then I declared it in my .e4xmi file.

But the processors of the bundle org.eclipse.e4.ui.workbench.addons.swt are executed, so at runtime 2 addons are "running" : the "default" one and my custom one.

What is the right way to override the default MinMaxAdd ? I thought about adding a processor that removes the default processor "MinMaxProcessor", but I don't know if it a good idea...

Thank you for your help.
Re: e4 Compatibility Mode > MinMaxAddon [message #1777696 is a reply to message #1777607] Fri, 01 December 2017 16:21 Go to previous message
Laurent CARON is currently offline Laurent CARONFriend
Messages: 6
Registered: June 2011
Junior Member
I finally found a solution, which is pretty brutal.
We have the chance to build our application with our own Nexus repository.

What i've done :
- I modified the META-INF directory delete the files eclipse_.rsa and eclipse._sf
- I removed all SHA-256-Digest: lines in the manifest.mf
- Then I modified plugin.xml to remove the lines

<processor
beforefragment="true"
class="org.eclipse.e4.ui.workbench.addons.swt.MinMaxProcessor">
</processor>

Now the default min-max add on is no longer initialized...

Bad solution because I'll have to do the same on the next release of RCP Framework, but I hope that the full e4 migration will be done next summer.
Previous Topic:How to keep IDs consistent
Next Topic:E4 Application Model issues
Goto Forum:
  


Current Time: Sat Sep 22 16:29:40 GMT 2018

Powered by FUDForum. Page generated in 0.01548 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top