Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Eclipse 4.7 and Tycho
Eclipse 4.7 and Tycho [message #1777445] Wed, 29 November 2017 12:36 Go to next message
Mariano Camarzana is currently offline Mariano CamarzanaFriend
Messages: 17
Registered: July 2017
Junior Member
Hello everyone, I recently migrated an application from Eclipse 3.7 to Eclipse 4.7 using the Compatibility Layer. Now add the use of Tycho to deploy the application. The application defines target platform and features.
I managed to get all the errors, I only have the following:

No solution found because the problem is unsatisfiable.: [Unable to satisfy dependency from com.zetti.ftpos.features.feature.group 1.0.0.qualifier to com.zetti.ftpos.product.deploy 0.0.0.; Unable to satisfy dependency from org.eclipse.jdt.core 3.13.0.v_OTDT_r260_201706061122 to org.eclipse.objectteams.otdt.core.patch.feature.group [2.0.0,3.0.0).; No solution found because the problem is unsatisfiable.]

I have investigated that it is recommended to add dependency to the parent POM

<properties>
		<tycho-version>1.0.0</tycho-version>
		<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
	</properties>

	<build>
		<plugins>
			<plugin>
				<groupId>org.eclipse.tycho</groupId>
				<artifactId>target-platform-configuration</artifactId>
				<version>${tycho-version}</version>
				<configuration>
	            <dependency-resolution>
	               <extraRequirements>
	                   <requirement>
	                       <type>p2-installable-unit</type>
	                       <id>org.eclipse.jdt.feature.group</id>
	                       <versionRange>0.0.0</versionRange>
	                   </requirement>
	               </extraRequirements>
	           </dependency-resolution>				
                    <target>
                        <artifact>
                            <groupId>com.zetti.ftpos</groupId>
                            <artifactId>ftpos</artifactId>
                            <version>1.0.0-SNAPSHOT</version>
                        </artifact>
                    </target>				
					<environments>
						<environment>
							<os>linux</os>
							<ws>gtk</ws>
							<arch>x86</arch>
						</environment>
						<environment>
							<os>linux</os>
							<ws>gtk</ws>
							<arch>x86_64</arch>
						</environment>
						<environment>
							<os>win32</os>
							<ws>win32</ws>
							<arch>x86</arch>
						</environment>
						<environment>
							<os>win32</os>
							<ws>win32</ws>
							<arch>x86_64</arch>
						</environment>
						<environment>
							<os>macosx</os>
							<ws>cocoa</ws>
							<arch>x86_64</arch>
						</environment>
					</environments>
				</configuration>
			</plugin>
            <plugin>
                <groupId>org.eclipse.tycho</groupId>
                <artifactId>tycho-maven-plugin</artifactId>
                <version>${tycho-version}</version>
                <extensions>true</extensions>
            </plugin>
		</plugins>
	</build>


Even so I continue with the same error

Some clue?

Thanks in advance!.

Eclipse 4.7 Oxygen
Tycho 1.0.0
Java 1.8

Mariano

[Updated on: Wed, 29 November 2017 19:56]

Report message to a moderator

Re: Eclipse 4.7 and Tycho [message #1777506 is a reply to message #1777445] Wed, 29 November 2017 19:02 Go to previous messageGo to next message
Daniel   is currently offline Daniel Friend
Messages: 29
Registered: July 2014
Junior Member
Hi there,

please be aware that this just is a very wild and uninformed guess ... are you sure you really need or want to follow through with "satisfying this dependency"?

i just did search in google with the term "org.eclipse.objectteams.otdt.core.patch" and arrived at https://bugs.eclipse.org/bugs/show_bug.cgi?id=350133

If i understand the comments correctly they talk about an update path in 3.7 which allows for unneeded/-necessary/-wanted installation of said patch feature.

Maybe you could just continue without the burden of satisfying this dependency?

cheers
Daniel

/edit:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=350133#c40
https://bugs.eclipse.org/bugs/show_bug.cgi?id=350133#c55

this comments and the surrounding talk might also be helpful

[Updated on: Wed, 29 November 2017 19:12]

Report message to a moderator

Re: Eclipse 4.7 and Tycho [message #1777569 is a reply to message #1777506] Thu, 30 November 2017 11:49 Go to previous messageGo to next message
Mariano Camarzana is currently offline Mariano CamarzanaFriend
Messages: 17
Registered: July 2017
Junior Member
Thanks for answering, I had already read the error that you mention, the problem in this case is that it is the only mistake I have to execute the deployment by Tycho. When throwing the exception the deploy is stopped, that's why I have to fix it.

Best Regards

Mariano



  • Attachment: tycho.log
    (Size: 138.31KB, Downloaded 30 times)
Re: Eclipse 4.7 and Tycho [message #1777592 is a reply to message #1777445] Thu, 30 November 2017 16:00 Go to previous messageGo to next message
Daniel   is currently offline Daniel Friend
Messages: 29
Registered: July 2014
Junior Member
Please be aware of my humble disclaimer that i do not concern me as someone who should be answering your question ... i am really not well experienced in the workings of tycho ... i merely try to "think alongside" and reply with my thoughts. It would be great if you would get answers from someone more experienced with tycho than myself!

Concerning your problem:
What log does your build produce if you apply the dependency-filter mentioned in https://bugs.eclipse.org/bugs/show_bug.cgi?id=350133#c40 adjusted to the version of jdt.core in your logs?

<plugin>
   <groupId>org.eclipse.tycho</groupId>
   <artifactId>target-platform-configuration</artifactId>
   <version>${tycho-version}</version>
   <configuration>
      <filters>
         <filter>
            <type>eclipse-plugin</type>
            <id>org.eclipse.jdt.core</id>
            <restrictTo>
               <version>3.13.0.v_OTDT_r260_201706061122</version>
            </restrictTo>
         </filter>
      </filters>
   </configuration>
</plugin>

https://wiki.eclipse.org/Tycho/Target_Platform#Filtering

Cheers
Daniel
Re: Eclipse 4.7 and Tycho [message #1777608 is a reply to message #1777592] Thu, 30 November 2017 17:39 Go to previous messageGo to next message
Mariano Camarzana is currently offline Mariano CamarzanaFriend
Messages: 17
Registered: July 2017
Junior Member
I tried your advice but I still have the same error.
Attached the log.


Best Regards
Mariano
  • Attachment: tycho.log
    (Size: 139.28KB, Downloaded 35 times)
Re: Eclipse 4.7 and Tycho [message #1777619 is a reply to message #1777608] Thu, 30 November 2017 21:02 Go to previous messageGo to next message
Daniel   is currently offline Daniel Friend
Messages: 29
Registered: July 2014
Junior Member
I think i "censored" out a relevant detail and also replaced the version wrong ... i think i put in "offending" plugin-version-stuff instead of the "wanted" plugin version. You probably need to find out the version of org.eclipse.jdt.core like he mentioned - adapt to other release trains (e.g. probably oxygen?) / service releases (e.g. SR1a?) and use that instead of my example.

Also I left out Jans commented advice . Jan mentioned:
<!-- this is the version for Kepler SR1, have to adapt for other release trains/service releases -->
<restrictTo>
    <version>3.9.1.v20130905-0837</version>
</restrictTo>

I still think filtering might be able to help you ... but i have no clue how to find out said adapted version.

cheers
Daniel

//edit:
despite my uninitiated guesses you might also try to find help in the tycho-users mailing list. https://accounts.eclipse.org/mailing-list/tycho-user

[Updated on: Thu, 30 November 2017 21:06]

Report message to a moderator

Re: Eclipse 4.7 and Tycho [message #1777680 is a reply to message #1777619] Fri, 01 December 2017 12:22 Go to previous messageGo to next message
Mariano Camarzana is currently offline Mariano CamarzanaFriend
Messages: 17
Registered: July 2017
Junior Member
Thank you very much Daniel !, you were right, I needed to set the jdt.core version correctly.

 <filters>
        <filter>
                  <type>eclipse-plugin</type>
                   <id>org.eclipse.jdt.core</id>
                   <restrictTo>
                   <version>3.13.0.v20170516-1929</version>
                   </restrictTo>
        </filter>
</filters>


I still can not perform the deploy because of the error:
Bundle-ClassPath entry icu-data.jar does not exist in /.m2/repository/p2/osgi/bundle/com.ibm.icu/58.2.0.v20170418-1837/com.ibm.icu-58.2.0.v20170418-1837.jar

Try a couple of tips that they mention in
http://tycho-user.eclipse.narkive.com/1LXKrPt0/nested-jars-in-dependency-issue
But it does not work...
Any clues?.

Best Regards.

Mariano.

[Updated on: Fri, 01 December 2017 19:34]

Report message to a moderator

Re: Eclipse 4.7 and Tycho [message #1777803 is a reply to message #1777680] Mon, 04 December 2017 17:26 Go to previous message
Mariano Camarzana is currently offline Mariano CamarzanaFriend
Messages: 17
Registered: July 2017
Junior Member
To eliminate this error, what I did was add the package to the p2 site generated:

<artifact> <id> com.ibm.icu:icu4j:58.2 </ id> <override> true </ override> </ artifact>


Instead of importing the whole org.eclipse.ui package, what I did was import the specific package that requires e.g. org.eclipse.ui.ide.
I hope it serves someone.

Best Regards.
Mariano.

[Updated on: Tue, 05 December 2017 11:48]

Report message to a moderator

Previous Topic:Eclipse RCP and Java 9 results in NoClassDefFoundError
Next Topic:Is it possible to simulataneously launch multiple instances of an RCP with different ini file
Goto Forum:
  


Current Time: Sat Sep 22 06:49:41 GMT 2018

Powered by FUDForum. Page generated in 0.03941 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top