Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Internal error occurred during: "Launching Launch Runtime Eclipse"
Internal error occurred during: "Launching Launch Runtime Eclipse" [message #1776507] Fri, 17 November 2017 06:50 Go to next message
serio adamo is currently offline serio adamoFriend
Messages: 24
Registered: September 2017
Junior Member
This is a very strange issue:
Yesterday I used xtext for my project and it works fine.
Today I open the eclipse, select my xtext project, Run as Eclipse Application, then error occurred:

An internal error occurred during: "Launching Eclipse Application".
org.eclipse.jdt.launching.JavaRuntime.isModularJava(Lorg/eclipse/jdt/launching/IVMInstall;)Z
index.php/fa/31294/0/

I have no idea what cause this issue. (perhaps my environment problem?)
So I start a clean win7 snapshot image in my vmware.

1. install jdk-8u101-windows-x64.exe
2. install eclipse-java-oxygen-R-win32-x86_64
3. run eclipse and install new software for xtext
Oxygen - http://download.eclipse.org/releases/oxygen
Modeling/Xtext Complete SDK 2.120.v20170519-1412
4. Create Xtext/Xtext Project (org.xtext.example.mydsl)
Everything use defauly settings.
5. Select GenerateMyDsl.mwe2 and run it.
6. Select Project and Run as Eclipse Application
But the error still occurred....

Anyone here and encountered the same problem?
Need for help.
Very thanks.
  • Attachment: Capture.PNG
    (Size: 16.33KB, Downloaded 1533 times)
Re: Internal error occurred during: "Launching Launch Runtime Eclipse" [message #1776567 is a reply to message #1776507] Fri, 17 November 2017 19:22 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 12324
Registered: July 2009
Senior Member
Please attach the complete error log from the error view

Need professional support for Xtext, Xpand, EMF?
Go to: https://xtext.itemis.com
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Internal error occurred during: "Launching Launch Runtime Eclipse" [message #1776568 is a reply to message #1776567] Fri, 17 November 2017 19:23 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 12324
Registered: July 2009
Senior Member
And ps: which java version do you use?

Need professional support for Xtext, Xpand, EMF?
Go to: https://xtext.itemis.com
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Internal error occurred during: "Launching Launch Runtime Eclipse" [message #1776586 is a reply to message #1776568] Sat, 18 November 2017 02:18 Go to previous messageGo to next message
serio adamo is currently offline serio adamoFriend
Messages: 24
Registered: September 2017
Junior Member
Christian Dietrich wrote on Fri, 17 November 2017 19:22
Please attach the complete error log from the error view


!ENTRY org.eclipse.core.jobs 4 2 2017-11-18 10:15:29.905
!MESSAGE An internal error occurred during: "Launching Launch Runtime Eclipse".
!STACK 0
java.lang.NoSuchMethodError: org.eclipse.jdt.launching.JavaRuntime.isModularJava(Lorg/eclipse/jdt/launching/IVMInstall;)Z
at org.eclipse.pde.launching.AbstractPDELaunchConfiguration.launch(AbstractPDELaunchConfiguration.java:77)
at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:885)
at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:739)
at org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(DebugUIPlugin.java:1039)
at org.eclipse.debug.internal.ui.DebugUIPlugin$8.run(DebugUIPlugin.java:1256)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:56)

Christian Dietrich wrote on Fri, 17 November 2017 19:23
And ps: which java version do you use?


Java version:
java version "1.8.0_101"
Java(TM) SE Runtime Environment (build 1.8.0_101-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.101-b13, mixed mode)
Install package: jdk-8u101-windows-x64.exe

[Updated on: Sat, 18 November 2017 02:20]

Report message to a moderator

Re: Internal error occurred during: "Launching Launch Runtime Eclipse" [message #1776591 is a reply to message #1776586] Sat, 18 November 2017 07:58 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 12324
Registered: July 2009
Senior Member
For me it looks like you have somewhere
(Eg due automatic plugin update)
A mixture of oxygen 1a and pre oxygen 1a plugins

(Pde from 1a jdt from before)
Can you have a look at the version number of the pde and jdt plugins


Need professional support for Xtext, Xpand, EMF?
Go to: https://xtext.itemis.com
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Internal error occurred during: "Launching Launch Runtime Eclipse" [message #1776594 is a reply to message #1776591] Sat, 18 November 2017 09:18 Go to previous messageGo to next message
serio adamo is currently offline serio adamoFriend
Messages: 24
Registered: September 2017
Junior Member
Christian Dietrich wrote on Sat, 18 November 2017 07:58
For me it looks like you have somewhere
(Eg due automatic plugin update)
A mixture of oxygen 1a and pre oxygen 1a plugins

(Pde from 1a jdt from before)
Can you have a look at the version number of the pde and jdt plugins


org.eclipse.pde.core:
3.11.100.v20170517-0724

org.eclipse.pde.launching:
3.7.50.v20171007-1315

org.eclipse.pde.ui:
3.10.50.v20171007-1315

org.eclipse.pde.build:
3.9.300.v20170515-0912

org.eclipse.jdt:
2.13.0.v20170612-0950

the plugins org.eclipse.pde.ui and org.eclipse.pde.launching seems be automatic updated. (That is very strange, because I have turn off the automatic updates in Preferences/Install/Update/Automatic Updates)

[Updated on: Sat, 18 November 2017 09:23]

Report message to a moderator

Re: Internal error occurred during: "Launching Launch Runtime Eclipse" [message #1776595 is a reply to message #1776594] Sat, 18 November 2017 09:39 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 12324
Registered: July 2009
Senior Member
yes. your jdt and pde are not in sync. this causes the issue

Need professional support for Xtext, Xpand, EMF?
Go to: https://xtext.itemis.com
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Internal error occurred during: "Launching Launch Runtime Eclipse" [message #1776596 is a reply to message #1776595] Sat, 18 November 2017 09:48 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 6079
Registered: July 2009
Senior Member
Hi

Oxygen.1a and Photon.M3 introduce both Java 9 and JUnit 5 support providing new opportunities for some obscure errors.

Many of these have been attributed to PDE(JUnit) and JDT version mismatches. It is unclear whether this is due to users or idiot distributions facilitating idiot installations.

Make very sure that you fully update from a consistent distribution and do not allow any other distribution site to contribute. Verify the "Available sites" in the Install dialog very carefully.

Regards

Ed Willink
Re: Internal error occurred during: "Launching Launch Runtime Eclipse" [message #1776602 is a reply to message #1776595] Sat, 18 November 2017 11:34 Go to previous messageGo to next message
serio adamo is currently offline serio adamoFriend
Messages: 24
Registered: September 2017
Junior Member
Christian Dietrich wrote on Sat, 18 November 2017 09:39
yes. your jdt and pde are not in sync. this causes the issue


Thanks.
You said jdt and pde are not in sync.
But how to make it match?
Should I update jdt to a match version? or downgrade pde to a version which match jdt?
Where to find a match version?
Re: Internal error occurred during: "Launching Launch Runtime Eclipse" [message #1776603 is a reply to message #1776596] Sat, 18 November 2017 11:39 Go to previous messageGo to next message
serio adamo is currently offline serio adamoFriend
Messages: 24
Registered: September 2017
Junior Member
Ed Willink wrote on Sat, 18 November 2017 09:48


Make very sure that you fully update from a consistent distribution and do not allow any other distribution site to contribute. Verify the "Available sites" in the Install dialog very carefully.


I use eclipse-java-oxygen-R-win32-x86_64 and my available software site is default setting:

Oxygen
http://download.eclipse.org/releases/oxygen

Oxygen
http://download.eclipse.org/eclipse/updates/4.7

I dont understand why it automatic update to Oxygen.1a?
Could you give me some suggestion about how to fix this issue?
Very thanks.
Re: Internal error occurred during: "Launching Launch Runtime Eclipse" [message #1776606 is a reply to message #1776603] Sat, 18 November 2017 11:55 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 6079
Registered: July 2009
Senior Member
Hi

I presume that you invoked Help->Check for Updates and so Oxygen.1a was provided as the best update.

org.eclipse.jdt:
2.13.0.v20170612-0950

is wrong. It should be 2.13.1... Are you sure you did not get any errors while updating? Try updating again.

Regards

Ed Willink
Re: Internal error occurred during: "Launching Launch Runtime Eclipse" [message #1776610 is a reply to message #1776606] Sat, 18 November 2017 12:31 Go to previous message
serio adamo is currently offline serio adamoFriend
Messages: 24
Registered: September 2017
Junior Member
Ed Willink wrote on Sat, 18 November 2017 11:55
Hi

I presume that you invoked Help->Check for Updates and so Oxygen.1a was provided as the best update.

org.eclipse.jdt:
2.13.0.v20170612-0950

is wrong. It should be 2.13.1... Are you sure you did not get any errors while updating? Try updating again.

Regards

Ed Willink



In fact, I did not click Help->Check for Updates at all. As I mention at topic, I just reinstall eclipse...

Anyway, this issue was fixed, after update jdt to newest version: 3.12.1.v20171009-0410. (Only this version can be select, no 2.13.1...)

PS: But I will use neon, it more stable. oxygen seems silent update in background, even if turn off automatic update.....

Thanks again!

[Updated on: Sat, 18 November 2017 12:33]

Report message to a moderator

Previous Topic:Auto-completion not working
Next Topic:Model serialization problem
Goto Forum:
  


Current Time: Sat Oct 20 16:53:37 GMT 2018

Powered by FUDForum. Page generated in 0.02546 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top