Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Nebula Grid text color using Table-GridLine:horizontal
Nebula Grid text color using Table-GridLine:horizontal [message #1776345] Wed, 15 November 2017 14:00 Go to next message
Maurice AMSELLEM is currently offline Maurice AMSELLEMFriend
Messages: 2
Registered: November 2017
Junior Member
Hi, I am trying to use the nebula grid component, so simply used the NebulaGridExamplePage that comes with the examples.

In our application, we have customized the table horizontal lines color like this:

Table-GridLine:horizontal, {
color: #d0d0d0;
}

The problem is that the whole grid ( both horizontal lines and text and everything) uses this color.
This is weird.

I have tried setting the color to #FF0000 (red) and the whole grid displays in red.

I am using version 3.1.1
org.eclipse.rap.nebula.widgets.grid.source_3.1.1.20160831-0700.jar

Any idea what may be wrong ?
  • Attachment: red_grid.png
    (Size: 57.87KB, Downloaded 38 times)
Re: Nebula Grid text color using Table-GridLine:horizontal [message #1776351 is a reply to message #1776345] Wed, 15 November 2017 14:29 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2285
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi,
for Nebula Grid you should use Grid-GridLine element selector. Do you have a comma after the selector like in the snippet above? If yes, please remove it.
HTH,
Ivan
Re: Nebula Grid text color using Table-GridLine:horizontal [message #1776363 is a reply to message #1776351] Wed, 15 November 2017 17:38 Go to previous message
Maurice AMSELLEM is currently offline Maurice AMSELLEMFriend
Messages: 2
Registered: November 2017
Junior Member
Hi Ivan, thanks for the quick answer.

Actually, it was the ending comma that caused the issue, and it has nothing to do with Table-GridLine.

try this:

DummySelector, {
color: #FF0000;
}

and the grid will also display the text in red, like if it was "*"

That's funny.

Anyway, thank you for pointing the issue.
And yes, i will add explicit Grid* selectors to my theme.


Previous Topic:SWT.MouseHover
Next Topic:Usage of CSS3 @media print Rule in RAP
Goto Forum:
  


Current Time: Tue Aug 14 19:35:31 GMT 2018

Powered by FUDForum. Page generated in 0.01891 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top