Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Teacher and student has problem with debug running when he hits plays(Debugger running)
Teacher and student has problem with debug running when he hits plays [message #1776215] Tue, 14 November 2017 03:13 Go to next message
Matt Jenkins is currently offline Matt JenkinsFriend
Messages: 1
Registered: November 2017
Junior Member
Whenever one of my students runs his programs in Eclipse (doesn't matter which version), the debugger will randomly popup. I even had him switch seats and access his workspace from a different computer (and different version of Eclipse) and it does the same thing. I attached a picture of what it looks like. There are no errors in his code. Does anyone know why this is happening? It only happens to him (and no one else). I also uninstalled and reinstalled java and eclipse on his computer and it did not change anything. I teach computer science at the high school level. They access their workspace off a network drive.
  • Attachment: tamir.docx
    (Size: 118.87KB, Downloaded 7 times)
Re: Teacher and student has problem with debug running when he hits plays [message #1776268 is a reply to message #1776215] Tue, 14 November 2017 16:12 Go to previous message
Stephan Herrmann is currently offline Stephan HerrmannFriend
Messages: 1526
Registered: July 2009
Senior Member
The screenshot (why wrapped in a .docx?) shows: "Suspended (breakpoint at line 25 in OPERATION_BRACKET_STORM)", which sounds like a good explanation for the debugger kicking in.
You may want to check the preference at "Run/Debug > [x] Activate the debug view when a breakpoint is hit". This is a per-workspace preference. Perhaps that student has a different setting here than the rest of you?
Apparently, the program was launched using "Debug as ..." or equivalent. If you don't want to use the debugger, "Run as ..." should avoid all this.
Previous Topic:Eclipse Oxygen - Debugging Issue
Next Topic:console view won't open
Goto Forum:
  


Current Time: Mon Dec 11 03:59:48 GMT 2017

Powered by FUDForum. Page generated in 0.02000 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software