Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » what happen to Miscellaneous settings?(Where do we put -std= now?)
what happen to Miscellaneous settings? [message #1776211] Mon, 13 November 2017 23:38 Go to next message
Rick Blacker is currently offline Rick BlackerFriend
Messages: 14
Registered: August 2016
Junior Member
In the past we used to put the -std flag in the miscellaneous settings, however under Oxygen, I'm not seeing this anymore. Has it moved? Was it removed? And if so, where are we supposed to put this flag now?
Re: what happen to Miscellaneous settings? [message #1776213 is a reply to message #1776211] Tue, 14 November 2017 01:11 Go to previous messageGo to next message
Rick Blacker is currently offline Rick BlackerFriend
Messages: 14
Registered: August 2016
Junior Member
Okay, i figured it out... For some reason on that machine, that install... The Settings is NOT showing all the settings option tabs. It only shows Error Parsers tab.

I just installed Eclipse Oxygen on my home computer and everything is showing up as expected.

Re: what happen to Miscellaneous settings? [message #1776359 is a reply to message #1776213] Wed, 15 November 2017 16:35 Go to previous messageGo to next message
Rick Blacker is currently offline Rick BlackerFriend
Messages: 14
Registered: August 2016
Junior Member
Update...

Those tabs under Settings disappeared on my other machine as well. At this point I'm not sure if it's a bug in Eclipse or if it's expected behavior based on how a project is created. When I create a generic Hello World app, and I bring up Project Properties -> C/C++ Build -> Settings, I see the following tabs
* Tool Settings
* Build Steps
* Build Artifacts
* Binary Parsers
* Error Parsers

However, in this other project, I only see
* Binary Parsers
* Error Parsers

Does anyone know why?
Re: what happen to Miscellaneous settings? [message #1776369 is a reply to message #1776359] Wed, 15 November 2017 18:07 Go to previous messageGo to next message
Jonah Graham is currently offline Jonah GrahamFriend
Messages: 397
Registered: June 2014
Senior Member
The reason for this is the missing pages are only for some (most) kinds of projects. Are you using vanilla Eclipse CDT, or do you have some other plug-ins installed? Is your project perhaps created with a third-party toolchain/plug-in (like GNU Arm/MCU tools) and you now don't have it installed.

If you post the .cproject file I can probably help further.
Re: what happen to Miscellaneous settings? [message #1776377 is a reply to message #1776369] Wed, 15 November 2017 19:53 Go to previous message
Rick Blacker is currently offline Rick BlackerFriend
Messages: 14
Registered: August 2016
Junior Member
Hi Jonah,

It's related to this topic I just created. I think it really explains what I'm trying to figure out, accomplish. These were two different subjects which is why i have to different topics, but, are loosely related
https://www.eclipse.org/forums/index.php/t/1090025/
Previous Topic:why trace_printf("%f",x); triggers a HARD FAULT on a stm32 MCU?
Next Topic:Launching Cleanflight has encountered a problem
Goto Forum:
  


Current Time: Wed Dec 13 09:36:57 GMT 2017

Powered by FUDForum. Page generated in 0.02278 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software