Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » empty 'Welcome' tab(When I open up jave ee IDE for oxygen, the 'Welcome' page is blank)
empty 'Welcome' tab [message #1776117] Sun, 12 November 2017 01:20 Go to next message
Jim Anderson is currently offline Jim AndersonFriend
Messages: 72
Registered: October 2014
Member
I have been away from my java web development for several years and I'm finally able to get back to it. I have installed my old java web project and after about a week of work, I have been able to bring up my web page in Firefox. My next task is get my project running in the Eclipse IDE.

I have installed the Oxygen 4.7.1a release and was able to launch Eclipse. However, when Eclipse comes up, the 'Welcome' page is blank. I'm pretty sure the welcome has links to Eclipse documentation which I need to review to get back up to speed with Eclipse. I did a search and found that the welcome page can be blank with unsupported browsers.

If I understand correctly, Eclipse has a built in browser 'SWT' which can use a mozilla based browser as a widget, but I'm confused with the documentation.

Quote:
Q: What do I need to run the SWT Browser in a standalone application on Linux or Solaris?
A: Follow the steps below to use the SWT Browser widget in your standalone SWT application.

A supported native browser must be installed (linux requirements) (solaris requirements).
If a supported WebKitGTK and/or XULRunner is installed then it should be found automatically at runtime with no additional effort. For other native Mozilla-based browsers:
Set the environment variable MOZILLA_FIVE_HOME to the native browser's installation folder. e.g. setenv MOZILLA_FIVE_HOME /usr/lib/mozilla
Set the environmnent variable LD_LIBRARY_PATH to include MOZILLA_FIVE_HOME. e.g. setenv LD_LIBRARY_PATH ${MOZILLA_FIVE_HOME}:${LD_LIBRARY_PATH}
Your standalone SWT application can now use the Browser widget.


I have taken the steps to set the value of MOZILLA_FILE_HOME to /usr/lib/mozilla and I have set LD_LIBRARY_PATH to ${MOSILLA_FILE_HOME} but the 'Welcome' tab comes up blank.

I am running Firefox 53.0 and the latest version is 56.0.2. I will upgrade and try again, but I suspect that is not my problem. I will update when I try the latest version of Firefox.

Does anyone have a suggestion on how I can bring up the 'Welcome' page correctly?

Jim A


Re: empty 'Welcome' tab [message #1778406 is a reply to message #1776117] Wed, 13 December 2017 22:02 Go to previous message
Kevin Ushey is currently offline Kevin UsheyFriend
Messages: 1
Registered: December 2017
Junior Member
I'm seeing the same issue. FWIW, I'm using Ubuntu 16.04 LTS and have OpenJDK 8 installed from the apt repositories.

I did notice that double-clicking the 'Welcome' text shrinks the tab (so that it is no longer maximized), and in that view content within the Welcome tab is now visible. Re-maximizing it causes it to become blank again.

As an aside, I see no way to hide the Welcome screen in Oxygen, so now I have to close the Welcome screen every time I start Eclipse, which is no fun.
Previous Topic:Export perspective in Eclipse Oxygen
Next Topic:Link[http://download.eclipse.org/vjet/updates-0.10] NOT FOUND
Goto Forum:
  


Current Time: Sun Aug 19 19:05:06 GMT 2018

Powered by FUDForum. Page generated in 0.03185 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top