Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Saving an dirty editor part fails in Neon.3 Release (4.6.3)(Saving an dirty editor part fails when the view is detached (on separate window))
Saving an dirty editor part fails in Neon.3 Release (4.6.3) [message #1775915] Wed, 08 November 2017 09:03 Go to next message
Matthias Goebel is currently offline Matthias GoebelFriend
Messages: 7
Registered: July 2017
Junior Member
Hello community,

I've got a little usability problem with the IDE's save button behavior.
When dragging an editor on e.g. a second monitor it gets its own window detached from the main application window. But you can't use the save button anymore because it becomes disabled as soon as the main application window gains focus and sets its own parts active.
I know that you can use the ctrl+s shortcut, but it's kind of confusing anyway.

Is this a bug or desired behavior? Is there a way so get the button working?

Kind regards
Matthias
Re: Saving an dirty editor part fails in Neon.3 Release (4.6.3) [message #1776081 is a reply to message #1775915] Fri, 10 November 2017 14:32 Go to previous messageGo to next message
Brian de Alwis is currently offline Brian de AlwisFriend
Messages: 757
Registered: January 2012
Senior Member

By switching to the main application window, you change the active context. On some platforms you can click items in another window without changing focus (e.g., on OS X if you cmd-click).

Eclipse Platform committer. Ask me about Eclipse support, training, and consulting.
Re: Saving an dirty editor part fails in Neon.3 Release (4.6.3) [message #1776304 is a reply to message #1776081] Wed, 15 November 2017 08:46 Go to previous message
Matthias Goebel is currently offline Matthias GoebelFriend
Messages: 7
Registered: July 2017
Junior Member
Thanks for your feedback Brian!

I just wondered why it works one time and the other time not.

This behavior seems to be related to the focused widget in the main application window. When I select the e4 model editor as active part in the main window the button works.

Anyway... so I have to stay with ctrl+s shortcut on detached windows

Regards
Matthias
Previous Topic:Configure mapdb in eclipse smart home
Next Topic:Placeholders on Multi-Window
Goto Forum:
  


Current Time: Sun Jun 24 13:21:03 GMT 2018

Powered by FUDForum. Page generated in 0.01825 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top