Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Tool Integration: Makefile doesn't generated correctly.(Makefile has 'No tool found that can build the extension specified with the build artifact name $@')
Tool Integration: Makefile doesn't generated correctly. [message #1775841] Tue, 07 November 2017 06:32
Tommy Morinaga is currently offline Tommy MorinagaFriend
Messages: 2
Registered: September 2017
Junior Member
According to "Tutorial: An Example Tool Integration" of Eclipse Help, I added my original tool integration.
However, when builiding, I saw the following error.
make: *** No rule to make target `lapisu8_test', needed by `all'.  Stop.


Seeing Makefile ,build command doesn't generated correctly like below.
...
# All Target
all: lapisu8_test

# Tool invocations
	@echo 'No tool found that can build the extension specified with the build artifact name $@'
# Other Targets
clean:
...


Seeing subdir.mk, command seems generated correctly.
%.asm: ../%.c
	@echo 'Building file: $<'
	@echo 'Invoking: Compiler'
	ccu8 -c -Wall -o "$@" "$<"
	@echo 'Finished building: $<'
	@echo ' '


I attached Makefile series files and plugin.xml.
What could be the problem?
Thank you for the attention.


  • Attachment: plugin.xml
    (Size: 4.54KB, Downloaded 18 times)
  • Attachment: makefile
    (Size: 0.77KB, Downloaded 27 times)
  • Attachment: subdir.mk
    (Size: 0.53KB, Downloaded 24 times)
  • Attachment: objects.mk
    (Size: 0.23KB, Downloaded 24 times)
Previous Topic:Unresponsive GDB with Memory Leak
Next Topic:retrieve children elements of a function
Goto Forum:
  


Current Time: Tue Dec 12 14:20:38 GMT 2017

Powered by FUDForum. Page generated in 0.01512 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software