Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » ServerTools (WTP) » Apps deployed to 8.5.11 instance, can't add them to 8.5.23 instance
Apps deployed to 8.5.11 instance, can't add them to 8.5.23 instance [message #1775815] Mon, 06 November 2017 18:32 Go to next message
David M. Karr is currently offline David M. KarrFriend
Messages: 534
Registered: July 2009
Senior Member
Using Oxygen 1a.

I had to migrate my work from an old laptop to a new laptop. My workspace was migrated, but I'm still finding things that have to be restored properly.

I have two gradle webapp projects that I had been running in a Tomcat 8.5.11 instance in Eclipse. After getting back to this after a while, it seems like the 8.5.11 installation is corrupted, so I installed the latest 8.5.23 distribution. I created a new server instance in Eclipse and configured it similarly to the 8.5.11 instance.

I can still see the two apps added to the 8.5.11 instance. I need to add them to the 8.5.23 instance. When I click "Add and Remove...", I get a dialog saying "There are no resources that can be added or removed from the server".

I tried removing the two projects from the older instance (just guessing), but that didn't let me add them to the new instance. Now I can't add them back to the old instance (same error).

Do I have to do something in "Project Facets"? When I inspect this, I see one facet is "jst.web", version 2.4. When I click on that, the bottom pane says "Implementation of project facet jst.web could not be found. Functionality will be limited."

I did also see "Static Web Module". I tried to check that and apply, but that didn't make any difference.
Re: Apps deployed to 8.5.11 instance, can't add them to 8.5.23 instance [message #1775826 is a reply to message #1775815] Mon, 06 November 2017 21:26 Go to previous message
David M. Karr is currently offline David M. KarrFriend
Messages: 534
Registered: July 2009
Senior Member
I figured this out. I had yet to reinstall the web developer tools plugins (and other similar plugins) in the new installation.
Previous Topic:Starting Tomcat with Java 9
Next Topic:After migration/update, Tomcat says "The main resource set specified [...] is not valid"
Goto Forum:
  


Current Time: Tue Jan 16 14:10:56 GMT 2018

Powered by FUDForum. Page generated in 0.01876 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software