Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Epsilon » Register EPackage on startup
Register EPackage on startup [message #1775317] Fri, 27 October 2017 14:41 Go to next message
louis andia. is currently offline louis andia.Friend
Messages: 47
Registered: November 2016
Member
Hello,

My ecore is registered with Epsilon and working fine. I can open a model with MoDisco without problem each time i restart Eclipse and without to register my ecore again.
The problem is when i start Eclipse on a model file opened, it's like Eclipse try to open and display my model before Epsilon is loaded and EPackage is registered.
So, there is a way to tell Eclipse to load the plugin before trying to open the active file? Or the only way is to be sure when i close Eclipse the file open is not a model?

I hope it's clear.
Thank you.
Re: Register EPackage on startup [message #1775357 is a reply to message #1775317] Sat, 28 October 2017 09:44 Go to previous message
Dimitris Kolovos is currently offline Dimitris KolovosFriend
Messages: 1520
Registered: July 2009
Location: York, UK
Senior Member

Hi Louis,

We'd need to tweak Exeed to force metamodel registration on startup to achieve this. Could you please file an enhancement request in the Bugzilla?

Cheers,
Dimitris
Previous Topic:EOL stansalone problem
Next Topic:ETL - Reuse trace model from one phase as source model in another phase
Goto Forum:
  


Current Time: Mon Apr 23 21:38:39 GMT 2018

Powered by FUDForum. Page generated in 0.01963 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software