Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » Installer fails(Cannot install Oxygen JEE)
Installer fails [message #1775185] Wed, 25 October 2017 23:22 Go to next message
Brian Wood is currently offline Brian WoodFriend
Messages: 4
Registered: July 2009
Junior Member
Installer fails: log:
[2017-10-25 16:06:38] ERROR: org.eclipse.equinox.p2.transport.ecf code=1002 Unable to connect to repository http://download.eclipse.org/technology/epp/packages/oxygen/compositeContent.xml
java.net.ConnectException: Operation timed out (Connection timed out)
at java.net.PlainSocketImpl.socketConnect(Native Method)
at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350)
at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)
at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
at java.net.Socket.connect(Socket.java:589)
at org.apache.http.conn.scheme.PlainSocketFactory.connectSocket(PlainSocketFactory.java:120)
at org.apache.http.impl.conn.DefaultClientConnectionOperator.openConnection(DefaultClientConnectionOperator.java:179)
at org.apache.http.impl.conn.ManagedClientConnectionImpl.open(ManagedClientConnectionImpl.java:328)
at org.apache.http.impl.client.DefaultRequestDirector.tryConnect(DefaultRequestDirector.java:612)
at org.apache.http.impl.client.DefaultRequestDirector.execute(DefaultRequestDirector.java:447)
at org.apache.http.impl.client.AbstractHttpClient.doExecute(AbstractHttpClient.java:884)
at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:82)
at org.eclipse.ecf.provider.filetransfer.httpclient4.HttpClientFileSystemBrowser.runRequest(HttpClientFileSystemBrowser.java:263)
at org.eclipse.ecf.provider.filetransfer.browse.AbstractFileSystemBrowser$DirectoryJob.run(AbstractFileSystemBrowser.java:69)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:56)

added JVM args to Eclipse Installer.app//Contents/Eclipse/eclipse-inst.ini
-Dhttp.proxyHost=proxy.mycompany.com
-Dhttp.proxyPort=8080
-Dhttps.proxyHost=proxy.mycompany.com
-Dhttps.proxyPort=8080
Re: Installer fails [message #1775230 is a reply to message #1775185] Thu, 26 October 2017 14:38 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29653
Registered: July 2009
Senior Member
Networks and servers aren't perfect so it could just be a temporary failure. Via the installer's menu, you can configure any necessary proxy settings.
Re: Installer fails [message #1775232 is a reply to message #1775230] Thu, 26 October 2017 14:45 Go to previous messageGo to next message
Brian Wood is currently offline Brian WoodFriend
Messages: 4
Registered: July 2009
Junior Member
how does one do that? Where is the installer menu?
Re: Installer fails [message #1775311 is a reply to message #1775232] Fri, 27 October 2017 13:26 Go to previous messageGo to next message
Brian Wood is currently offline Brian WoodFriend
Messages: 4
Registered: July 2009
Junior Member
I figured out the settings - changed the proxy to be exactly what is in my Eclipse Neon, so I know it is correct. Now I get:
ERROR: org.eclipse.equinox.p2.metadata.repository code=1002 Unable to read repository at http://download.eclipse.org/releases/oxygen.
ERROR: org.eclipse.equinox.p2.transport.ecf code=1002 HTTP Proxy Authentication Required: http://download.eclipse.org/releases/oxygen/201710111001/content.xml.xz
ERROR: org.eclipse.ecf.identity code=0 Proxy Authentication Required
at org.eclipse.ecf.provider.filetransfer.httpclient4.HttpClientRetrieveFileTransfer.openStreams(HttpClientRetrieveFileTransfer.java:663)

Why oh why does this installer exist?
Re: Installer fails [message #1775325 is a reply to message #1775311] Fri, 27 October 2017 15:54 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29653
Registered: July 2009
Senior Member
The installer exists so you don't have to unzip/untar a package from https://www.eclipse.org/downloads/eclipse-packages/ and because the installer will ensure that you have the right JRE installed and that the installation will use that the right JRE. But you are of course welcome to unpackage a packaged download from the above link if your corporate firewall settings make it so hard to communicate with the outside world; that's what "Proxy Authentication Required" suggests is the case. Of course in that case it will be highly unlikely that your presumably (though not apparently) correct network proxy setting settings in your unpackaged installation will work either (because they use exactly the same mechanism/framework as the installer). So you're not likely to be able to add anything to your installation or update your installation in the future.
Re: Installer fails [message #1775332 is a reply to message #1775325] Fri, 27 October 2017 17:41 Go to previous messageGo to next message
Brian Wood is currently offline Brian WoodFriend
Messages: 4
Registered: July 2009
Junior Member
I was able to find the direct download for the latest version of Oxygen for my platform. Then I was able to use the proxy (with my correct settings, as I asserted before) to install plugins from the Marketplace. I was able to resolve my problems by eliminating the installer app from the equation.
Re: Installer fails [message #1775355 is a reply to message #1775332] Sat, 28 October 2017 08:16 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 29653
Registered: July 2009
Senior Member
The installer uses exactly the same underlying network communication framework as p2 (because it in fact uses p2) so it seems contradictory to me that the same settings that work in the IDE do not work in the installer but of course I can only test on a Mac virtual box and there I don't have firewall proxy settings that I can test against.
Previous Topic:Targlet's Source Locator
Next Topic:How/when are tasks triggered, enabled and executed?
Goto Forum:
  


Current Time: Sat Nov 17 06:18:54 GMT 2018

Powered by FUDForum. Page generated in 0.02306 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top