Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Memory Analyzer » does MAT work on java 9?(question to see if errors noticed in java 9 vm are expected)
does MAT work on java 9? [message #1775034] Mon, 23 October 2017 19:22 Go to next message
Mukarram Baig is currently offline Mukarram BaigFriend
Messages: 4
Registered: June 2014
Junior Member
Hi guys,

Thanks for the great tool!

I was trying to see if Eclipse MAT (1.7.0) works with java 9. I set the `-vm /usr/local/java/jdk9/bin/java` option in the MemoryAnalyzer.ini and it failed with a bunch of errors (attached). It gives a final message to resolve something in `config.ini` but it has way too much text to easily identify the fix. Would appreciate if someone can guide me here?

Thanks!


Re: does MAT work on java 9? [message #1775641 is a reply to message #1775034] Thu, 02 November 2017 13:54 Go to previous message
Andrew Johnson is currently offline Andrew JohnsonFriend
Messages: 142
Registered: July 2009
Senior Member
I haven't done much work on this so am not surprised there are problems, as stand alone Memory Analyzer is based on Eclipse 4.5 (Mars).

Some things to try:

  1. Use JDK 8 instead
  2. Install Memory Analyzer into Eclipse 4.7.1a
  3. See if https://wiki.eclipse.org/Configure_Eclipse_for_Java_9 offers any ideas


The latest nightly builds have an update to cope with the Java 9 String format in Java 9 heap dumps.

http://download.eclipse.org/mat/snapshots/update-site/

https://www.eclipse.org/mat/snapshotBuilds.php
Previous Topic:ParseHeapdump.sh throws error
Next Topic:Memory Analyzer 1.7.0 Released
Goto Forum:
  


Current Time: Sat Nov 17 19:03:57 GMT 2018

Powered by FUDForum. Page generated in 0.01871 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top