Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Cannot update Eclipse: missing repository for 2 google inject items(No repository found containing: osgi.bundle,com.google.inject,3.0.0.v201605172100)
Cannot update Eclipse: missing repository for 2 google inject items [message #1774621] Wed, 18 October 2017 00:35 Go to next message
Marc Sherman is currently offline Marc ShermanFriend
Messages: 1
Registered: October 2017
Junior Member
I have been getting the error msgs below for the past several weeks when I click on the update notification. The bundle must contain 20 line items/folders, but the missing repository error msg blocks all the updates, not just those relying on the com.google osgi's repository.
I was hoping that many people would be getting the same error msg, and that it would be fixed after a few days. So far that is not the case, so I have posted it here in the newby forum.
Thanks/Cheerss,
Marc

Eclipse version:
Version: Oxygen Release (4.7.0)
Build id: 20170620-1800

Error message:
An error occurred while collecting items to be installed
session context was:(profile=C__Users_marcs_java-oxygen2_eclipse, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).

No repository found containing: osgi.bundle,com.google.inject,3.0.0.v201605172100
No repository found containing: osgi.bundle,com.google.inject.multibindings,3.0.0.v201605172100
Re: Cannot update Eclipse: missing repository for 2 google inject items [message #1774628 is a reply to message #1774621] Wed, 18 October 2017 06:55 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29040
Registered: July 2009
Senior Member
Those bundles are in Neon and Oxygen update sites, e.g., in http://download.eclipse.org/releases/oxygen

Is that enabled in Window -> Preferences -> Install/Update -> Available Software Sites?
Re: Cannot update Eclipse: missing repository for 2 google inject items [message #1777686 is a reply to message #1774621] Fri, 01 December 2017 14:35 Go to previous message
Stephen Prokopchuk is currently offline Stephen ProkopchukFriend
Messages: 1
Registered: December 2017
Junior Member
This is what I did to fix it..


  1. Go into Help --> Install New Software
  2. Deselect the 'Contact all update sites during install to find required software (this might be optional.. haven't tested)
  3. Select the Oxygen (or your version of eclipse) site from the Work With.. drop-down
  4. Go through each section and each item and look for the update (looks like refresh) icon beside it.
  5. if it has an update icon beside it, select it.. there will be a few
  6. Install the checked items


Once this is done, you can do a normal update and things will hopefully be back to normal.

Previous Topic:avr-gdb failed to launch
Next Topic:What does Google Crome proposed code blocking mean for Java EE Tomcat development
Goto Forum:
  


Current Time: Sat Dec 16 20:45:30 GMT 2017

Powered by FUDForum. Page generated in 0.02918 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software