Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » "Unknown constant pool type 19" during Java 9 build with module
"Unknown constant pool type 19" during Java 9 build with module [message #1774368] Fri, 13 October 2017 11:28 Go to next message
ecl ecl is currently offline ecl eclFriend
Messages: 9
Registered: October 2017
Junior Member
I created a simple Java 9 hello world application (an example is here https://github.com/CodeFX-org/demo-jpms-hello-world). Whenever I declare a module, the Java builder fails with the following message:

Quote:

Errors running builder 'Java Builder' on project 'demo-jpms-hello-world-master'.
Unknown constant pool type 19


Subsequent tries to run the hello world program naturally fail, the error message is as follows:

Quote:

Error occurred during initialization of boot layer
java.lang.module.FindException: Module org.codefx.demo.jpms_hello_world not found


Commenting out all content of module-info.java makes the builder and the program execution run as expected.

At the same time, compiling and running from the command line works as expected. Using the above hello world example, this is the code that works:

javac -d target/classes $(find src -name '*.java')

jar --create --file target/jpms-hello-world.jar --main-class org.codefx.demo.jpms.HelloModularWorld -C target/classes .

java --module-path target/jpms-hello-world.jar --module org.codefx.demo.jpms_hello_world


I am running Eclipse Oxygen.1a Release (4.7.1a) on Java 9+181.

For a solution (in my case), see https://www.eclipse.org/forums/index.php?t=msg&th=1089434&goto=1774461&#msg_1774461.

[Updated on: Mon, 16 October 2017 09:53]

Report message to a moderator

Re: "Unknown constant pool type 19" during Java 9 build with module [message #1774379 is a reply to message #1774368] Fri, 13 October 2017 13:13 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3056
Registered: July 2009
Senior Member
You might want to post this question in the JDT forum: https://www.eclipse.org/forums/index.php/f/13/
Re: "Unknown constant pool type 19" during Java 9 build with module [message #1774407 is a reply to message #1774379] Fri, 13 October 2017 17:50 Go to previous messageGo to next message
ecl ecl is currently offline ecl eclFriend
Messages: 9
Registered: October 2017
Junior Member
Sorry for posting in the wrong forum, you are of course right.

Should I repost in the JDT forum or is it better if a moderator moves this thread?
Re: "Unknown constant pool type 19" during Java 9 build with module [message #1774411 is a reply to message #1774407] Fri, 13 October 2017 19:45 Go to previous message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3056
Registered: July 2009
Senior Member
Repost it there, then post a link to the question here, if you don't mind.
Previous Topic:Running Eclipse without JDK installed - Error: JVM shared library does not contain JNI Symbol
Next Topic:Installing Eclipse
Goto Forum:
  


Current Time: Thu Dec 14 04:26:41 GMT 2017

Powered by FUDForum. Page generated in 0.03069 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software