Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » 4DIAC - Framework for Distributed Industrial Automation and Control » a question to the opc ua client in 4diac
a question to the opc ua client in 4diac [message #1773564] Fri, 29 September 2017 13:11 Go to next message
Fei  Yin is currently offline Fei YinFriend
Messages: 36
Registered: July 2017
Member
hello, everyone,


i want to ask , why the opc ua client can't now get value from a extern opc ua server such as the opc ua server in siemens plc with variable node, although in the document it says opc ua client support read value with variable node ? the Forte remind still me that "can't find the methode node". You can see the error in the attachment and another attachment is the structure of the opc ua server in siemens plc at connecting with uaExpert to it.
  • Attachment: uaexpert.jpg
    (Size: 337.26KB, Downloaded 76 times)
  • Attachment: forte.jpg
    (Size: 254.37KB, Downloaded 80 times)
Re: a question to the opc ua client in 4diac [message #1773770 is a reply to message #1773564] Wed, 04 October 2017 12:28 Go to previous message
Stefan Profanter is currently offline Stefan ProfanterFriend
Messages: 12
Registered: July 2017
Junior Member
Hi,
did you read through the documentation, especially the chapter "Read and Write OPC UA variables on a remote server"

The develop branch of forte definitely supports reading and writing variables on a remote OPC UA server.

My guess is that you are not using the most recent version of the develop branch of forte.

So please try to update everything and read the documentation.

Before you try to connect to any Siemens PLC you should really work through ALL the examples as described in here https://eclipse.org/4diac/en_help.php -> OPC UA.
When you did that and all the examples are working as described, but not the Siemens PLC, we can continue debugging that issue. Otherwise it doesn't make much sense to continue the discussion here.

By the way, for posting Screenshots, please use a tool on your PC, e.g. "Snipping Tool" https://support.microsoft.com/en-us/help/13776/windows-use-snipping-tool-to-capture-screenshots and not your smartphone.

BR
Stefan

Previous Topic:question for the port set of FORTE
Next Topic:Monitoring N/A
Goto Forum:
  


Current Time: Tue Aug 21 06:23:37 GMT 2018

Powered by FUDForum. Page generated in 0.02510 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top