Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » missing constructor stereotype in Papyrus
missing constructor stereotype in Papyrus [message #1773297] Tue, 26 September 2017 08:49 Go to next message
Chriss Matt is currently offline Chriss MattFriend
Messages: 38
Registered: December 2012
Member
Hello,

How to add <<create>> to constructor in class diagram using Papyrus?
theoretically, it can be added using standard profile
I have imported the standard profile in model explorer but when I tried to apply the stereotype to the constructor of class I found no stereotype to apply?

Regards
Re: missing constructor stereotype in Papyrus [message #1773301 is a reply to message #1773297] Tue, 26 September 2017 09:03 Go to previous messageGo to next message
Benoit Maggi is currently offline Benoit MaggiFriend
Messages: 108
Registered: March 2013
Location: Bordeaux, France
Senior Member
Hi,

You need to
- import the standard profile
- apply the profile (to your model root for example)
- create a class with an operation
- select the operation
- open the properties> profile section
- applied the <<create>> stereotype

Regards,
Benoit
Re: missing constructor stereotype in Papyrus [message #1773318 is a reply to message #1773301] Tue, 26 September 2017 12:41 Go to previous message
Chriss Matt is currently offline Chriss MattFriend
Messages: 38
Registered: December 2012
Member
Hi Benoit !

thank you for helpful answer

Regards,
Chriss
Previous Topic:Zero values in literals omitted in .UML file
Next Topic:Issues installing Moka in Papyrus Oxygen
Goto Forum:
  


Current Time: Fri Apr 20 11:05:46 GMT 2018

Powered by FUDForum. Page generated in 0.01549 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software