Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Issues installing Moka in Papyrus Oxygen(Moka for Co-Simulation requirements)
Issues installing Moka in Papyrus Oxygen [message #1773175] Fri, 22 September 2017 17:34 Go to next message
Fran Gomez is currently offline Fran GomezFriend
Messages: 12
Registered: July 2014
Junior Member
Hi!

when I try to install Moka from the repository http://download.eclipse.org/modeling/mdt/papyrus/components/moka/oxygen/
the Moka for CoSimulation plugin is not being installed. I get this error:
Cannot complete the install because one or more required items could not be found.
  Software being installed: Moka For Cosimulation (Incubation) 2.1.0.201705162304 (org.eclipse.papyrus.moka.fmi.feature.feature.group 2.1.0.201705162304)
  Missing requirement: Moka For Cosimulation (Incubation) 2.1.0.201705162304 (org.eclipse.papyrus.moka.fmi.feature.feature.group 2.1.0.201705162304) requires 'jnr.ffi 0.0.0' but it could not be found

I am missing any plug-in?

[Updated on: Fri, 22 September 2017 17:36]

Report message to a moderator

Re: Issues installing Moka in Papyrus Oxygen [message #1773230 is a reply to message #1773175] Mon, 25 September 2017 07:00 Go to previous messageGo to next message
Quentin Le Menez is currently offline Quentin Le MenezFriend
Messages: 25
Registered: September 2014
Location: Paris Saclay, France
Junior Member
Hi Fran,
This particular error is due to the fact that Moka does not redistribute a required plugin (jnr.ffi) for its installation. those should be available through the Orbit project [1] which serves as a distribution platform for plugins/tools that are third party but approved to use in the eclipse eco-system.
A solution to this is being researched but as for now you should include the update site [2] used for this release in your installer and check the "check all provided update sites" during installation and everything should be fine :)

HTH,
Quentin

[1] http://download.eclipse.org/tools/orbit/downloads/
[2] http://download.eclipse.org/tools/orbit/downloads/drops/R20170307180635/repository/
Re: Issues installing Moka in Papyrus Oxygen [message #1773343 is a reply to message #1773230] Tue, 26 September 2017 14:43 Go to previous message
Fran Gomez is currently offline Fran GomezFriend
Messages: 12
Registered: July 2014
Junior Member
Thank you Quentin! It worked with reference [2]. To avoid problems, I installed all the plugins available.

Cheers!
Previous Topic:missing constructor stereotype in Papyrus
Next Topic:[Moka] State machine-based concurrent execution simulation using
Goto Forum:
  


Current Time: Wed Sep 26 02:25:57 GMT 2018

Powered by FUDForum. Page generated in 0.02094 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top