Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » scout » Announcement: Eclipse Scout RT Photon will require Java 8
Announcement: Eclipse Scout RT Photon will require Java 8 [message #1772882] Mon, 18 September 2017 10:18
Patrick Bänziger is currently offline Patrick BänzigerFriend
Messages: 54
Registered: September 2011
Member
This is an announcement regarding the upcoming Photon (8.0) release of Eclipse Scout, scheduled for release in Summer 2018:

The Eclipse Scout runtime (RT) will require a Java 8 runtime environment (JRE) - or a Java 8 compatible application server - starting with Eclipse Photon.
This means that you will no longer be able to compile applications based on Scout Photon with older Java Development Kits (JDK) and the created applications cannot be started on Java 7 or older.
With this change Scout will be able to offer APIs that make use of the new Java 8 language features.

There is no impact on the Scout SDK which has required a JDK 8 since the Neon release already.

This change is tracked in Bugzilla and will be part of the release notes.

The Maven Master has been updated as well, and to reflect this breaking change the version number was change to 3.0.x.
Fixes for pre-Photon releases will still be released with 2.x version numbers.
Previous Topic:Eclipse Scout Helloworld - Initialization Failed
Next Topic:Bugs in AbstractIntegerField
Goto Forum:
  


Current Time: Mon Sep 24 22:54:10 GMT 2018

Powered by FUDForum. Page generated in 0.01906 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top