Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » Eclipse IDE for Java Installers issue won't download(Goes through installation then will not finish download)
Eclipse IDE for Java Installers issue won't download [message #1772596] Tue, 12 September 2017 22:00 Go to next message
Corina Coulter is currently offline Corina CoulterFriend
Messages: 1
Registered: September 2017
Junior Member
Hi. I am downloading Eclipse for my Intro to Comp Sci Class and this error occurs that says "installation failed with an error"

Here is the log:
[2017-09-12 15:58:28] Executing bootstrap tasks
[2017-09-12 15:58:28] Java(TM) SE Runtime Environment 1.8.0_144-b01
[2017-09-12 15:58:28] Product org.eclipse.products.epp.package.java.oxygen
[2017-09-12 15:58:28] Bundle org.eclipse.oomph.setup 1.8.0.v20170408-0745, build=3059, branch=2161405b80cf99ed791602ba56cdf44084f5ca43
[2017-09-12 15:58:28] Bundle org.eclipse.oomph.setup.core 1.8.0.v20170531-0903, build=3059, branch=2161405b80cf99ed791602ba56cdf44084f5ca43
[2017-09-12 15:58:28] Bundle org.eclipse.oomph.setup.p2 1.8.0.v20170318-0419, build=3059, branch=2161405b80cf99ed791602ba56cdf44084f5ca43
[2017-09-12 15:58:28] Performing P2 Director (Eclipse IDE for Java Developers (Oxygen))
[2017-09-12 15:58:28] Offline = false
[2017-09-12 15:58:28] Mirrors = true
[2017-09-12 15:58:28] Resolving 24 requirements from 3 repositories to C:\Users\Corina\eclipse\java-oxygen9\eclipse
[2017-09-12 15:58:28] Requirement epp.package.java [4.7.0,4.8.0)
[2017-09-12 15:58:28] Requirement org.eclipse.platform.feature.group [4.7.0,4.8.0)
[2017-09-12 15:58:28] Requirement org.eclipse.rcp.feature.group [4.7.0,4.8.0)
[2017-09-12 15:58:28] Requirement org.eclipse.buildship.feature.group
[2017-09-12 15:58:28] Requirement org.eclipse.eclemma.feature.feature.group
[2017-09-12 15:58:28] Requirement org.eclipse.egit.feature.group
[2017-09-12 15:58:28] Requirement org.eclipse.egit.mylyn.feature.group
[2017-09-12 15:58:28] Requirement org.eclipse.jdt.feature.group
[2017-09-12 15:58:28] Requirement org.eclipse.jgit.feature.group
[2017-09-12 15:58:28] Requirement org.eclipse.m2e.feature.feature.group
[2017-09-12 15:58:28] Requirement org.eclipse.m2e.logback.feature.feature.group
[2017-09-12 15:58:28] Requirement org.eclipse.mylyn.bugzilla_feature.feature.group
[2017-09-12 15:58:28] Requirement org.eclipse.mylyn.context_feature.feature.group
[2017-09-12 15:58:28] Requirement org.eclipse.mylyn.git.feature.group
[2017-09-12 15:58:28] Requirement org.eclipse.mylyn.hudson.feature.group
[2017-09-12 15:58:28] Requirement org.eclipse.mylyn.ide_feature.feature.group
[2017-09-12 15:58:28] Requirement org.eclipse.mylyn.java_feature.feature.group
[2017-09-12 15:58:28] Requirement org.eclipse.mylyn.wikitext_feature.feature.group
[2017-09-12 15:58:28] Requirement org.eclipse.mylyn_feature.feature.group
[2017-09-12 15:58:28] Requirement org.eclipse.recommenders.mylyn.rcp.feature.feature.group
[2017-09-12 15:58:28] Requirement org.eclipse.recommenders.rcp.feature.feature.group
[2017-09-12 15:58:28] Requirement org.eclipse.recommenders.snipmatch.rcp.feature.feature.group
[2017-09-12 15:58:28] Requirement org.eclipse.wst.xml_ui.feature.feature.group
[2017-09-12 15:58:28] Requirement org.eclipse.oomph.setup.feature.group
[2017-09-12 15:58:28] Repository http://download.eclipse.org/technology/epp/packages/oxygen
[2017-09-12 15:58:28] Repository http://download.eclipse.org/releases/oxygen/201706281000
[2017-09-12 15:58:28] Repository http://download.eclipse.org/oomph/updates/milestone/latest
[2017-09-12 15:58:30] Calculating requirements and dependencies.
[2017-09-12 15:58:31] Computing prerequisite plan
[2017-09-12 15:58:32] Collecting 1 artifacts from http://download.eclipse.org/technology/epp/packages/oxygen
[2017-09-12 15:58:48] Downloading epp.package.java.executable.win32.win32.x86_64
[2017-09-12 15:58:48] Collected 1 artifacts for http://download.eclipse.org/technology/epp/packages/oxygen in 15.428s
[2017-09-12 15:58:48] Collecting 3 artifacts from http://download.eclipse.org/releases/oxygen/201706281000
[2017-09-12 15:59:03] Downloading org.eclipse.rcp_root
[2017-09-12 15:59:03] Downloading org.eclipse.platform_root
[2017-09-12 15:59:03] Downloading org.eclipse.platform.ide.executable.win32.win32.x86_64
[2017-09-12 15:59:03] Collected 3 artifacts for http://download.eclipse.org/releases/oxygen/201706281000 in 15.355s
[2017-09-12 15:59:05] An error was detected while performing the engine operation and the changes are being rolled back. See the log for details.
[2017-09-12 15:59:05] ERROR: org.eclipse.equinox.p2.engine code=4 An error occurred during the org.eclipse.equi
at org.eclipse.oomph.util.OomphPlugin.coreException(OomphPlugin.java:280)
at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl$3.commit(ProfileTransactionImpl.java:547)
at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.commit(ProfileTransactionImpl.java:340)
at org.eclipse.oomph.setup.p2.impl.P2TaskImpl.perform(P2TaskImpl.java:729)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:3324)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:3252)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:3233)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:3133)
at org.eclipse.oomph.setup.internal.installer.SimpleVariablePage.installPerform(SimpleVariablePage.java:1289)
at org.eclipse.oomph.setup.internal.installer.SimpleVariablePage.access$32(SimpleVariablePage.java:1166)
at org.eclipse.oomph.setup.internal.installer.SimpleVariablePage$20.run(SimpleVariablePage.java:1111)
ERROR: org.eclipse.equinox.p2.engine code=0 session context was:(profile=C__Users_Corina_eclipse_java-oxygen9_eclipse, phase=org.eclipse.equinox.internal.p2.engine.phases.CheckTrust, operand=, action=).
ERROR: org.eclipse.equinox.p2.engine code=0 Error reading signed content.
java.util.zip.ZipException: Exception in opening zip file: C:\Users\Corina\.p2\pool\plugins\org.eclipse.oomph.setup.doc_1.9.0.v20170706-0615.jar
at org.eclipse.osgi.framework.util.SecureAction.getZipFile(SecureAction.java:317)
at org.eclipse.osgi.internal.signedcontent.SignedBundleHook.getSignedContent(SignedBundleHook.java:212)
at org.eclipse.equinox.internal.p2.engine.phases.CertificateChecker.checkCertificates(CertificateChecker.java:74)
at org.eclipse.equinox.internal.p2.engine.phases.CertificateChecker.start(CertificateChecker.java:55)
at org.eclipse.equinox.internal.p2.engine.phases.CheckTrust.completePhase(CheckTrust.java:52)
at org.eclipse.equinox.internal.p2.engine.Phase.postPerform(Phase.java:252)
at org.eclipse.equinox.internal.p2.engine.Phase.perform(Phase.java:102)
at org.eclipse.equinox.internal.p2.engine.PhaseSet.perform(PhaseSet.java:47)
at org.eclipse.equinox.internal.p2.engine.Engine.perform(Engine.java:77)
at org.eclipse.equinox.internal.p2.engine.Engine.perform(Engine.java:45)
at org.eclipse.equinox.internal.provisional.p2.director.PlanExecutionHelper.executePlan(PlanExecutionHelper.java:42)
at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl$3.commit(ProfileTransactionImpl.java:543)
at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.commit(ProfileTransactionImpl.java:340)
at org.eclipse.oomph.setup.p2.impl.P2TaskImpl.perform(P2TaskImpl.java:729)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:3324)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:3252)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:3233)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:3133)
at org.eclipse.oomph.setup.internal.installer.SimpleVariablePage.installPerform(SimpleVariablePage.java:1289)
at org.eclipse.oomph.setup.internal.installer.SimpleVariablePage.access$32(SimpleVariablePage.java:1166)
at org.eclipse.oomph.setup.internal.installer.SimpleVariablePage$20.run(SimpleVariablePage.java:1111)
Caused by: java.util.zip.ZipException: error in opening zip file
at java.util.zip.ZipFile.open(Native Method)
at java.util.zip.ZipFile.<init>(Unknown Source)
at java.util.zip.ZipFile.<init>(Unknown Source)
at java.util.zip.ZipFile.<init>(Unknown Source)
at org.eclipse.osgi.framework.util.SecureAction.getZipFile(SecureAction.java:304)
at org.eclipse.osgi.internal.signedcontent.SignedBundleHook.getSignedContent(SignedBundleHook.java:212)
at org.eclipse.equinox.internal.p2.engine.phases.CertificateChecker.checkCertificates(CertificateChecker.java:74)
at org.eclipse.equinox.internal.p2.engine.phases.CertificateChecker.start(CertificateChecker.java:55)
at org.eclipse.equinox.internal.p2.engine.phases.CheckTrust.completePhase(CheckTrust.java:52)
at org.eclipse.equinox.internal.p2.engine.Phase.postPerform(Phase.java:252)
at org.eclipse.equinox.internal.p2.engine.Phase.perform(Phase.java:102)
at org.eclipse.equinox.internal.p2.engine.PhaseSet.perform(PhaseSet.java:47)
at org.eclipse.equinox.internal.p2.engine.Engine.perform(Engine.java:77)
at org.eclipse.equinox.internal.p2.engine.Engine.perform(Engine.java:45)
at org.eclipse.equinox.internal.provisional.p2.director.PlanExecutionHelper.executePlan(PlanExecutionHelper.java:42)
at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl$3.commit(ProfileTransactionImpl.java:543)
at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.commit(ProfileTransactionImpl.java:340)
at org.eclipse.oomph.setup.p2.impl.P2TaskImpl.perform(P2TaskImpl.java:729)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:3324)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:3252)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:3233)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:3133)
at org.eclipse.oomph.setup.internal.installer.SimpleVariablePage.installPerform(SimpleVariablePage.java:1289)
at org.eclipse.oomph.setup.internal.installer.SimpleVariablePage.access$32(SimpleVariablePage.java:1166)
... 1 more

[2017-09-12 15:59:05]
Re: Eclipse IDE for Java Installers issue won't download [message #1772741 is a reply to message #1772596] Thu, 14 September 2017 15:03 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 29539
Registered: July 2009
Senior Member
Does C:\Users\Corina\.p2\pool\plugins\org.eclipse.oomph.setup.doc_1.9.0.v20170706-0615.jar exist in your file system? Are you able to open it and look at the contents? (I.e., it's not corrupt in some way?)

It sounds like perhaps it's downloaded a bad artifact from a bad mirror. In the installer you could try Bundle Pools... in the menu, use Analyze Agent... to see if it detects any bad artifacts in the pool which you can then repair with that dialog.
Previous Topic:Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved a
Next Topic:What Oomph features include Updater and Authoring Tool?
Goto Forum:
  


Current Time: Thu Sep 20 18:01:07 GMT 2018

Powered by FUDForum. Page generated in 0.01289 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top