Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » Can't install new Eclipse using Oomph(Installation shows errors during the operation)
Can't install new Eclipse using Oomph [message #1772075] Tue, 05 September 2017 09:51 Go to next message
med medin is currently offline med medinFriend
Messages: 7
Registered: April 2017
Junior Member
It has been 3 day and I'm trying to install Eclipse using Oomph, and it always gives me the follwing error:
[2017-09-05 10:39:20] Executing bootstrap tasks
[2017-09-05 10:39:20] OpenJDK Runtime Environment 1.8.0_131-8u131-b11-2ubuntu1.16.04.3-b11
[2017-09-05 10:39:20] Product org.eclipse.products.epp.package.java.latest
[2017-09-05 10:39:20] Bundle org.eclipse.oomph.setup 1.8.0.v20170408-0745, build=3025, branch=9c793033181f462770594c3bc61db1a4678f8a63
[2017-09-05 10:39:20] Bundle org.eclipse.oomph.setup.core 1.8.0.v20170531-0903, build=3044, branch=2161405b80cf99ed791602ba56cdf44084f5ca43
[2017-09-05 10:39:20] Bundle org.eclipse.oomph.setup.p2 1.8.0.v20170318-0419, build=3025, branch=9c793033181f462770594c3bc61db1a4678f8a63
[2017-09-05 10:39:20] Performing P2 Director (Eclipse IDE for Java Developers (Oxygen))
[2017-09-05 10:39:20] Offline = false
[2017-09-05 10:39:20] Mirrors = true
[2017-09-05 10:39:20] Resolving 24 requirements from 3 repositories to /mnt/989A18F59A18D19C/eclipse/EclipseJSEOxygenLatest/IDE/eclipse
[2017-09-05 10:39:20] Requirement epp.package.java [4.7.0,5.0.0)
[2017-09-05 10:39:20] Requirement org.eclipse.platform.feature.group [4.7.0,5.0.0)
[2017-09-05 10:39:20] Requirement org.eclipse.rcp.feature.group [4.7.0,5.0.0)
[2017-09-05 10:39:20] Requirement org.eclipse.buildship.feature.group
[2017-09-05 10:39:20] Requirement org.eclipse.eclemma.feature.feature.group
[2017-09-05 10:39:20] Requirement org.eclipse.egit.feature.group
[2017-09-05 10:39:20] Requirement org.eclipse.egit.mylyn.feature.group
[2017-09-05 10:39:20] Requirement org.eclipse.jdt.feature.group
[2017-09-05 10:39:20] Requirement org.eclipse.jgit.feature.group
[2017-09-05 10:39:20] Requirement org.eclipse.m2e.feature.feature.group
[2017-09-05 10:39:20] Requirement org.eclipse.m2e.logback.feature.feature.group
[2017-09-05 10:39:20] Requirement org.eclipse.mylyn.bugzilla_feature.feature.group
[2017-09-05 10:39:20] Requirement org.eclipse.mylyn.context_feature.feature.group
[2017-09-05 10:39:20] Requirement org.eclipse.mylyn.git.feature.group
[2017-09-05 10:39:20] Requirement org.eclipse.mylyn.hudson.feature.group
[2017-09-05 10:39:20] Requirement org.eclipse.mylyn.ide_feature.feature.group
[2017-09-05 10:39:20] Requirement org.eclipse.mylyn.java_feature.feature.group
[2017-09-05 10:39:20] Requirement org.eclipse.mylyn.wikitext_feature.feature.group
[2017-09-05 10:39:20] Requirement org.eclipse.mylyn_feature.feature.group
[2017-09-05 10:39:20] Requirement org.eclipse.recommenders.mylyn.rcp.feature.feature.group
[2017-09-05 10:39:20] Requirement org.eclipse.recommenders.rcp.feature.feature.group
[2017-09-05 10:39:20] Requirement org.eclipse.recommenders.snipmatch.rcp.feature.feature.group
[2017-09-05 10:39:20] Requirement org.eclipse.wst.xml_ui.feature.feature.group
[2017-09-05 10:39:20] Requirement org.eclipse.oomph.setup.feature.group
[2017-09-05 10:39:20] Repository http://download.eclipse.org/technology/epp/packages/oxygen
[2017-09-05 10:39:20] Repository http://download.eclipse.org/releases/oxygen/201706281000
[2017-09-05 10:39:20] Repository http://download.eclipse.org/oomph/updates/milestone/latest
[2017-09-05 10:39:28] Calculating requirements and dependencies.
[2017-09-05 10:39:29] Computing prerequisite plan
[2017-09-05 10:39:35] Collecting 1 artifacts from http://download.eclipse.org/technology/epp/packages/oxygen
[2017-09-05 10:39:37] Downloading epp.package.java.executable.gtk.linux.x86
[2017-09-05 10:39:37] Collected 1 artifacts for http://download.eclipse.org/technology/epp/packages/oxygen in 1.996s
[2017-09-05 10:39:37] Collecting 3 artifacts from http://download.eclipse.org/releases/oxygen/201706281000
[2017-09-05 10:39:38] Downloading org.eclipse.platform_root
[2017-09-05 10:39:38] Downloading org.eclipse.rcp_root
[2017-09-05 10:39:38] Downloading org.eclipse.platform.ide.executable.gtk.linux.x86
[2017-09-05 10:39:38] Collected 3 artifacts for http://download.eclipse.org/releases/oxygen/201706281000 in 0.776s
[2017-09-05 10:42:37] Installing a.jre.javase [1.6.0]
[2017-09-05 10:42:37] Installing ch.qos.logback.classic [1.0.7.v20121108-1250]
[2017-09-05 10:42:38] Installing ch.qos.logback.core [1.0.7.v20121108-1250]
[2017-09-05 10:42:38] Installing ch.qos.logback.slf4j [1.0.7.v201505121915]
[2017-09-05 10:42:38] Installing com.google.gson [2.7.0.v20170129-0911]
[2017-09-05 10:42:38] Installing com.google.guava [15.0.0.v201403281430]
[2017-09-05 10:42:39] Installing com.google.inject [3.0.0.v201312141243]
[2017-09-05 10:42:39] Installing com.google.inject.multibindings [3.0.0.v201402270930]
[2017-09-05 10:42:39] Installing com.gradleware.tooling.client [0.19.0.v20170412105839]
[2017-09-05 10:42:39] Installing com.gradleware.tooling.model [0.19.0.v20170412105839]
[2017-09-05 10:42:39] Installing com.gradleware.tooling.utils [0.19.0.v20170412105839]
[2017-09-05 10:42:39] Installing com.ibm.icu [58.2.0.v20170418-1837]
[2017-09-05 10:42:39] Installing com.jcraft.jsch [0.1.54.v20170116-1932]
[2017-09-05 10:42:39] Installing com.mountainminds.eclemma.core [3.0.0.201706140232]
[2017-09-05 10:42:39] Installing com.sun.el [2.2.0.v201303151357]
[2017-09-05 10:42:39] Installing config.a.jre.javase [1.6.0]
[2017-09-05 10:42:39] Installing epp.package.java [4.7.0.20170620-1800]
[2017-09-05 10:42:39] Installing epp.package.java.executable.gtk.linux.x86 [4.7.0.20170620-1800]
[2017-09-05 10:42:39] An error was detected while performing the engine operation and the changes are being rolled back. See the log for details.
[2017-09-05 10:42:39] ERROR: org.eclipse.equinox.p2.engine code=4 An error occurred while installing the items
  at org.eclipse.oomph.util.OomphPlugin.coreException(OomphPlugin.java:280)
  at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl$3.commit(ProfileTransactionImpl.java:547)
  at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.commit(ProfileTransactionImpl.java:340)
  at org.eclipse.oomph.setup.p2.impl.P2TaskImpl.perform(P2TaskImpl.java:729)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:3324)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:3252)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:3233)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:3133)
  at org.eclipse.oomph.setup.internal.installer.SimpleVariablePage.installPerform(SimpleVariablePage.java:1289)
  at org.eclipse.oomph.setup.internal.installer.SimpleVariablePage.access$32(SimpleVariablePage.java:1166)
  at org.eclipse.oomph.setup.internal.installer.SimpleVariablePage$20.run(SimpleVariablePage.java:1111)
  ERROR: org.eclipse.equinox.p2.engine code=0 session context was:(profile=_mnt_989A18F59A18D19C_eclipse_EclipseJSEOxygenLatest_IDE_eclipse, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]epp.package.java.executable.gtk.linux.x86 4.7.0.20170620-1800, action=org.eclipse.equinox.internal.p2.touchpoint.natives.actions.UnzipAction).
  ERROR: org.eclipse.equinox.p2.touchpoint.natives code=0 The artifact for binary,epp.package.java.executable.gtk.linux.x86,4.7.0.20170620-1800 is not available.

[2017-09-05 10:42:39] 


My settings are:

Eclipse IDE for Java Developers
Version: Oxygen Release (4.7.0)
OS: Linux, v.4.13.0-041300-generic, x86 / gtk 2.24.30

openjdk version "1.8.0_131"
OpenJDK Runtime Environment (build 1.8.0_131-8u131-b11-2ubuntu1.16.04.3-b11)
OpenJDK Server VM (build 25.131-b11, mixed mode)

Eclipse Installer version: 1.7.0 Build 3098

[Updated on: Tue, 05 September 2017 09:56]

Report message to a moderator

Re: Can't install new Eclipse using Oomph [message #1772115 is a reply to message #1772075] Tue, 05 September 2017 16:51 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29538
Registered: July 2009
Senior Member
It sounds like perhaps it's downloaded a bad artifact from a bad mirror. In the installer you could try try Bundle Pools... in the menu, use Analyze Agent... to see if it detects any bad artifacts in the pool which you can then repair with that dialog.
Re: Can't install new Eclipse using Oomph [message #1772134 is a reply to message #1772115] Tue, 05 September 2017 23:21 Go to previous messageGo to next message
med medin is currently offline med medinFriend
Messages: 7
Registered: April 2017
Junior Member
Thanks for your answer, I tried Analyze Agent but it doesn't find any damaged artifacts.
http://imgur.com/download/iwgHQqx
Re: Can't install new Eclipse using Oomph [message #1772144 is a reply to message #1772134] Wed, 06 September 2017 06:12 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29538
Registered: July 2009
Senior Member
Oh yes, this is a special type of artifacts that p2 caches differently. Try deleting ~/.p2/org.eclipse.equinox.p2.core/cache to force it to download a new one. You could also for this artifact in that folder's "binary" subfolder; it's a zip file but without the .zip file extension so you could try unzipping it to see if it's corrupt in some way.
Re: Can't install new Eclipse using Oomph [message #1772162 is a reply to message #1772144] Wed, 06 September 2017 08:46 Go to previous messageGo to next message
med medin is currently offline med medinFriend
Messages: 7
Registered: April 2017
Junior Member
Thanks really for your great help, I really love Oomph and how it makes my IDEs installation to small sizes by sharing common libraries, like you said I found inside ~/.p2/org.eclipse.equinox.p2.core/cache/binary one file called org.eclipse.cdt_root_9.3.0.201707130901 I deleted it and relaunched the installation again and now everything works perfectly. Thanks really I couldn't have solve it without you.
Re: Can't install new Eclipse using Oomph [message #1772167 is a reply to message #1772162] Wed, 06 September 2017 09:12 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 29538
Registered: July 2009
Senior Member
Sorry you ran into this problem. I opened https://bugs.eclipse.org/bugs/show_bug.cgi?id=521913 to see if we could do a better job finding/fixing such an error.
Previous Topic:Don't see "Setup Project Model" for oomph
Next Topic:Eclipse Installer couldn't complete the profile generation
Goto Forum:
  


Current Time: Wed Sep 19 22:37:23 GMT 2018

Powered by FUDForum. Page generated in 0.02031 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top