Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Eclipse Oxygen - Debugging Issue
Eclipse Oxygen - Debugging Issue [message #1772065] Tue, 05 September 2017 07:27 Go to next message
Mathias Dolag is currently offline Mathias DolagFriend
Messages: 6
Registered: September 2014
Junior Member
Since updating Eclipse from Neon to Oxygen I've an issue with the "F6 - Step Over" function while debugging my code. Each time I'll use "Step Over" and the current line contains a method call I'll get into the method (behaviour of "F5 - Step Into"). The same behaviour occurs when using the "Step over" - button. After stepping into the method I lost connection (e. g. when using "F6 - Step Over" again) to the debugger and an error occurs: "com.sun.jdi.InternalException: Got an error code in reply:35 occurred creating step request.".

A typical code line which causes the mentioned problem looks like:
Collection<Object> coll = getSomething(...);
...
...
private Collection<Object> getSomething(...) { ... }


The issues occur with a basic installation of "Eclipse for RCP/RAP Developers". No specific debug settings were made.
Does anyone have the same issue and can give me a hint how to solve this?
Re: Eclipse Oxygen - Debugging Issue [message #1772739 is a reply to message #1772065] Thu, 14 September 2017 14:11 Go to previous messageGo to next message
Florian Dunz is currently offline Florian DunzFriend
Messages: 4
Registered: August 2014
Junior Member
I've got the exact same issue and behaviour. Anyone got any idea why this is happening? Did you maybe fix it somehow?
Re: Eclipse Oxygen - Debugging Issue [message #1774552 is a reply to message #1772739] Tue, 17 October 2017 07:13 Go to previous messageGo to next message
Hans-Peter Lackner is currently offline Hans-Peter LacknerFriend
Messages: 1
Registered: October 2017
Junior Member
I had the exact same problem and found the solution...

go to Window - Preferences - Java - Debug and disable "Show method result after a step operation (if supported by the VM; may be slow"
Re: Eclipse Oxygen - Debugging Issue [message #1776150 is a reply to message #1774552] Mon, 13 November 2017 08:32 Go to previous messageGo to next message
Eclipse UserFriend
I had the exact same problem and found an answer to your question:

On the page https://www.eclipse.org/eclipse/news/4.7/jdt.php#step-show-methodresult they introduced this new feature. If you disable it, Step Over will work as always ;-)

go to Window - Preferences - Java - Debug and disable "Show method result after a step operation (if supported by the VM; may be slow"

[Updated on: Mon, 13 November 2017 08:33] by Moderator

Report message to a moderator

Re: Eclipse Oxygen - Debugging Issue [message #1778475 is a reply to message #1772065] Thu, 14 December 2017 16:12 Go to previous message
Mathias Dolag is currently offline Mathias DolagFriend
Messages: 6
Registered: September 2014
Junior Member
Thanks. Removing this setting has solved the problem.

Maybe it's interesting that this problem only occurred while doing "remote debugging". I forgot to mention this in my original post.
Previous Topic:Why jdt has no PDOM structure like cdt?
Next Topic:Detail Formatter null value
Goto Forum:
  


Current Time: Sun Dec 17 11:45:24 GMT 2017

Powered by FUDForum. Page generated in 0.01553 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software