Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Sirius » Drag and Drop Configuration(Container Drop is working unexpected)
Drag and Drop Configuration [message #1772064] Tue, 05 September 2017 07:20 Go to next message
tuki tuk is currently offline tuki tukFriend
Messages: 3
Registered: September 2017
Junior Member
Hi,

I have some trouble with the Container Drop in Sirius. In my Project is a Container C1 that contains sub nodes and I also have another Container C2 that contains two more Containers with Subnodes. What I want is the following: I wish to drag an subnode from C1 to drop it in a Container in C2. I configured the Container Drop, but it doesnt work. If I drag an subnode the cursor shows the "forbidden icon". Iam sure that I configured the Container Drop correct, because now it is possible to drag the subnodes (C1) from a list in the the Model Explorer and drop them in the Contrainer in C2. But thats not exacly what I expected.

Has somebody experience with this behavior of sirius?

best regards
Re: Drag and Drop Configuration [message #1772269 is a reply to message #1772064] Thu, 07 September 2017 09:50 Go to previous messageGo to next message
Steve Monnier is currently offline Steve MonnierFriend
Messages: 470
Registered: May 2011
Senior Member
Hello,

Can you check on your drop tool, tab General, how is set the "Drag Source" field. It looks like you set it in "Model" mode instead of "Representation" (or "Both" if you still want the drop tool to work from the Model Explorer view).

Regards,
Steve


Steve Monnier - Obeo
Need training or professional services for Sirius?
http://www.obeodesigner.com/sirius
Re: Drag and Drop Configuration [message #1772534 is a reply to message #1772269] Tue, 12 September 2017 06:19 Go to previous messageGo to next message
tuki tuk is currently offline tuki tukFriend
Messages: 3
Registered: September 2017
Junior Member
Hi,

Thanks for the reply,
I allready have the "Drag Source" set to "Both". When I set the "Drag Source" to "Representation" then nothing happens (in my editor its called "Diagram" instead of "Representation").

Best regards.
Re: Drag and Drop Configuration [message #1772619 is a reply to message #1772534] Wed, 13 September 2017 08:02 Go to previous messageGo to next message
Pierre-Charles David is currently offline Pierre-Charles DavidFriend
Messages: 523
Registered: July 2009
Senior Member
Hi,

it's difficult to know without more details, but typical problems with Drop Tool configuration that you could look at:
* the "Mappings" attribute of the tool missing the type of element you try to drag (it should include all the mappings you want to be able to drag into the container);
* a precondition that is too restrictive and does not accept the type you try to drag.

Regards,
Pierre-Charles


Pierre-Charles David - Obeo

Need training or professional services for Sirius?
http://www.obeodesigner.com/sirius
Re: Drag and Drop Configuration [message #1773317 is a reply to message #1772619] Tue, 26 September 2017 12:40 Go to previous message
tuki tuk is currently offline tuki tukFriend
Messages: 3
Registered: September 2017
Junior Member
Hi,

sorry in the last days I wasnt at work. I think my Mappings and Precondition is correct configured. Because the Drag & Drop from the Model is working. Thats the point I dont understandm why is Drag & Drop from the Model working and from the Diagram not... (Drag Source is Both).
I dont now which informations could be helpful. Iam not allowed to share informations froms the project.

Regards,
tuki
Previous Topic:How to control the elements in a fragment
Next Topic:Removing JPG and BMP option from sceen capture for CentOS 6.7
Goto Forum:
  


Current Time: Fri Apr 10 20:26:30 GMT 2020

Powered by FUDForum. Page generated in 0.06553 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top