Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Argument specification modifies dashes
Argument specification modifies dashes [message #1771098] Mon, 21 August 2017 21:23 Go to next message
Ken Roser is currently offline Ken RoserFriend
Messages: 15
Registered: June 2014
Junior Member
Since Oxygen, the dialog box that's used to specify program arguments is converting a dash,dash (--) to a unicode character with the value 9480. This character looks like a long dash.

This is what I type: --
It changes to: --

Is this a bug, or just me not correctly using some new feature?
Re: Argument specification modifies dashes [message #1771099 is a reply to message #1771098] Mon, 21 August 2017 21:24 Go to previous messageGo to next message
Ken Roser is currently offline Ken RoserFriend
Messages: 15
Registered: June 2014
Junior Member
This forum did just the opposite of what Eclipse is doing. I entered the unicode character and it mapped it back to two dashes where I said "It changes to:"
Re: Argument specification modifies dashes [message #1771171 is a reply to message #1771099] Tue, 22 August 2017 15:41 Go to previous messageGo to next message
Jonah Graham is currently offline Jonah GrahamFriend
Messages: 397
Registered: June 2014
Senior Member
Hi Ken,

I can't reproduce this problem. Just to confirm, is the dialog you are referring to the one in the Debug Launch Configuration in the Arguments tab?

Can you provide more details so I can reproduce? What platform are you running on (Windows/Linux/etc), are there are typing tools installed, which language are you typing in?

Thanks.
Jonah
Re: Argument specification modifies dashes [message #1771184 is a reply to message #1771171] Tue, 22 August 2017 16:56 Go to previous messageGo to next message
Ken Roser is currently offline Ken RoserFriend
Messages: 15
Registered: June 2014
Junior Member
Jonah,
Yes it is that Arguments tab. I just did some testing and find that it's a problem on the Mac but not on Linux.
The language is English and there are no typing tools installed.
It acts like auto-correct does in Microsoft Word. After I type the two dashes you see them get replaced with that unicode character.

[Updated on: Tue, 22 August 2017 19:41]

Report message to a moderator

Re: Argument specification modifies dashes [message #1773123 is a reply to message #1771184] Thu, 21 September 2017 21:18 Go to previous message
Ken Roser is currently offline Ken RoserFriend
Messages: 15
Registered: June 2014
Junior Member
Since no one on this BB could help, I entered a bug on the issue, https://bugs.eclipse.org/bugs/show_bug.cgi?id=522539
Previous Topic:renaming files in project
Next Topic:Coding rules/quality indicators plugins
Goto Forum:
  


Current Time: Mon Dec 11 04:03:59 GMT 2017

Powered by FUDForum. Page generated in 0.01468 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software