Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Neon 2 uninstall. How ?
Neon 2 uninstall. How ? [message #1770021] Mon, 07 August 2017 14:55 Go to next message
fech orama is currently offline fech oramaFriend
Messages: 3
Registered: August 2017
Junior Member
IH

I have a Neon.2 installation on Fedora 26.

I can use an Eclipe V4.7 with an unzip download. So without setup.
But I can't have the menu in french.
I have a version conflict.

The Neon.2 was setup it's a long time. So, is it possible to upgrade (for uninstall) and if, how ?
I try to delete directory .pid and .eclipse like I see on the web but not working. The Neon stay alive, and start again. The shortcut stay.

Initialy, (start of problem) I have 3 versions at the same time on my computer.
A standard Eclipse
A php Eclipe
and an other for java that was unzip.

Now, I keep the java version, and the standard was uninstall.
But the php (so Neon) staying alive... U U U.... :-)

Someone with a solution to try ?

Tx
Re: Neon 2 uninstall. How ? [message #1770159 is a reply to message #1770021] Tue, 08 August 2017 17:24 Go to previous messageGo to next message
Stephan Herrmann is currently offline Stephan HerrmannFriend
Messages: 1527
Registered: July 2009
Senior Member
Regarding translations for Oxygen, it seems that Babel (the translation project) is just in their phase of release candidates, see http://build.eclipse.org/technology/babel/babel_language_packs/RC1/. Additionally see https://www.eclipse.org/babel/downloads.php for general instructions.

Upgrading Neon to Oxygen should generally not be a problem, after entering the software site http://download.eclipse.org/releases/oxygen check for updates should propose what you are looking for.

Removing an unwanted version of Eclipse is in many cases as simply as removing the "eclipse" folder. If your installation is different, we'd need to know how exactly Eclipse was installed on your machine, before we can comment on your version problem.
Re: Neon 2 uninstall. How ? [message #1770170 is a reply to message #1770159] Tue, 08 August 2017 19:40 Go to previous messageGo to next message
fech orama is currently offline fech oramaFriend
Messages: 3
Registered: August 2017
Junior Member
this is from
/opt/eclipse-php

Pearaps also
.pid
on my personal directory

this is the .ini
-startup
plugins/org.eclipse.equinox.launcher_1.3.201.v20161025-1711.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.401.v20161122-1740
-product
org.eclipse.epp.package.php.product
--launcher.defaultAction
openFile
-showsplash
org.eclipse.platform
--launcher.defaultAction
openFile
--launcher.appendVmargs
-vmargs
-Dosgi.requiredJavaVersion=1.8
-XX:+UseG1GC
-XX:+UseStringDeduplication
-Dosgi.requiredJavaVersion=1.8
-Xms256m
-Xmx1024m

Re: Neon 2 uninstall. How ? [message #1770171 is a reply to message #1770170] Tue, 08 August 2017 19:50 Go to previous messageGo to next message
Stephan Herrmann is currently offline Stephan HerrmannFriend
Messages: 1527
Registered: July 2009
Senior Member
Thanks for providing more details, but it doesn't tell us, how you installed Eclipse. Some questions: downloaded as zip or installed using the Installer (aka Oomph)? Installed with user permission are admin permissions? Into a private / shared location?

My only guess is, that removing /opt/eclipse-php would remove Eclipse Neon (if that is what you want). But then I don't even know if /opt/eclipse-php is a real directory or a soft link. Etc.

I have no idea what .pid is all about. During installing hundreds of Eclipse installations, I never saw that, so not sure how that would be related.
Re: Neon 2 uninstall. How ? [message #1770174 is a reply to message #1770171] Tue, 08 August 2017 20:47 Go to previous message
fech orama is currently offline fech oramaFriend
Messages: 3
Registered: August 2017
Junior Member
So, I have download an archive installer.
I untar and after I setup.
I have always the untar hierarchy of files.
Inside there is a pid directory... and other of course.

So, the setup was with eclipse-inst

The ini with is :
-startup
plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.500.v20170531-1133
--launcher.appendVmargs
--launcher.XXMaxPermSize
256M
-name
Eclipse Installer
-data
@noDefault
--launcher.GTK_version
2
-vmargs
-Xms256M
-Xmx1024M

There is a config.ini in configuration directory:
#This configuration file was written by: org.eclipse.oomph.extractor.lib.PropertiesUpdater
#Wed Jun 14 02:42:31 EDT 2017
ds.delayed.keepInstances=true
oomph.setup.product.filter=(?\!org\\.eclipse\\.products\\.org\\.eclipse\\.platform\\.ide).*
osgi.bundles=reference\:file\:org.eclipse.equinox.simpleconfigurator_1.2.0.v20170110-1705.jar@1\:start
eclipse.application=org.eclipse.oomph.setup.installer.application
eclipse.p2.max.threads=10
eclipse.p2.profile=DefaultProfile
osgi.framework.extensions=reference\:file\:org.eclipse.osgi.compatibility.state_1.1.0.v20170516-1513.jar
org.eclipse.update.reconcile=false
osgi.bundles.defaultStartLevel=4
osgi.framework=file\:plugins/org.eclipse.osgi_3.12.0.v20170512-1932.jar
eclipse.product=org.eclipse.oomph.setup.installer.product
org.eclipse.equinox.simpleconfigurator.configUrl=file\:org.eclipse.equinox.simpleconfigurator/bundles.info
osgi.splashPath=platform\:/base/plugins/org.eclipse.oomph.setup.installer
p2.userAgent=eclipse/oomph/installer
oomph.setup.jre.choice=false
oomph.setup.product.version.filter=.*\\.oxygen
equinox.use.ds=true
oomph.setup.product.catalog.filter=org\\.eclipse\\.products
eclipse.p2.data.area=@config.dir/../p2
osgi.requiredJavaVersion=1.8

If the setup is with ./eclipse-inst
pearaps there is an option to remove ?? like ./eclipse-inst -r ...... or not :-)
yes ? no ?
Previous Topic:IntStream flagged as potential resource leak
Next Topic:Custom Annotation Processor message warning not showing in Eclipse 4.6.3
Goto Forum:
  


Current Time: Thu Dec 14 08:19:36 GMT 2017

Powered by FUDForum. Page generated in 0.01827 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software