Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » 4DIAC - Framework for Distributed Industrial Automation and Control » error at Building Forte (Error at compiling )
error at Building Forte [message #1769997] Mon, 07 August 2017 12:10 Go to next message
Fei  Yin is currently offline Fei YinFriend
Messages: 36
Registered: July 2017
Member
hello guys,
i met some error at compiling Forte, for example c1021, e0020. Have you a idea to solve this error.
  • Attachment: Fehler6.PNG
    (Size: 48.47KB, Downloaded 45 times)
Re: error at Building Forte [message #1769999 is a reply to message #1769997] Mon, 07 August 2017 12:15 Go to previous messageGo to next message
Martin Melik-Merkumians is currently offline Martin Melik-MerkumiansFriend
Messages: 47
Registered: March 2016
Member
For E0020 I would need to see the exported code.

For C1021: The Visual Studio C++ compiler does not know the #error preprocessor command, which is exported by the 4diac-IDE C++ exporter.

VS uses #pragma error(message)

But, as I just see that you exported SERVER_1_2, this is not necessary, as there is a generic implementation for SERVER FBs which relies on the naming convention of SERVER FB Type names to instantiate the correct SERVER FB.

So the best solution for you is to delete the exported SERVER_1_2.cpp and .h files, as you do not need them.

FORTE will create the correct implementation on deployment

Best,
Martin
Re: error at Building Forte [message #1770000 is a reply to message #1769999] Mon, 07 August 2017 12:23 Go to previous messageGo to next message
Fei  Yin is currently offline Fei YinFriend
Messages: 36
Registered: July 2017
Member
thank you for your answer, in attachment you can see this code or e2020.
Re: error at Building Forte [message #1770005 is a reply to message #1770000] Mon, 07 August 2017 13:20 Go to previous messageGo to next message
Alois Zoitl is currently offline Alois ZoitlFriend
Messages: 644
Registered: January 2014
Senior Member
As Martin said Server_1_2 is already in FORTE. If you want to test how to implement Service Interface FBs, please note that we are on purpose generating code that will lead to compile errors. The places with the #error lines is the place where you need to place your SIFB specific code.
Re: error at Building Forte [message #1770084 is a reply to message #1770005] Tue, 08 August 2017 08:49 Go to previous messageGo to next message
Fei  Yin is currently offline Fei YinFriend
Messages: 36
Registered: July 2017
Member
hello, i have compiled successful the forte, but i can not deploy my 4diac programm in 4diac and it is Connection refused. the forte seem to work not. You can see this in attachment.
  • Attachment: fehler3.PNG
    (Size: 15.15KB, Downloaded 52 times)
Re: error at Building Forte [message #1770086 is a reply to message #1770084] Tue, 08 August 2017 08:58 Go to previous messageGo to next message
Alois Zoitl is currently offline Alois ZoitlFriend
Messages: 644
Registered: January 2014
Senior Member
Normally if you get the bind filed error it means that you have already a forte or an other programm running which is using the port 61499. Can you check that no other fortes are running?
Re: error at Building Forte [message #1770087 is a reply to message #1770086] Tue, 08 August 2017 09:03 Go to previous messageGo to next message
Fei  Yin is currently offline Fei YinFriend
Messages: 36
Registered: July 2017
Member
no, i see the Task Manager and it has not another Fore running. And i closed the Forte and open again the Forte,but it is also the same error.
Re: error at Building Forte [message #1770090 is a reply to message #1770087] Tue, 08 August 2017 09:11 Go to previous messageGo to next message
Martin Melik-Merkumians is currently offline Martin Melik-MerkumiansFriend
Messages: 47
Registered: March 2016
Member
I had the same problem with Windows, it seems that some service is using the 61499 port. Please provide a different port via the -c <IP>:<Port> option
Re: error at Building Forte [message #1770091 is a reply to message #1770090] Tue, 08 August 2017 09:13 Go to previous messageGo to next message
Fei  Yin is currently offline Fei YinFriend
Messages: 36
Registered: July 2017
Member
where can i set this?
Re: error at Building Forte [message #1770093 is a reply to message #1770091] Tue, 08 August 2017 09:23 Go to previous messageGo to next message
Martin Melik-Merkumians is currently offline Martin Melik-MerkumiansFriend
Messages: 47
Registered: March 2016
Member
To be honest, i don't know, otherwise I would have told you which service was the culprit, but a little bit of Google research gave the hint.

EDIT: Ah sorry, I misread set for see and though you asked where you can see the other service.

You set the option at startup with forte so e.g., forte -c localhost:12345

[Updated on: Tue, 08 August 2017 09:43]

Report message to a moderator

Re: error at Building Forte [message #1770125 is a reply to message #1770093] Tue, 08 August 2017 14:12 Go to previous message
Jose Maria Jesus Cabral Lassalle is currently offline Jose Maria Jesus Cabral LassalleFriend
Messages: 103
Registered: February 2016
Senior Member
If you still have the binding problem, see this https://www.eclipse.org/forums/index.php?t=msg&th=1074591&goto=1723977&#msg_1723977
Previous Topic:deploy error
Next Topic:Integration of open62541 in FORTE 1.6.2 version
Goto Forum:
  


Current Time: Mon Oct 15 15:07:49 GMT 2018

Powered by FUDForum. Page generated in 0.02328 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top